aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /multimedia
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dragon/Makefile2
-rw-r--r--multimedia/kdemultimedia4-ffmpegthumbs/Makefile2
-rw-r--r--multimedia/kdemultimedia4-mplayerthumbs/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/multimedia/dragon/Makefile b/multimedia/dragon/Makefile
index 9fd635aed18e..0b6a676f664e 100644
--- a/multimedia/dragon/Makefile
+++ b/multimedia/dragon/Makefile
@@ -18,7 +18,7 @@ LATEST_LINK= kdemultimedia-dragon
CONFLICTS_INSTALL= kdemultimedia-4.[1-8].*
MAKE_JOBS_SAFE= yes
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= dbus phonon \
moc_build qmake_build rcc_build uic_build
diff --git a/multimedia/kdemultimedia4-ffmpegthumbs/Makefile b/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
index 9cc579442984..2bdbd2efbaab 100644
--- a/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
+++ b/multimedia/kdemultimedia4-ffmpegthumbs/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= swscale.1:${PORTSDIR}/multimedia/ffmpeg
CONFLICTS_INSTALL= kdemultimedia-4.[1-8].*
MAKE_JOBS_SAFE= yes
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
diff --git a/multimedia/kdemultimedia4-mplayerthumbs/Makefile b/multimedia/kdemultimedia4-mplayerthumbs/Makefile
index c8fe86caa45f..40cea73adda5 100644
--- a/multimedia/kdemultimedia4-mplayerthumbs/Makefile
+++ b/multimedia/kdemultimedia4-mplayerthumbs/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
CONFLICTS_INSTALL= kdemultimedia-4.[1-8].*
MAKE_JOBS_SAFE= yes
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= phonon moc_build qmake_build rcc_build uic_build
USE_XZ= yes