aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-09-01 17:46:27 +0800
committeravilla <avilla@FreeBSD.org>2012-09-01 17:46:27 +0800
commit15d0d07ec8a020ac680817896d50a2c2f7b85b71 (patch)
treec6d15bb8f22bced313bade52d4b89315428ebe84 /multimedia
parent14b5716860f3b2e2a8e07b03a00f90fff80b9bdf (diff)
downloadfreebsd-ports-gnome-15d0d07ec8a020ac680817896d50a2c2f7b85b71.tar.gz
freebsd-ports-gnome-15d0d07ec8a020ac680817896d50a2c2f7b85b71.tar.zst
freebsd-ports-gnome-15d0d07ec8a020ac680817896d50a2c2f7b85b71.zip
- Update to 0.8.2.
- Fix COMMENT (mlt is no server). - OPTIONSngify and improve descriptions. - Move demo/ to PORTEXAMPLES. - Move melt.1 to MAN1. - Remove header from Makefile.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mlt/Makefile120
-rw-r--r--multimedia/mlt/distinfo4
-rw-r--r--multimedia/mlt/pkg-plist47
3 files changed, 106 insertions, 65 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index aa85a95d7d29..f84620ce786d 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -1,23 +1,18 @@
-# New ports collection makefile for: mlt
-# Date created: 7 October 2008
-# Whom: Alberto Villa <villa.alberto@gmail.com>
-#
# $FreeBSD$
PORTNAME= mlt
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.2
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= avilla@FreeBSD.org
-COMMENT= Multimedia framework and video playout server for TV broadcasting
+COMMENT= Multimedia framework for TV broadcasting
-LICENSE= LGPL21 GPLv2 GPLv3
+LICENSE= GPLv2 GPLv3 LGPL21
LICENSE_COMB= multi
-LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING
LICENSE_FILE_GPLv2= ${WRKSRC}/GPL
LICENSE_FILE_GPLv3= ${WRKSRC}/GPLv3
+LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -25,46 +20,44 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
CONFLICTS_INSTALL= freeze-[0-9]*
USE_GNOME= gnomehack libxml2
+USE_PKGCONFIG= build
USE_SDL= image
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gpl --enable-gpl3 --linsys-with-jpeg
USE_GMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include # Frei0r detection.
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-
-# Required at least for frei0r detection.
-CFLAGS+= -I${LOCALBASE}/include
-
-PORTDOCS= AUTHORS ChangeLog NEWS README docs demo
-
-OPTIONS= DV "Quasar DV Codec module" on \
- FFMPEG "Avformat module" on \
- FREI0R "frei0r module" on \
- GTK2 "GTK+ 2 module" on \
- JACK "JACK Rack module" off \
- KINO "Kino module" on \
- QT4 "QImage module" on \
- RESAMPLE "Secret Rabbit Code module" on \
- SOX "Sound eXchange module" on \
- SWFDEC "Swfdec module" on \
- VDPAU "NVIDIA VDPAU support (requires FFMPEG)" off \
- VORBIS "Vorbis module" on
-
.ifndef(WITH_DEBUG)
CONFIGURE_ARGS+= --disable-debug
.else
CONFIGURE_ARGS+= --enable-debug
.endif
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+PORTDOCS= AUTHORS ChangeLog NEWS README docs
+PORTEXAMPLES= demo
+
+MAN1= melt.1
+
+OPTIONS_DEFINE= DV FFMPEG FREI0R GTK2 JACK QT4 QUICKTIME \
+ SAMPLERATE SOX SWFDEC VDPAU VORBIS
+OPTIONS_DEFAULT=DV FFMPEG FREI0R GTK2 QT4 \
+ SAMPLERATE SOX SWFDEC VORBIS
+
+GTK2_DESC= GTK+ 2 support (images, text rendering...)
+QT4_DESC= QImage support (Kdenlive titles, images...)
+SOX_DESC= SoX audio effects support
+
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= does not compile on sparc64 (invokes i386 asm)
.endif
-.ifndef(WITHOUT_DV)
+.if ${PORT_OPTIONS:MDV}
LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv
CONFIGURE_ARGS+= --enable-dv
PLIST_SUB+= DV=""
@@ -73,8 +66,8 @@ CONFIGURE_ARGS+= --disable-dv
PLIST_SUB+= DV="@comment "
.endif
-.if !defined(WITHOUT_FFMPEG) || defined(WITH_VDPAU)
-LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
+.if ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MVDPAU}
+LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-avformat \
--avformat-swscale
PLIST_SUB+= FFMPEG=""
@@ -83,7 +76,7 @@ CONFIGURE_ARGS+= --disable-avformat
PLIST_SUB+= FFMPEG="@comment "
.endif
-.ifndef(WITHOUT_FREI0R)
+.if ${PORT_OPTIONS:MFREI0R}
BUILD_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
CONFIGURE_ARGS+= --enable-frei0r
PLIST_SUB+= FREI0R=""
@@ -92,7 +85,7 @@ CONFIGURE_ARGS+= --disable-frei0r
PLIST_SUB+= FREI0R="@comment "
.endif
-.ifndef(WITHOUT_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
USE_GNOME+= gdkpixbuf2 gtk20 pango
CONFIGURE_ARGS+= --enable-gtk2
@@ -102,7 +95,7 @@ CONFIGURE_ARGS+= --disable-gtk2
PLIST_SUB+= GTK2="@comment "
.endif
-.ifdef(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
CONFIGURE_ARGS+= --enable-jackrack
@@ -112,17 +105,7 @@ CONFIGURE_ARGS+= --disable-jackrack
PLIST_SUB+= JACK="@comment "
.endif
-.ifndef(WITHOUT_KINO)
-LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv \
- quicktime.0:${PORTSDIR}/multimedia/libquicktime
-CONFIGURE_ARGS+= --enable-kino
-PLIST_SUB+= KINO=""
-.else
-CONFIGURE_ARGS+= --disable-kino
-PLIST_SUB+= KINO="@comment "
-.endif
-
-.ifndef(WITHOUT_QT4)
+.if ${PORT_OPTIONS:MQT4}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
USE_QT4+= gui svg xml
CONFIGURE_ARGS+= --enable-qimage \
@@ -134,16 +117,26 @@ CONFIGURE_ARGS+= --disable-qimage
PLIST_SUB+= QT4="@comment "
.endif
-.ifndef(WITHOUT_RESAMPLE)
+.if ${PORT_OPTIONS:MQUICKTIME}
+LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv \
+ quicktime.0:${PORTSDIR}/multimedia/libquicktime
+CONFIGURE_ARGS+= --enable-kino
+PLIST_SUB+= KINO=""
+.else
+CONFIGURE_ARGS+= --disable-kino
+PLIST_SUB+= KINO="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MSAMPLERATE}
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+= --enable-resample
-PLIST_SUB+= RESAMPLE=""
+PLIST_SUB+= SAMPLERATE=""
.else
CONFIGURE_ARGS+= --disable-resample
-PLIST_SUB+= RESAMPLE="@comment "
+PLIST_SUB+= SAMPLERATE="@comment "
.endif
-.ifndef(WITHOUT_SOX)
+.if ${PORT_OPTIONS:MSOX}
LIB_DEPENDS+= sox.1:${PORTSDIR}/audio/sox
CONFIGURE_ARGS+= --enable-sox
PLIST_SUB+= SOX=""
@@ -152,7 +145,7 @@ CONFIGURE_ARGS+= --disable-sox
PLIST_SUB+= SOX="@comment "
.endif
-.ifndef(WITHOUT_SWFDEC)
+.if ${PORT_OPTIONS:MSWFDEC}
LIB_DEPENDS+= swfdec-0.8.0:${PORTSDIR}/graphics/swfdec
CONFIGURE_ARGS+= --enable-swfdec
PLIST_SUB+= SWFDEC=""
@@ -161,14 +154,14 @@ CONFIGURE_ARGS+= --disable-swfdec
PLIST_SUB+= SWFDEC="@comment "
.endif
-.ifdef(WITH_VDPAU)
+.if ${PORT_OPTIONS:MVDPAU}
USE_XORG+= x11
CONFIGURE_ARGS+= --avformat-vdpau
.else
CONFIGURE_ARGS+= --avformat--no-vdpau
.endif
-.ifndef(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --enable-vorbis
PLIST_SUB+= VORBIS=""
@@ -178,25 +171,32 @@ PLIST_SUB+= VORBIS="@comment "
.endif
pre-configure:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/src/modules/avformat/vdpau.c \
${WRKSRC}/src/modules/frei0r/factory.c \
${WRKSRC}/src/modules/jackrack/plugin_mgr.c \
${WRKSRC}/src/modules/linsys/Makefile
- ${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' \
${WRKSRC}/src/framework/Makefile \
${WRKSRC}/src/melt/Makefile \
${WRKSRC}/src/modules/*/Makefile
- ${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,g' \
${WRKSRC}/Makefile
post-install:
-.ifndef(NOPORTDOCS)
-.for f in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/docs/melt.1 ${MANPREFIX}/man/man1/melt.1
+ ${RM} -f ${WRKSRC}/docs/melt.1
+.if ${PORT_OPTIONS:MDOCS}
+. for f in ${PORTDOCS}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${DOCSDIR}
-.endfor
+. endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+. for f in ${PORTEXAMPLES}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${EXAMPLESDIR}
+. endfor
.endif
.include <bsd.port.mk>
diff --git a/multimedia/mlt/distinfo b/multimedia/mlt/distinfo
index 205e93e2098d..691b5b893f44 100644
--- a/multimedia/mlt/distinfo
+++ b/multimedia/mlt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mlt-0.8.0.tar.gz) = 7bd07b392663b33a0408c900117b2e431c93e5f29394578cfbeff7b26a0cc6dd
-SIZE (mlt-0.8.0.tar.gz) = 1143227
+SHA256 (mlt-0.8.2.tar.gz) = 36c743d2abc68ce737ac526507fc2caf71b3d6a53a2bf31d22e8193a8b899577
+SIZE (mlt-0.8.2.tar.gz) = 1161293
diff --git a/multimedia/mlt/pkg-plist b/multimedia/mlt/pkg-plist
index c9abf21e8f0f..1139775e1700 100644
--- a/multimedia/mlt/pkg-plist
+++ b/multimedia/mlt/pkg-plist
@@ -72,7 +72,7 @@ lib/mlt/libmltnormalize.so
lib/mlt/libmltoldfilm.so
lib/mlt/libmltplus.so
%%QT4%%lib/mlt/libmltqimage.so
-%%RESAMPLE%%lib/mlt/libmltresample.so
+%%SAMPLERATE%%lib/mlt/libmltresample.so
lib/mlt/libmltrotoscoping.so
lib/mlt/libmltsdl.so
%%SOX%%lib/mlt/libmltsox.so
@@ -219,7 +219,16 @@ libdata/pkgconfig/mlt-framework.pc
%%DATADIR%%/plus/filter_invert.yml
%%DATADIR%%/plus/filter_sepia.yml
%%DATADIR%%/plus/transition_affine.yml
+%%DATADIR%%/presets/consumer/avformat/AAC
+%%DATADIR%%/presets/consumer/avformat/Flash
+%%DATADIR%%/presets/consumer/avformat/MJPEG
+%%DATADIR%%/presets/consumer/avformat/MP3
+%%DATADIR%%/presets/consumer/avformat/MPEG-2
+%%DATADIR%%/presets/consumer/avformat/MPEG-4
+%%DATADIR%%/presets/consumer/avformat/MPEG-4-ASP
%%DATADIR%%/presets/consumer/avformat/Sony-PSP
+%%DATADIR%%/presets/consumer/avformat/Vorbis
+%%DATADIR%%/presets/consumer/avformat/WAV
%%DATADIR%%/presets/consumer/avformat/XDCAM-HD422
%%DATADIR%%/presets/consumer/avformat/atsc_1080i_50/DNxHD
%%DATADIR%%/presets/consumer/avformat/atsc_1080i_5994/DNxHD
@@ -251,6 +260,28 @@ libdata/pkgconfig/mlt-framework.pc
%%DATADIR%%/presets/consumer/avformat/dv_pal_wide/DV
%%DATADIR%%/presets/consumer/avformat/dv_pal_wide/DVCPRO50
%%DATADIR%%/presets/consumer/avformat/dv_pal_wide/DVD
+%%DATADIR%%/presets/consumer/avformat/hdv_1080_25p/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_1080_30p/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_1080_50i/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_1080_60i/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_720_25p/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_720_30p/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_720_50p/HDV
+%%DATADIR%%/presets/consumer/avformat/hdv_720_60p/HDV
+%%DATADIR%%/presets/consumer/avformat/lossless/FFV1
+%%DATADIR%%/presets/consumer/avformat/lossless/H.264
+%%DATADIR%%/presets/consumer/avformat/lossless/HuffYUV
+%%DATADIR%%/presets/consumer/avformat/lossless/MJPEG
+%%DATADIR%%/presets/consumer/avformat/lossless/MPEG-2
+%%DATADIR%%/presets/consumer/avformat/lossless/MPEG-4
+%%DATADIR%%/presets/consumer/avformat/lossless/ProRes
+%%DATADIR%%/presets/consumer/avformat/stills/BMP
+%%DATADIR%%/presets/consumer/avformat/stills/DPX
+%%DATADIR%%/presets/consumer/avformat/stills/JPEG
+%%DATADIR%%/presets/consumer/avformat/stills/PNG
+%%DATADIR%%/presets/consumer/avformat/stills/PPM
+%%DATADIR%%/presets/consumer/avformat/stills/TGA
+%%DATADIR%%/presets/consumer/avformat/stills/TIFF
%%DATADIR%%/presets/consumer/avformat/webm
%%DATADIR%%/presets/consumer/avformat/x264-medium
%%DATADIR%%/presets/consumer/avformat/x264-medium-baseline
@@ -319,7 +350,7 @@ libdata/pkgconfig/mlt-framework.pc
%%QT4%%%%DATADIR%%/qimage/producer_kdenlivetitle.yml
%%QT4%%%%DATADIR%%/qimage/producer_qimage.yml
%%QT4%%%%DATADIR%%/qimage/transition_vqm.yml
-%%RESAMPLE%%%%DATADIR%%/resample/filter_resample.yml
+%%SAMPLERATE%%%%DATADIR%%/resample/filter_resample.yml
%%DATADIR%%/rotoscoping/filter_rotoscoping.yml
%%DATADIR%%/sdl/consumer_sdl.yml
%%DATADIR%%/sdl/consumer_sdl_audio.yml
@@ -349,12 +380,22 @@ libdata/pkgconfig/mlt-framework.pc
%%SOX%%@dirrm %%DATADIR%%/sox
@dirrm %%DATADIR%%/sdl
@dirrm %%DATADIR%%/rotoscoping
-%%RESAMPLE%%@dirrm %%DATADIR%%/resample
+%%SAMPLERATE%%@dirrm %%DATADIR%%/resample
%%QT4%%@dirrm %%DATADIR%%/qimage
@dirrm %%DATADIR%%/profiles
@dirrm %%DATADIR%%/presets/filter/volume
@dirrm %%DATADIR%%/presets/filter/brightness
@dirrm %%DATADIR%%/presets/filter
+@dirrm %%DATADIR%%/presets/consumer/avformat/stills
+@dirrm %%DATADIR%%/presets/consumer/avformat/lossless
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_720_60p
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_720_50p
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_720_30p
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_720_25p
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_1080_60i
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_1080_50i
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_1080_30p
+@dirrm %%DATADIR%%/presets/consumer/avformat/hdv_1080_25p
@dirrm %%DATADIR%%/presets/consumer/avformat/dv_pal_wide
@dirrm %%DATADIR%%/presets/consumer/avformat/dv_pal
@dirrm %%DATADIR%%/presets/consumer/avformat/dv_ntsc_wide