aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-11-09 22:30:02 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-11-09 22:30:02 +0800
commit1856135f876616142f11dec7e66c5c088c324598 (patch)
treeca64d90fe979fab8f7ed8d1e9bdd41583f1793d9 /multimedia
parent205cc44135bcb305bd243c70b6b574ba71c18b19 (diff)
downloadfreebsd-ports-gnome-1856135f876616142f11dec7e66c5c088c324598.tar.gz
freebsd-ports-gnome-1856135f876616142f11dec7e66c5c088c324598.tar.zst
freebsd-ports-gnome-1856135f876616142f11dec7e66c5c088c324598.zip
Remove support for WANT_SDL/HAVE_SDL knobs
WANT_SDL/HAVE_SDL macros allowed a port to check which SDL components are installed. This goes against the policy of avoiding automatic dependencies, and there are actually no cases in the portstree where these knobs are used properly, so axe them out. Approved by: portmgr (mat) Differential Revision: D4093
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious-plugins/Makefile1
-rw-r--r--multimedia/avidemux/Makefile.common1
-rw-r--r--multimedia/ffmpeg0/Makefile1
-rw-r--r--multimedia/mplayer/Makefile.common1
-rw-r--r--multimedia/transcode/Makefile1
5 files changed, 0 insertions, 5 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index af8519abdaae..72828ca52921 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
USE_GNOME= glib20
-WANT_SDL= yes
OPTIONS_DEFINE= DBUS OSS4 SDLOUT ALSA CUE MP3 STATUSICON AOSD AOSDXCOMP \
ADPLUG VORBIS FLAC WAVPACK AAC SNDFILE MODPLUG JACK \
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 2055ea79a95a..b3f8f1ad3678 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -19,7 +19,6 @@ USE_QT4= # empty
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
USE_SQLITE= yes
-WANT_SDL= yes
USES= cmake:outsource pkgconfig iconv gmake compiler:features
USES+= dos2unix
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake po/CMakeLists.txt
diff --git a/multimedia/ffmpeg0/Makefile b/multimedia/ffmpeg0/Makefile
index 1fa537bc84af..dc5317e3f963 100644
--- a/multimedia/ffmpeg0/Makefile
+++ b/multimedia/ffmpeg0/Makefile
@@ -25,7 +25,6 @@ PORTSCOUT= limit:^0\.7.*
USES= cpe gmake perl5 pkgconfig tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/ffmpeg${FFMPEG_SUFFIX}
USE_PERL5= build
-WANT_SDL= yes
FFMPEG_SUFFIX= 0
HAS_CONFIGURE= yes
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index 00bb5b10fe5b..942f9edf75a9 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -51,4 +51,3 @@ CONFIGURE_ARGS= --cc="${CC}" \
--enable-ass-internal
WANT_GNOME= yes
-WANT_SDL= yes
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 38a44fa337a7..9fc934cc3d24 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
USE_LDCONFIG= yes
USES= gmake libtool pkgconfig tar:bzip2
USE_GCC= any
-WANT_SDL= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oss