aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /multimedia
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux/Makefile.common2
-rw-r--r--multimedia/gstreamer-qt4/Makefile2
-rw-r--r--multimedia/plexhometheater/Makefile2
-rw-r--r--multimedia/zoneminder-h264/Makefile2
-rw-r--r--multimedia/zoneminder/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 16d0c8065624..aaaafef13673 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -19,7 +19,7 @@ USE_QT4= # empty
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
-USES= cmake:outsource pkgconfig iconv gmake compiler:features sqlite
+USES= cmake:outsource,noninja pkgconfig iconv gmake compiler:features sqlite
USES+= dos2unix execinfo
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake \
avidemux_core/ADM_coreVideoCodec/include/ADM_coreVideoCodec6_export.h \
diff --git a/multimedia/gstreamer-qt4/Makefile b/multimedia/gstreamer-qt4/Makefile
index 419335333484..cecaac157033 100644
--- a/multimedia/gstreamer-qt4/Makefile
+++ b/multimedia/gstreamer-qt4/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USES= bison cmake gmake kde:4 pathfix pkgconfig tar:bzip2
+USES= bison cmake:noninja gmake kde:4 pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GSTREAMER= yes
USE_GNOME= glib20
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index af35b2385bbb..b064a59306e0 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -67,7 +67,7 @@ GH_ACCOUNT= plexinc
GH_PROJECT= plex-home-theater-public
BUNDLE_LIBS= yes
-USES= cmake:outsource execinfo gmake iconv:wchar_t jpeg pkgconfig python:2
+USES= cmake:outsource execinfo iconv:wchar_t jpeg pkgconfig python:2
CMAKE_ARGS+= -DENABLE_AUTOUPDATE:BOOL=false
CMAKE_ARGS+= -DENABLE_DUMP_SYMBOLS:BOOL=false
CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=false
diff --git a/multimedia/zoneminder-h264/Makefile b/multimedia/zoneminder-h264/Makefile
index 88d80d02b291..b0c4baf4af76 100644
--- a/multimedia/zoneminder-h264/Makefile
+++ b/multimedia/zoneminder-h264/Makefile
@@ -40,7 +40,7 @@ USE_GITHUB= yes
GH_TUPLE= zoneminder:ZoneMinder:e723b6d \
FriendsOfCake:crud:c3976f1:crud
-USES= cmake jpeg mysql perl5 php shebangfix ssl
+USES= cmake:noninja jpeg mysql perl5 php shebangfix ssl
USE_RC_SUBR= zoneminder
USE_PHP= json pdo_mysql session gd sockets ctype
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index c19ee4de6cb2..cfce739764f2 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -34,7 +34,7 @@ USE_GITHUB= yes
GH_PROJECT= ZoneMinder
GH_TUPLE= FriendsOfCake:crud:c3976f1:crud
-USES= cmake jpeg mysql perl5 php shebangfix ssl
+USES= cmake:noninja jpeg mysql perl5 php shebangfix ssl
USE_RC_SUBR= zoneminder
USE_PHP= json pdo_mysql session gd sockets ctype opcache