aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2013-12-04 10:51:00 +0800
committerjhale <jhale@FreeBSD.org>2013-12-04 10:51:00 +0800
commit481fb7ae25d2cadd7407b763c6fd10f97c884b84 (patch)
tree3dd64f0c809f9e8c1a80871241444471c0db3540 /multimedia
parent80d813445175211c54cb28d2e8fec5b786b625c4 (diff)
downloadfreebsd-ports-gnome-481fb7ae25d2cadd7407b763c6fd10f97c884b84.tar.gz
freebsd-ports-gnome-481fb7ae25d2cadd7407b763c6fd10f97c884b84.tar.zst
freebsd-ports-gnome-481fb7ae25d2cadd7407b763c6fd10f97c884b84.zip
- Update graphics/*opencv* to 2.4.7
- Revert options helpers to if statements since the OFF condition is not applied when OPTIONS_EXCLUDE is used - Move most of the OpenCV modules from the graphics/opencv-core port to graphics/opencv, leaving opencv-core as just the bare minimum required for building ffmpeg with OpenCV support - Install examples for python and java bindings - Add new slave port graphics/opencv-java: Java bindings for OpenCV - Bump PORTREVISION and make dependency adjustments and fixes for dependent ports - Add UPDATING entry
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile1
-rw-r--r--multimedia/ffmpeg0/Makefile1
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common1
-rw-r--r--multimedia/libav/Makefile5
-rw-r--r--multimedia/lives/Makefile1
5 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 278efcccd9ed..3db54e49f56b 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 2.1.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
diff --git a/multimedia/ffmpeg0/Makefile b/multimedia/ffmpeg0/Makefile
index c17f2c2c3149..bd7b3ff55bb7 100644
--- a/multimedia/ffmpeg0/Makefile
+++ b/multimedia/ffmpeg0/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.7.16
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 7d42042acaa2..cc119b87a7ba 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -430,6 +430,7 @@ gst_ogg_DIST= base
# opencv
gst_opencv_LIB_DEPENDS+=libopencv_highgui.so:${PORTSDIR}/graphics/opencv
+gst_opencv_CONFIGURE_ENV+= OPENCV_CFLAGS="-I${LOCALBASE}/include/opencv"
gst_opencv_PLIST_FILES= ${GST_LIB_DIR}/libgstopencv.la \
${GST_LIB_DIR}/libgstopencv.so
gst_opencv_DIST= bad
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index fc70340f44af..935dc237dd1f 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libav
PORTVERSION= 9.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://libav.org/releases/
@@ -89,8 +89,7 @@ JACK_CONFIGURE_ENABLE= indev=jack
LAME_LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame
LAME_CONFIGURE_ENABLE= libmp3lame
-OPENCV_LIB_DEPENDS= libopencv_imgproc.so:${PORTSDIR}/graphics/opencv-core \
- libopencv_gpu.so:${PORTSDIR}/graphics/opencv
+OPENCV_LIB_DEPENDS= libopencv_gpu.so:${PORTSDIR}/graphics/opencv
OPENCV_CONFIGURE_ENABLE= libopencv
OPENJPEG_LIB_DEPENDS= libopenjpeg.so:${PORTSDIR}/graphics/openjpeg
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index dd1d59f1f8fa..b6549b30ead0 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lives
PORTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://salsaman.home.xs4all.nl/lives/current/
DISTNAME= LiVES-${PORTVERSION}