aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-07-15 07:42:13 +0800
committerjbeich <jbeich@FreeBSD.org>2017-07-15 07:42:13 +0800
commit4c16792980456ad76a63a37478309f744a002a15 (patch)
tree4542f6773e8d13f7f86e9955b8fee994b104711b /multimedia
parent89278b594e05c460cb83b24e79a2a9042926655d (diff)
downloadfreebsd-ports-gnome-4c16792980456ad76a63a37478309f744a002a15.tar.gz
freebsd-ports-gnome-4c16792980456ad76a63a37478309f744a002a15.tar.zst
freebsd-ports-gnome-4c16792980456ad76a63a37478309f744a002a15.zip
multimedia/x264: enable FFMS, LAVF, SWSCALE by default
Without FFmpeg-based demuxers x264 CLI can only read raw formats as source. So, enable more options to allow the binary package not only write but also read mp4/mkv. PR: 220694 Approved by: koobs (maintainer) MFH: 2017Q3 (usability improvement) Differential Revision: https://reviews.freebsd.org/D11566
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libx264/Makefile1
-rw-r--r--multimedia/x264/Makefile4
2 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/libx264/Makefile b/multimedia/libx264/Makefile
index 46245f3b5133..1e76c72bb3f3 100644
--- a/multimedia/libx264/Makefile
+++ b/multimedia/libx264/Makefile
@@ -3,6 +3,7 @@
#
# Updating notes: see multimedia/x264/Makefile.
+PORTREVISION= 0
PKGNAMEPREFIX= lib
COMMENT= H.264/MPEG-4 AVC Video Encoding (Library)
MASTERDIR= ${.CURDIR}/../x264
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index c1f0038f882c..e3968bd0599f 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -19,7 +19,7 @@
PORTNAME= x264
PORTVERSION= 0.${X264_BUILD}.${X264_REV}
-PORTREVISION?= 0
+PORTREVISION?= 1 # 0 in libx264
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
@@ -53,7 +53,7 @@ PLIST_FILES?= bin/x264
OPTIONS_DEFINE+= DEBUG FFMS GCC LAVF PGO SWSCALE
OPTIONS_RADIO+= MP4
OPTIONS_RADIO_MP4+= GPAC LSMASH
-OPTIONS_DEFAULT+= LSMASH
+OPTIONS_DEFAULT+= FFMS LAVF LSMASH SWSCALE
FFMS_DESC= FFmpeg Source input support
GPAC_DESC= GPAC library support