aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2009-08-05 20:28:16 +0800
committerkwm <kwm@FreeBSD.org>2009-08-05 20:28:16 +0800
commit538ce077a8c007f80c073816dfd727cd1aee1ef9 (patch)
tree8ac2b8535a5baaca1dd4a7f8e4f01a7f9065aae2 /multimedia
parentf4a311cf539e032c94b886b4780a86f6d9ca6094 (diff)
downloadfreebsd-ports-gnome-538ce077a8c007f80c073816dfd727cd1aee1ef9.tar.gz
freebsd-ports-gnome-538ce077a8c007f80c073816dfd727cd1aee1ef9.tar.zst
freebsd-ports-gnome-538ce077a8c007f80c073816dfd727cd1aee1ef9.zip
Update to 0.10.24.
Changelog: http://gstreamer.freedesktop.org/releases/gstreamer/0.10.24.html Fix argument warnings in gst/gstregister.c while here fix the other one in gstfilesrc. PR: ports/137441 [1] Submitted by: Mark Andrews <marka@isc.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer/Makefile5
-rw-r--r--multimedia/gstreamer/distinfo6
-rw-r--r--multimedia/gstreamer/files/patch-gst_gstregistry.c11
-rw-r--r--multimedia/gstreamer/files/patch-plugins_elements_gstfilesrc.c13
-rw-r--r--multimedia/gstreamer/pkg-plist3
5 files changed, 32 insertions, 6 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index 030ae89fd3be..d1093b081b16 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.10.23
+PORTVERSION= 0.10.24
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/ \
GNOME
@@ -18,7 +18,7 @@ COMMENT= Development framework for creating media applications
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
-CFLAGS:= ${CFLAGS} -O2
+CFLAGS:= ${CFLAGS} -O2 -Wno-format
USE_BISON= build
USE_XORG= x11 xv xext videoproto xextproto
USE_BZIP2= yes
@@ -29,7 +29,6 @@ USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS= --disable-tests \
--disable-examples \
- --disable-docs-build \
--disable-failing-tests \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
diff --git a/multimedia/gstreamer/distinfo b/multimedia/gstreamer/distinfo
index 757121a18093..e9a656fda3fc 100644
--- a/multimedia/gstreamer/distinfo
+++ b/multimedia/gstreamer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gstreamer-0.10.23.tar.bz2) = f7b2e300d2d85756407ec529424ab237
-SHA256 (gstreamer-0.10.23.tar.bz2) = cf750821040102d2c9fbfed56472a86fd0d8c24ada37901c41867c88438a776d
-SIZE (gstreamer-0.10.23.tar.bz2) = 2871267
+MD5 (gstreamer-0.10.24.tar.bz2) = 178d3326c96c360c9a15751bd5d73a6c
+SHA256 (gstreamer-0.10.24.tar.bz2) = ee8e22ff368333e668904133b40622702a1c687872e8ee5e06df9a5aad71963c
+SIZE (gstreamer-0.10.24.tar.bz2) = 2982027
diff --git a/multimedia/gstreamer/files/patch-gst_gstregistry.c b/multimedia/gstreamer/files/patch-gst_gstregistry.c
new file mode 100644
index 000000000000..b2ddff9c7eb6
--- /dev/null
+++ b/multimedia/gstreamer/files/patch-gst_gstregistry.c
@@ -0,0 +1,11 @@
+--- gst/gstregistry.c.orig 2009-07-14 11:54:05.000000000 +0200
++++ gst/gstregistry.c 2009-08-05 14:05:20.000000000 +0200
+@@ -896,7 +896,7 @@ gst_registry_scan_path_level (GstRegistr
+ GST_DEBUG_OBJECT (registry, "mtime %ld != %ld or size %"
+ G_GINT64_FORMAT " != %" G_GINT64_FORMAT " or external dependency "
+ "env_vars changed: %d or external dependencies changed: %d",
+- plugin->file_mtime, file_status.st_mtime,
++ (glong) plugin->file_mtime, (glong) file_status.st_mtime,
+ (gint64) plugin->file_size, (gint64) file_status.st_size,
+ env_vars_changed, deps_changed);
+ gst_registry_remove_plugin (gst_registry_get_default (), plugin);
diff --git a/multimedia/gstreamer/files/patch-plugins_elements_gstfilesrc.c b/multimedia/gstreamer/files/patch-plugins_elements_gstfilesrc.c
new file mode 100644
index 000000000000..b1513ade714c
--- /dev/null
+++ b/multimedia/gstreamer/files/patch-plugins_elements_gstfilesrc.c
@@ -0,0 +1,13 @@
+--- plugins/elements/gstfilesrc.c.orig 2009-07-14 11:54:05.000000000 +0200
++++ plugins/elements/gstfilesrc.c 2009-08-05 09:23:45.000000000 +0200
+@@ -585,8 +585,8 @@ gst_file_src_map_region (GstFileSrc * sr
+
+ g_return_val_if_fail (offset >= 0, NULL);
+
+- GST_LOG_OBJECT (src, "mapping region %08llx+%08lx from file into memory",
+- offset, (gulong) size);
++ GST_LOG_OBJECT (src, "mapping region %08lx+%08lx from file into memory",
++ (gulong) offset, (gulong) size);
+
+ mmapregion = mmap (NULL, size, PROT_READ, MAP_SHARED, src->fd, offset);
+
diff --git a/multimedia/gstreamer/pkg-plist b/multimedia/gstreamer/pkg-plist
index f03a89807bed..bb7d05af7c48 100644
--- a/multimedia/gstreamer/pkg-plist
+++ b/multimedia/gstreamer/pkg-plist
@@ -22,6 +22,7 @@ include/gstreamer-%%VERSION%%/gst/base/gstpushsrc.h
include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstbufferstraw.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstcheck.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstconsistencychecker.h
include/gstreamer-%%VERSION%%/gst/controller/gstcontroller.h
include/gstreamer-%%VERSION%%/gst/controller/gstcontrolsource.h
include/gstreamer-%%VERSION%%/gst/controller/gstinterpolationcontrolsource.h
@@ -31,6 +32,7 @@ include/gstreamer-%%VERSION%%/gst/glib-compat.h
include/gstreamer-%%VERSION%%/gst/gst.h
include/gstreamer-%%VERSION%%/gst/gstbin.h
include/gstreamer-%%VERSION%%/gst/gstbuffer.h
+include/gstreamer-%%VERSION%%/gst/gstbufferlist.h
include/gstreamer-%%VERSION%%/gst/gstbus.h
include/gstreamer-%%VERSION%%/gst/gstcaps.h
include/gstreamer-%%VERSION%%/gst/gstchildproxy.h
@@ -73,6 +75,7 @@ include/gstreamer-%%VERSION%%/gst/gstsystemclock.h
include/gstreamer-%%VERSION%%/gst/gsttaglist.h
include/gstreamer-%%VERSION%%/gst/gsttagsetter.h
include/gstreamer-%%VERSION%%/gst/gsttask.h
+include/gstreamer-%%VERSION%%/gst/gsttaskpool.h
include/gstreamer-%%VERSION%%/gst/gsttrace.h
include/gstreamer-%%VERSION%%/gst/gsttypefind.h
include/gstreamer-%%VERSION%%/gst/gsttypefindfactory.h