aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-06-05 14:53:35 +0800
committerjgh <jgh@FreeBSD.org>2013-06-05 14:53:35 +0800
commit569c8f66c77c094dd7d78b267e89eb132bb86016 (patch)
tree543f7dd36235b9a954cac9ea81a6be2e6e9dfa38 /multimedia
parentbc4088e00a08594dbd3249cf2262c71539227438 (diff)
downloadfreebsd-ports-gnome-569c8f66c77c094dd7d78b267e89eb132bb86016.tar.gz
freebsd-ports-gnome-569c8f66c77c094dd7d78b267e89eb132bb86016.tar.zst
freebsd-ports-gnome-569c8f66c77c094dd7d78b267e89eb132bb86016.zip
- adoption of optionsNG
Approved by: portmgr (bapt)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/totem/Makefile31
-rw-r--r--multimedia/totem/pkg-plist2
-rw-r--r--multimedia/tunapie/Makefile38
3 files changed, 33 insertions, 38 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 16b91e045ef6..ce94d767182a 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -1,8 +1,6 @@
-# Whom: Hendrik Scholz <hendrik@scholz.net>
-#
+# Created by: Hendrik Scholz <hendrik@scholz.net>
# $FreeBSD$
# $MCom: ports/multimedia/totem/Makefile,v 1.151 2010/09/27 19:04:37 kwm Exp $
-#
PORTNAME= totem
PORTVERSION= 2.32.0
@@ -12,7 +10,7 @@ MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER?= gnome@FreeBSD.org
-COMMENT?= A gstreamer-based video player for the GNOME 2 Desktop
+COMMENT?= Gstreamer-based video player for the GNOME 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= gdata.7:${PORTSDIR}/devel/libgdata \
@@ -26,9 +24,9 @@ CONFLICTS= totem-3.[0-9]*
USE_PYTHON= yes
USE_BZIP2= yes
-USES= pathfix gettext
-USE_GNOME= gnomeprefix intlhack desktopfileutils \
- nautilus2 ltverhack pygtk2 gnomehier
+USES= pathfix gettext desktop-file-utils
+USE_GNOME= gnomeprefix intlhack nautilus2 \
+ ltverhack pygtk2 gnomehier
USE_GSTREAMER= core gconf hal good mpeg2dec soup ugly python gio
INSTALLS_ICONS= yes
USE_GMAKE= yes
@@ -46,12 +44,13 @@ MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-OPTIONS= LIRC "Enable lirc support" off \
- GALAGO "Enable Galago support" off \
- BROWSER_PLUGINS "Enable install plugins for gecko browser" on \
- PUBLISH "Enable Publish (network playlist) plugin" off \
-# TRACKER "Enable tracker local search plugin" off
+OPTIONS_DEFINE= LIRC GALAGO BROWSER_PLUGINS PUBLISH TRACKER
+GALAGO_DESC= Galago support
+BROWSER_PLUGINS_DESC= Plugins for gecko browser
+PUBLISH_DESC= Publish (network playlist) plugin
+TRACKER_DESC= Tracker local search plugin
+OPTIONS_DEFAULT= BROWSER_PLUGINS
# check configure script for allowed_plugins="..." for new plugins
TOTEM_PLUGINS= thumbnail screensaver ontop gromit media-player-keys \
properties skipto youtube opensubtitles screenshot \
@@ -60,6 +59,7 @@ TOTEM_PLUGINS= thumbnail screensaver ontop gromit media-player-keys \
# Not using:
# TOTEM_PLUGINS= mythtv bemused jamendo
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if defined(WITH_PUBLISH)
@@ -78,7 +78,7 @@ PLIST_SUB+= PUBLISH="@comment "
PLIST_SUB+= TRACKER="@comment "
#.endif
-.if defined(WITH_LIRC)
+.if ${PORT_OPTIONS:MLIRC}
LIB_DEPENDS+= lirc_client.2:${PORTSDIR}/comms/lirc
PLIST_SUB+= LIRC=""
TOTEM_PLUGINS:= ${TOTEM_PLUGINS} lirc
@@ -86,7 +86,7 @@ TOTEM_PLUGINS:= ${TOTEM_PLUGINS} lirc
PLIST_SUB+= LIRC="@comment "
.endif
-.if defined(WITH_GALAGO)
+.if ${PORT_OPTIONS:MGALAGO}
LIB_DEPENDS+= galago.3:${PORTSDIR}/devel/libgalago
PLIST_SUB+= GALAGO=""
TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
@@ -94,7 +94,7 @@ TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
PLIST_SUB+= GALAGO="@comment "
.endif
-.if !defined(WITHOUT_BROWSER_PLUGINS)
+.if ${PORT_OPTIONS:MBROWSER_PLUGINS}
CONFIGURE_ARGS+=--enable-browser-plugins \
--enable-gmp-plugin \
--enable-narrowspace-plugin
@@ -130,7 +130,6 @@ post-patch:
${WRKSRC}/src/backend/bacon-video-widget-gst-0.10.c
post-install:
- @-update-desktop-database
${MKDIR} ${PREFIX}/share/vala/vapi
${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vapi ${PREFIX}/share/vala/vapi
${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.deps ${PREFIX}/share/vala/vapi
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index b592b540fd34..f4c455311f98 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -563,8 +563,6 @@ share/vala/vapi/totem.vapi
@dirrm lib/totem/plugins
@dirrm lib/totem
%%BROWSER_PLUGINS%%@dirrmtry %%WEBPLUGINS_DIR%%
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index a63ed9171138..76fddf13cc94 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tunapie
-# Date created: 2006-04-03
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= tunapie
PORTVERSION= 2.1.18
@@ -23,13 +19,14 @@ USE_PYTHON= yes
USE_WX= 2.6+
WX_COMPS= python:run
-OPTIONS= ADULT "non-censored TV listings" off \
- AMAROK "use amarok instead of mplayer" off \
- TOTEM "use totem instead of mplayer" off \
- VLC "use vlc instead of mplayer" off \
- XINE "use xine instead of mplayer" off \
- AUDACIOUS "use audacious instead of xmms" off \
- BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms" off
+OPTIONS_DEFINE= ADULT AMAROK TOTEM VLC XINE AUDACIOUS BEEP_MEDIA_PLAYER
+ADULT_DESC= non-censored TV listings
+AMAROK_DESC= use amarok instead of mplayer
+TOTEM_DESC= use totem instead of mplayer
+VLC_DESC= use vlc instead of mplayer
+XINE_DESC= use xine instead of mplayer
+AUDACIOUS_DESC= use audacious instead of xmms
+BEEP_MEDIA_PLAYER_DESC= use beep-media-player instead of xmms
.if !defined(NO_INSTALL_MANPAGES)
MAN1= tunapie.1
@@ -53,32 +50,33 @@ do-install:
@${MKDIR} ${DESKTOPDIR}
@cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
.if !defined(NO_INSTALL_MANPAGES)
- @${CP} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
+ @${CP} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
.endif
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if defined(WITH_ADULT)
+.if ${PORT_OPTIONS:MADULT}
ADULT_TVLIST= --adult
.endif
# default VIDEOPLAYER
-.if defined(WITH_AMAROK)
+.if ${PORT_OPTIONS:MAMAROK}
RUN_DEPENDS+= amarok:${PORTSDIR}/audio/amarok
-.elif defined(WITH_TOTEM)
+.elif ${PORT_OPTIONS:MTOTEM}
RUN_DEPENDS+= totem:${PORTSDIR}/multimedia/totem
-.elif defined(WITH_XINE)
+.elif ${PORT_OPTIONS:MXINE}
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
-.elif defined(WITH_VLC)
+.elif ${PORT_OPTIONS:MVLC}
RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
.else
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
# default AUDIOPLAYER
-.if defined(WITH_AUDACIOUS)
+.if ${PORT_OPTIONS:MAUDACIOUS}
RUN_DEPENDS+= audacious:${PORTSDIR}/multimedia/audacious
-.elifdef(WITH_BEEP_MEDIA_PLAYER)
+.elif ${PORT_OPTIONS:MBEEP_MEDIA_PLAYER}
RUN_DEPENDS+= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
.else
RUN_DEPENDS+= xmms:${PORTSDIR}/multimedia/xmms