aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-10-23 00:25:55 +0800
committeradamw <adamw@FreeBSD.org>2014-10-23 00:25:55 +0800
commit56d2e07f9d6a0425acdd829678357f1a6115cf85 (patch)
tree789530f1448607d15e4cb02e01f155a9b6e2314e /multimedia
parentedc6684845a843b1201c9c5d6c441feb74bb34cb (diff)
downloadfreebsd-ports-gnome-56d2e07f9d6a0425acdd829678357f1a6115cf85.tar.gz
freebsd-ports-gnome-56d2e07f9d6a0425acdd829678357f1a6115cf85.tar.zst
freebsd-ports-gnome-56d2e07f9d6a0425acdd829678357f1a6115cf85.zip
Use iconv port, for wchar_t.
When running the plexhometheater player, the following line is repeatedly printed into the log output. ERROR: convert_checked iconv_open() failed from UTF-8 to WCHAR_T, errno=22(Invalid argument) This is because the plexhometheater port currently uses the iconv in base, which does not provide the wchar_t functionality. PR: 194533 Submitted by: Ben Woods (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexhometheater/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 7df5350d1e69..caa922e7caa2 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -69,7 +69,7 @@ GH_PROJECT= plex-home-theater-public
GH_COMMIT= 2d6426d
GH_TAGNAME= pht-v1.2.2
-USES= cmake:outsource iconv pkgconfig python:2
+USES= cmake:outsource iconv:wchar_t pkgconfig python:2
CMAKE_ARGS+= -DENABLE_AUTOUPDATE:BOOL=false
CMAKE_ARGS+= -DENABLE_DUMP_SYMBOLS:BOOL=false
CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=false
@@ -126,6 +126,8 @@ post-patch:
${WRKSRC}/lib/ffmpeg/common.mak \
${WRKSRC}/lib/ffmpeg/configure \
${WRKSRC}/lib/ffmpeg/libavcodec/Makefile
+ @${REINPLACE_CMD} 's/iconv_open/libiconv_open/' \
+ ${WRKSRC}/plex/CMakeModules/FindIconv.cmake
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin