aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-12-15 06:09:58 +0800
committerpav <pav@FreeBSD.org>2007-12-15 06:09:58 +0800
commit64e917c4f5dd7752db85c893256f44806064236e (patch)
tree58ea61241d12fba570ad7996bfd248c9c47325b1 /multimedia
parent483766841b67832acfca5311432c228722d6b78d (diff)
downloadfreebsd-ports-gnome-64e917c4f5dd7752db85c893256f44806064236e.tar.gz
freebsd-ports-gnome-64e917c4f5dd7752db85c893256f44806064236e.tar.zst
freebsd-ports-gnome-64e917c4f5dd7752db85c893256f44806064236e.zip
- Update to 0.4
PR: ports/118138 Submitted by: Nikos Ntarmos <ntarmos@ceid.upatras.gr> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/shell-fm/Makefile27
-rw-r--r--multimedia/shell-fm/distinfo6
-rw-r--r--multimedia/shell-fm/files/patch-reconfig18
-rw-r--r--multimedia/shell-fm/files/patch-rl_completion.h11
-rw-r--r--multimedia/shell-fm/files/patch-shell-fm.1226
-rw-r--r--multimedia/shell-fm/files/patch-strndup.c59
6 files changed, 186 insertions, 161 deletions
diff --git a/multimedia/shell-fm/Makefile b/multimedia/shell-fm/Makefile
index 91c42dc363cf..dd6de1df9bb0 100644
--- a/multimedia/shell-fm/Makefile
+++ b/multimedia/shell-fm/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= shell-fm
-PORTVERSION= 20061229
-PORTREVISION= 2
+PORTVERSION= 0.4
+PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= http://ntarmos.dyndns.org/Software/FreeBSD/
@@ -23,22 +23,29 @@ ACLOCAL_ARGS= -I m4
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-USE_GCC= 3.4+
pre-configure:
@(cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
post-install:
- @(${MKDIR} ${PREFIX}/share/examples/shell-fm && \
- ${INSTALL} -m 444 ${WRKSRC}/src/shell-fm.rc-example \
- ${PREFIX}/share/examples/shell-fm)
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/COPYING ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_MSG} "installing example config file to ${EXAMPLESDIR}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_MAN} ${WRKSRC}/shell-fm.rc-example ${EXAMPLESDIR}
+.endif
MAN1= shell-fm.1
MANCOMPRESSED= no
-
-PLIST_FILES= bin/shell-fm \
- share/examples/shell-fm/shell-fm.rc-example
-PLIST_DIRS= share/examples/shell-fm
+PLIST_FILES= bin/shell-fm
+PORTDOCS= AUTHORS COPYING README
+PORTEXAMPLES= shell-fm.rc-example
.include <bsd.port.mk>
diff --git a/multimedia/shell-fm/distinfo b/multimedia/shell-fm/distinfo
index 2988704f76ed..2e1aa164fa50 100644
--- a/multimedia/shell-fm/distinfo
+++ b/multimedia/shell-fm/distinfo
@@ -1,3 +1,3 @@
-MD5 (shell-fm-20061229.tar.gz) = 86480049f21a8f440e76dd6d858b5450
-SHA256 (shell-fm-20061229.tar.gz) = 88c17ecb35a744d20682427784f9446a5e6fc7a7186cdd0fa20d07418b4507e3
-SIZE (shell-fm-20061229.tar.gz) = 30487
+MD5 (shell-fm-0.4.tar.gz) = 8042dca006ebc8c29bce0ef4e3c964a8
+SHA256 (shell-fm-0.4.tar.gz) = 03fd3ea13a1ecd97355aa9a504480b3b407c46bc6893477d3d1b61f300c3425b
+SIZE (shell-fm-0.4.tar.gz) = 56641
diff --git a/multimedia/shell-fm/files/patch-reconfig b/multimedia/shell-fm/files/patch-reconfig
deleted file mode 100644
index 941069702262..000000000000
--- a/multimedia/shell-fm/files/patch-reconfig
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urNbB src/reconfig.orig src/reconfig
---- reconfig.orig Sat Dec 16 01:01:06 2006
-+++ reconfig Sat Dec 16 02:57:44 2006
-@@ -36,10 +36,10 @@
-
- $clean_only && exit
-
--do_cmd aclocal -I m4
--do_cmd autoheader
--do_cmd automake --add-missing --copy
--do_cmd autoconf
-+do_cmd aclocal-1.9 -I m4
-+do_cmd autoheader-2.61
-+do_cmd automake-1.9 --add-missing --copy
-+do_cmd autoconf-2.61
-
-
-
diff --git a/multimedia/shell-fm/files/patch-rl_completion.h b/multimedia/shell-fm/files/patch-rl_completion.h
deleted file mode 100644
index 8a911bbe1e26..000000000000
--- a/multimedia/shell-fm/files/patch-rl_completion.h
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urNbB src/include/rl_completion.h.orig src/include/rl_completion.h
---- src/include/rl_completion.h.orig Sat Dec 16 01:01:06 2006
-+++ src/include/rl_completion.h Sat Dec 16 02:08:02 2006
-@@ -6,6 +6,7 @@
- #define SHELLFM_COMPLETION
-
- #include <readline/readline.h>
-+#include <time.h>
- #include "strarray.h"
-
- /* a tree composed of this structure will define the completion logic */
diff --git a/multimedia/shell-fm/files/patch-shell-fm.1 b/multimedia/shell-fm/files/patch-shell-fm.1
index 792ebe6eb5ab..998ef45b38e9 100644
--- a/multimedia/shell-fm/files/patch-shell-fm.1
+++ b/multimedia/shell-fm/files/patch-shell-fm.1
@@ -1,7 +1,6 @@
-diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
---- src/shell-fm.1.orig Thu Jan 1 02:00:00 1970
-+++ src/shell-fm.1 Sat Dec 16 00:59:11 2006
-@@ -0,0 +1,179 @@
+--- /dev/null 2007-11-19 22:27:41.000000000 +0200
++++ src/shell-fm.1 2007-11-19 22:27:20.000000000 +0200
+@@ -0,0 +1,223 @@
+.\"
+.\" $Id$
+.\"
@@ -13,11 +12,13 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+.Nd command-line Last.FM client
+.Sh SYNOPSIS
+.Nm shell-fm
-+.Op Fl d Ar daemon mode
++.Op Fl d
+.Op Fl i Ar address to listen on
-+.Op Fl W Ar port to listen on
++.Op Fl p Ar port to listen on
+.Op Fl D Ar device to play on
++.Op Fl y Ar http://proxy-server
+.Op Fl h
++.Op lastfm://...
+.Sh DESCRIPTION
+.Nm shell-fm
+is a console based player for the streams provided by Last.FM. It's
@@ -27,9 +28,9 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+is Open Source and published under the terms of the GNU General Public
+License, so feel free to modify and/or redistribute it.
+.Sh RUNNINF SHELL-FM
-+Usage of
++Usage of
+.Nm shell-fm
-+is pretty simple. To tell
++is pretty simple. To tell
+.Nm shell-fm
+what to play, you simply give it the direct link to a Last.FM stream (a
+URL starting with lastfm://). The URLs are very clear and easy to
@@ -42,11 +43,11 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+ Blood
+ lastfm://artist/The Distillers/fans - The Distillers fan radio
+ lastfm://globaltags/punk rock - songs that have been
-+ tagged as "punk rock"
++ tagged as "punk rock"
+.fi
-+.Pp
++.Pp
+Radios can be specified in three ways. First you can give a stream URL
-+as command line argument to
++as command line argument to
+.Nm shell-fm
+:
+.Pp
@@ -54,13 +55,13 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+.Pp
+Note that you need to quote the URL, if it contains white spaces.
+.br
-+Next you can enter a new URL while
++Next you can enter a new URL while
+.Nm shell-fm
+is already running by pressing the r key.
+.Nm shell-fm
+then will prompt you for a new URL. Note that you don't need / may not
-+quote the URL here like in the command line.
-+.Nm shell-fm
++quote the URL here like in the command line.
++.Nm shell-fm
+will take care of whitespaces for you. Finally, you can name a default
+stream in your configuration file, which is started by default if you
+run
@@ -72,69 +73,102 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+keys are known at the moment (may/will be more in future).
+.br
+.nf
-+ username - your Last.FM nick
-+ password - your Last.FM password; if password and username or
-+ only the password are missing here, shell-fm will
-+ prompt you for it on startup.
-+ default-radio - the default radio which shell-fm will play on startup
-+ if you called it without an command line argument.
-+ np-file - the (absolute) path to a file in which you want
-+ shell-fm to save information about the currently
-+ played track in.
-+ np-file-format - the format in which shell-fm will write the song
-+ information to your np-file. Note that both, np-file
-+ and np-file-format need to be specified to make
-+ shell-fm write to the np-file. The format may contain
-+ any character plus some placeholders shell-fm will
-+ replace. They are:
-+ %a - artist
-+ %t - title
-+ %A - album
-+ %d - duration in seconds
-+ %s - station name
-+ %u - station URL
-+ %U - artist URL
-+ %T - track URL
++ username = YourLogin - your Last.FM username.
++ password = YourPass - your Last.FM password.
++ np-file = /path/to/np-file - the (absolute) path to a file in which
++ you want shell-fm to save information
++ about the currently played track in.
++ np-file-format = format - the format in which shell-fm will write
++ the song information to your np-file.
++ Note that both, np-file and
++ np-file-format need to be specified to
++ make shell-fm write to the np-file. The
++ format may contain any character plus
++ some placeholders shell-fm will replace.
++ They are:
++ %a - artist
++ %t - track
++ %A - album
++ %d - track duration
++ %s - station name
++ %u - station URL
++ %U - artist URL
++ %X - album URL
++ %T - track URL
++ %R - remaining seconds of the played
++ track
++ np-cmd = command - if defined, this command will be
++ executed every time a new track is
++ played. Accepts the sape format flast as
++ np-file-format.
++ default-radio = lastfm://.. - the default radio which shell-fm will
++ play on startup if you called it without
++ an command line argument.
++ key0x?? = command - bind an external command to the key with
++ the hexadecimal, UPPERCASE (!),
++ zero-padded ASCII code "??". Keys that
++ are already bound to an action (as
++ listed here) can't be overwritten.
++ Again, you can use all the variables as
++ in "np-file-format" and "np-cmp". Please
++ note that future versions may use
++ further keys, so you might need to
++ change your configuration then.
++ ?-color = color-code - (where ? is one of the meta tag
++ variables (see list above). This allows
++ you to color every kind of tag with a
++ different color (e.g. paint track titles
++ red, artists green and so on). This is
++ the list of valid color codes:
++ 0;30 = black (not very useful)
++ 1;30 = dark gray
++ 0;31 = red
++ 1;31 = light red
++ 0;32 = green
++ 1;32 = light green
++ 0;33 = dark yellow/brown
++ 1;33 = yellow
++ 0;34 = blue
++ 1;34 = light blue
++ 0;35 = violet
++ 1;35 = pink
++ 0;36 = turquoise
++ 1;36 = cyan
++ 0;37 = gray
++ 1;37 = white
++ bind = ip/host - binds a socket to the given host so you
++ can send simple commands to Shell.FM
++ over a network to control it. For now,
++ only the most common commands are
++ supported: "skip", "love", "ban",
++ "quit", "play" and "info". "play" takes
++ a radio statio URI as paramater. "info"
++ takes a format string as parameter (same
++ as for np-file-format) and returns the
++ string (formatted).
++ port = 123 - if defined, the socket interface will be
++ bound to this port instead of the
++ default, 54311.
++ extern = command - on some platforms, Shell.FM is still
++ unable to play streams properly. This
++ option enables you to use Shell.FM for
++ stream control, but use another player
++ for the playback. The stream will be
++ written to STDIN of the external player.
++ For example, extern = /usr/bin/madplay
++ -Q - should work find on Mac OS X (if
++ you have madplay installed).
++ extern-restart = anything - if defined (no matter what value),
++ Shell.FM will stop and restart the
++ external player whenever the track
++ changes.
++ proxy = http://proxy-server - use proxy server for HTTP requests.
++ expiry = 86400 - TTL of cached files in seconds.
+.fi
+.Pp
-+There may and will be more placeholders available in future releases.
-+.br
-+.nf
-+ np-cmd - command that's executed whenever the track changes. Allows
-+ the same format placeholders as the "np-file-format"
-+ option.
-+ key0x?? - bind an external command to the key with the hexadecimal,
-+ UPPERCASE (!), zero-padded ASCII code "??". Keys that are
-+ already bound to an action (as listed here) can't be
-+ overwritten. Again, you can use all the variables as in
-+ "np-file-format" and "np-cmp". Please note that future
-+ versions may use further keys, so you might need to change
-+ your configuration then.
-+ ?-color - (where ? is one of the meta tag variables (see list
-+ above). This allows you to color every kind of tag with a
-+ different color (e.g. paint track titles red, artists
-+ green and so on). This is the list of valid color codes:
-+ 0;30 = black (not very useful)
-+ 1;30 = dark gray
-+ 0;31 = red
-+ 1;31 = light red
-+ 0;32 = green
-+ 1;32 = light green
-+ 0;33 = dark yellow/brown
-+ 1;33 = yellow
-+ 0;34 = blue
-+ 1;34 = light blue
-+ 0;35 = violet
-+ 1;35 = pink
-+ 0;36 = turquoise
-+ 1;36 = cyan
-+ 0;37 = gray
-+ 1;37 = white
-+.fi
-+.Pp
-+This is what your configuration file for
-+.Nm shell-fm
-+could look like:
++This is what your configuration file for
++.Nm shell-fm
++could look like:
+.nf
+ [~]$ cat ~/.shell-fm/shell-fm.rc
+ username = shell-monkey
@@ -146,7 +180,7 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+ t-color = 1;32
+ a-color = 0;32
+ s-color = 1;37
-+ [~]$
++ [~]$
+.fi
+.Sh CONTROLS
+These keys are available from within
@@ -154,23 +188,32 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+to control it's behaviour:
+.br
+.nf
-+ r - prompt for a new station URL.
-+ l - love the currently played track.
-+ B - (uppercase!) ban the currently played track.
-+ n - skip the currently played track.
-+ Q - (uppercase!) quit.
-+ d - enable/disable discovery mode.
-+ A - ban the artist of the currently played track (whenever another
-+ track of this artist is streamed again, it will be banned
-+ automatically).
-+ R - toggle RTP on/off (RTP = record tracks to profile)
-+ f - listen to the fan radio of the currently played tracks artist
-+ s - listen to the similar-artists radio of the currently played
-+ tracks artist
++ l - love the currently played track.
++ B - (uppercase!) ban the currently played track.
++ n - skip the currently played track.
++ Q - (uppercase!) quit.
++ r - prompt for a new station URL.
++ i - display some information about the currently played track.
++ d - enable/disable discovery mode.
++ A - ban the artist of the currently played track (whenever another
++ track of this artist is streamed again, it will be banned
++ automatically).
++ R - recommend currently played track/artist/album to someone.
++ f - jump to the currently played tracks artists fan radio.
++ s - jump to the currently played tracks artists similar artists
++ radio.
++ H - bookmark the currently played stream.
++ h - list bookmarks.
++ [0-9] - jump to a previously bookmarked stream.
++ p - pause (experimental - after a while the stream will be
++ closed)
++ S - stop playing
++ T - tag the currently played track/artist/album.
++ ? - show a list of available keys.
+.fi
+.br
+Note that the radio URL prompt provides a simple history (use up/down
-+arrow keys to browse it). By default,
++arrow keys to browse it). By default,
+.Nm Shell.FM
+will remember only the URLs you entered in the current session. If you
+want the history to survive, you need to create an empty file name
@@ -178,7 +221,7 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+.Sh SEE ALSO
+http://nex.scrapping.cc/shell-fm/
+.Sh CREDITS
-+Jonas Kramer <jonas.kramer@gmx.net> wrote the actual code.
++Read the AUTHORS file in the port's doc directory.
+.Sh AUTHOR
+Nikos Ntarmos <ntarmos@ceid.upatras.gr>
--- src/Makefile.am.orig Sat Dec 16 04:37:00 2006
@@ -191,3 +234,4 @@ diff -urNbB src/shell-fm.1.orig shell-fm/src/shell-fm.1
+EXTRA_DIST = ${man_MANS}
## vim: noet ts=8 sw=8
+
diff --git a/multimedia/shell-fm/files/patch-strndup.c b/multimedia/shell-fm/files/patch-strndup.c
index eed4c89b077b..a23f3c093b9b 100644
--- a/multimedia/shell-fm/files/patch-strndup.c
+++ b/multimedia/shell-fm/files/patch-strndup.c
@@ -1,6 +1,6 @@
--- src/strndup.c.orig Sat Dec 16 04:21:22 2006
+++ src/strndup.c Sat Dec 16 04:20:48 2006
-@@ -0,0 +1,14 @@
+@@ -0,0 +1,17 @@
+#include "strndup.h"
+#include <string.h>
+#include <stdlib.h>
@@ -9,7 +9,10 @@
+
+char* strndup(const char* src, size_t len) {
+ char* _tmpStr = (char*)malloc(len + 1);
-+ strncpy(_tmpStr, src, len);
++ if (_tmpStr) {
++ strncpy(_tmpStr, src, len);
++ _tmpStr[len] = 0;
++ }
+ return _tmpStr;
+}
+
@@ -31,41 +34,41 @@
+
--- src/Makefile.am.orig Sat Dec 16 04:18:32 2006
+++ src/Makefile.am Sat Dec 16 04:18:41 2006
-@@ -6,6 +6,7 @@
+@@ -169,6 +169,7 @@
+ SUBDIRS = include
INCLUDES = -I$(srcdir)/include
-
shell_fm_SOURCES = \
+strndup.c \
autoban.c \
bookmark.c \
getln.c \
---- src/radio.c.orig Sat Dec 16 04:25:00 2006
-+++ src/radio.c Sat Dec 16 02:07:30 2006
-@@ -35,6 +35,7 @@
- #include "settings.h"
- #include "rl_completion.h"
- #include "strarray.h"
-+#include "strndup.h"
-
- #define LASTFM_URL_PREFIX "lastfm://"
- #define LASTFM_URL_MIN_LENGTH 6 // shortest possible: 'user/a'
---- src/strarray.c.orig Sat Dec 16 04:25:13 2006
-+++ src/strarray.c Sat Dec 16 02:07:39 2006
-@@ -22,6 +22,7 @@
-
- #include "compatibility.h"
- #include "strarray.h"
-+#include "strndup.h"
-
- void strarray_init (strarray_t *sa) {
- sa->strings = NULL;
--- src/tag.c.orig Sat Dec 16 04:25:15 2006
+++ src/tag.c Sat Dec 16 02:07:49 2006
-@@ -23,6 +23,7 @@
+@@ -22,6 +22,7 @@
#include "split.h"
#include "interface.h"
- #include "rl_completion.h"
+ #include "completion.h"
++#include "strndup.h"
+ #include "md5.h"
+ #include "feeds.h"
+
+--- src/feeds.c.o 2007-11-19 18:31:19.000000000 +0200
++++ src/feeds.c 2007-11-19 18:31:43.000000000 +0200
+@@ -8,6 +8,7 @@
+ #include "http.h"
+ #include "feeds.h"
+ #include "tag.h"
++#include "strndup.h"
+
+ char ** neighbors(const char * user) {
+ char * encoded = NULL, feed[128], ** names = NULL;
+--- src/playlist.c.o 2007-11-19 18:31:15.000000000 +0200
++++ src/playlist.c 2007-11-19 18:31:31.000000000 +0200
+@@ -18,6 +18,7 @@
+ #include "http.h"
+ #include "settings.h"
+ #include "service.h"
+#include "strndup.h"
- static char ** getPopularTags(char, struct hash);
- static char * getExistingTags(char, struct hash);
+ #include "playlist.h"
+ #include "globals.h"