aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-05-11 10:52:06 +0800
committerlioux <lioux@FreeBSD.org>2003-05-11 10:52:06 +0800
commit73fbe363991cea162f1e7da6b77e4a8d850eca26 (patch)
tree3962ff56f01e083337227741f461ab7e44a71b57 /multimedia
parent4aaad0e22e579e90d9b2e1505f14b7f7c3c08398 (diff)
downloadfreebsd-ports-gnome-73fbe363991cea162f1e7da6b77e4a8d850eca26.tar.gz
freebsd-ports-gnome-73fbe363991cea162f1e7da6b77e4a8d850eca26.tar.zst
freebsd-ports-gnome-73fbe363991cea162f1e7da6b77e4a8d850eca26.zip
o Do not check return of dlerror(3) to see if there was an error.
dlerror(3) holds the value of the LAST dlsym(3) error. It does not tell if an error occured in the last dlsym(3) call. It could have happened before. o Bump PORTREVISION Submitted by: nectar
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ogle-gui/Makefile1
-rw-r--r--multimedia/ogle-gui/files/patch-src::my_glade.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/ogle-gui/Makefile b/multimedia/ogle-gui/Makefile
index 2663643c4b28..d9becae2921c 100644
--- a/multimedia/ogle-gui/Makefile
+++ b/multimedia/ogle-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ogle
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= multimedia gnome
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
PKGNAMESUFFIX= -gui
diff --git a/multimedia/ogle-gui/files/patch-src::my_glade.c b/multimedia/ogle-gui/files/patch-src::my_glade.c
new file mode 100644
index 000000000000..b4d23cd9777e
--- /dev/null
+++ b/multimedia/ogle-gui/files/patch-src::my_glade.c
@@ -0,0 +1,11 @@
+--- src/my_glade.c.orig Sat May 10 23:43:23 2003
++++ src/my_glade.c Sat May 10 23:45:47 2003
+@@ -39,7 +39,7 @@
+
+ fun = dlsym(handle, new_symbol);
+ error = dlerror();
+- if(error != NULL) {
++ if(fun == NULL) {
+ fprintf(stderr, "Error during dlsym of %s: %s\n", new_symbol, error);
+ gtk_exit(1);
+ }