aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-19 21:46:57 +0800
committertijl <tijl@FreeBSD.org>2014-09-19 21:46:57 +0800
commit9497d257d1560b5824a0e735364e6d8f535f01db (patch)
tree42849d1960a6e5ff5287677cf09e0880b6fdf47a /multimedia
parentd5a4c6ed2501df8529ba870930f25ea01ec49e1e (diff)
downloadfreebsd-ports-gnome-9497d257d1560b5824a0e735364e6d8f535f01db.tar.gz
freebsd-ports-gnome-9497d257d1560b5824a0e735364e6d8f535f01db.tar.zst
freebsd-ports-gnome-9497d257d1560b5824a0e735364e6d8f535f01db.zip
Drop .la files and add INSTALL_TARGET=install-strip
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libtheora/Makefile16
-rw-r--r--multimedia/libtheora/pkg-plist11
2 files changed, 12 insertions, 15 deletions
diff --git a/multimedia/libtheora/Makefile b/multimedia/libtheora/Makefile
index bc521fdf71fe..ea8f695f98f2 100644
--- a/multimedia/libtheora/Makefile
+++ b/multimedia/libtheora/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libtheora
PORTVERSION= 1.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
MASTER_SITES= http://downloads.xiph.org/releases/theora/ \
http://distfiles.master.finkmirrors.net/
@@ -14,15 +14,15 @@ COMMENT= Theora video codec for the Ogg multimedia streaming system
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
GNU_CONFIGURE= yes
-USES= libtool:keepla tar:bzip2
-USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-sdltest \
+ --disable-examples
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--disable-sdltest \
- --enable-shared \
- --disable-examples
+INSTALL_TARGET= install-strip
+USES= libtool tar:bzip2
+USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
@@ -32,4 +32,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|#define OC_X86_ASM|#undef OC_X86_ASM|' ${WRKSRC}/configure
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/libtheora/pkg-plist b/multimedia/libtheora/pkg-plist
index a0b85eacf196..18b7db426e36 100644
--- a/multimedia/libtheora/pkg-plist
+++ b/multimedia/libtheora/pkg-plist
@@ -3,19 +3,16 @@ include/theora/codec.h
include/theora/theoraenc.h
include/theora/theoradec.h
lib/libtheora.a
-lib/libtheora.la
lib/libtheora.so
lib/libtheora.so.0
lib/libtheora.so.0.3.10
-lib/libtheoraenc.a
-lib/libtheoraenc.la
-lib/libtheoraenc.so
-lib/libtheoraenc.so.1
-lib/libtheoradec.so.1.1.4
lib/libtheoradec.a
-lib/libtheoradec.la
lib/libtheoradec.so
lib/libtheoradec.so.1
+lib/libtheoradec.so.1.1.4
+lib/libtheoraenc.a
+lib/libtheoraenc.so
+lib/libtheoraenc.so.1
lib/libtheoraenc.so.1.1.2
libdata/pkgconfig/theora.pc
libdata/pkgconfig/theoraenc.pc