aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2014-05-17 01:27:39 +0800
committernox <nox@FreeBSD.org>2014-05-17 01:27:39 +0800
commit9591fc45d8791fcbdcdf235518f67e51548847cf (patch)
treea923e8428481671786e32db94071bc834b60c871 /multimedia
parent657bcbee4770823743ebf36b327d3a138644ebee (diff)
downloadfreebsd-ports-gnome-9591fc45d8791fcbdcdf235518f67e51548847cf.tar.gz
freebsd-ports-gnome-9591fc45d8791fcbdcdf235518f67e51548847cf.tar.zst
freebsd-ports-gnome-9591fc45d8791fcbdcdf235518f67e51548847cf.zip
- Fix plist with older nvidia-driver versions that don't support opengl 2.0 .
- Bump PORTREVISION. Reported by: Garrett Garrison
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 9de87e9f9258..9b8afb5ae83c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xine
PORTVERSION= 1.2.4
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= multimedia ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib/${PORTVERSION}
PKGNAMEPREFIX= lib
@@ -65,7 +65,8 @@ OPTIONS_DEFINE= CACA ESOUND JACK GNOMEVFS2 PULSEAUDIO XVMC SMB AALIB \
DOCSDIR= ${PREFIX}/share/doc/xine-lib
# Please sync with XINE_PLUGINSDIR in multimedia/xine
# and multimedia/vdr-plugin-xineliboutput
-PLIST_SUB= PLUGINSDIR="lib/xine/plugins/2.3"
+PLUGINSDIR= lib/xine/plugins/2.3
+PLIST_SUB= PLUGINSDIR="${PLUGINSDIR}"
.include <bsd.port.options.mk>
@@ -226,4 +227,12 @@ post-patch:
's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' \
${WRKSRC}/configure
+# XXX older nvidia-driver versions don't support opengl 2.0 so this
+# plugin might not get built:
+post-install:
+.if !exists(${STAGEDIR}${PREFIX}/${PLUGINSDIR}/xineplug_vo_out_opengl2.so)
+ ${REINPLACE_CMD} -e '/xineplug_vo_out_opengl2.so/d' \
+ ${TMPPLIST}
+.endif
+
.include <bsd.port.post.mk>