aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-03-03 09:22:23 +0800
committerhq <hq@FreeBSD.org>2005-03-03 09:22:23 +0800
commit9c70f96a75f2a34b44020cb61c7963045e3a3fb8 (patch)
tree92119739a37d60c5465af8780cfcfab14a17737f /multimedia
parent35b473b511adb9a41f6ce7e9ba524eea9c46820c (diff)
downloadfreebsd-ports-gnome-9c70f96a75f2a34b44020cb61c7963045e3a3fb8.tar.gz
freebsd-ports-gnome-9c70f96a75f2a34b44020cb61c7963045e3a3fb8.tar.zst
freebsd-ports-gnome-9c70f96a75f2a34b44020cb61c7963045e3a3fb8.zip
- Update to 0.7.1 -- mainly a bug fix release:
* fixed merging ac3 streams in avi containers * fixed video bitrate allowed range * fixed compilation without subtitles support * fixed some invalid casts * added x264 support - Add WITH_DEBUG switch
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ogmrip/Makefile17
-rw-r--r--multimedia/ogmrip/distinfo4
-rw-r--r--multimedia/ogmrip/files/patch-ogmrip-pref.diff31
-rw-r--r--multimedia/ogmrip/pkg-plist1
4 files changed, 18 insertions, 35 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 0b9a2e1cdb5b..d69197e0da93 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ogmrip
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -33,6 +33,10 @@ GCONF_SCHEMAS= ogmrip.schemas
CONFIGURE_ARGS= --sharedstatedir=${PREFIX}/libdata
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-maintainer-mode --enable-devel-mode
+.endif
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/bin/mkvmerge)
@@ -43,6 +47,13 @@ PLIST_SUB+= MKV_SUPPORT=""
PLIST_SUB+= MKV_SUPPORT="@comment "
.endif
+.if !defined(WITH_DEBUG)
+pre-extract:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " *** Define WITH_DEBUG to enable debug symbols ***"
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/data/Makefile.in
@@ -55,6 +66,10 @@ pre-configure:
${FALSE} ; \
fi
+pre-install:
+ @${LOCALBASE}/bin/mencoder -ovc help 2> /dev/null | ${GREP} -q "^ *x264 *- .*$$" \
+ && ${ECHO_CMD} "include/ogmrip/ogmrip-x264.h" >>${TMPPLIST} || ${TRUE}
+
post-install:
@${ECHO_CMD} ""
@${CAT} ${PKGMESSAGE}
diff --git a/multimedia/ogmrip/distinfo b/multimedia/ogmrip/distinfo
index 4e34215993a8..1d5d3ecc6691 100644
--- a/multimedia/ogmrip/distinfo
+++ b/multimedia/ogmrip/distinfo
@@ -1,2 +1,2 @@
-MD5 (ogmrip-0.7.0.tar.gz) = 6e29e1de82d4254620eab5f90ffd0903
-SIZE (ogmrip-0.7.0.tar.gz) = 488594
+MD5 (ogmrip-0.7.1.tar.gz) = 601470fc028b7c14b9e84455d198b8f9
+SIZE (ogmrip-0.7.1.tar.gz) = 489483
diff --git a/multimedia/ogmrip/files/patch-ogmrip-pref.diff b/multimedia/ogmrip/files/patch-ogmrip-pref.diff
deleted file mode 100644
index 53c1e18237ca..000000000000
--- a/multimedia/ogmrip/files/patch-ogmrip-pref.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-$FreeBSD$
-
---- src/ogmrip-pref.c.orig 2005-02-24 02:25:46.143332080 +0100
-+++ src/ogmrip-pref.c 2005-02-24 02:27:45.306216568 +0100
-@@ -124,22 +124,22 @@
- }
-
- static void
--ogmrip_pref_output_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *label)
-+ogmrip_pref_output_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *widget)
- {
- /*
- * Sanity checks
- */
-- gtk_label_set_text (GTK_LABEL (label),
-+ gtk_entry_set_text (GTK_ENTRY (widget),
- gconf_value_get_string (entry->value));
- }
-
- static void
--ogmrip_pref_tmp_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *label)
-+ogmrip_pref_tmp_dir_notified (GConfClient *gconf, guint id, GConfEntry *entry, GtkWidget *widget)
- {
- /*
- * Sanity checks
- */
-- gtk_label_set_text (GTK_LABEL (label),
-+ gtk_entry_set_text (GTK_ENTRY (widget),
- gconf_value_get_string (entry->value));
- }
-
diff --git a/multimedia/ogmrip/pkg-plist b/multimedia/ogmrip/pkg-plist
index 90a3a3d33aa3..cc2c425022e8 100644
--- a/multimedia/ogmrip/pkg-plist
+++ b/multimedia/ogmrip/pkg-plist
@@ -20,7 +20,6 @@ include/ogmrip/ogmrip-tools.h
include/ogmrip/ogmrip-video.h
include/ogmrip/ogmrip-vobsub.h
include/ogmrip/ogmrip-vorbis.h
-include/ogmrip/ogmrip-theora.h
include/ogmrip/ogmrip-wav.h
include/ogmrip/ogmrip-xvid.h
include/ogmrip/ogmrip.h