aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2012-06-24 18:01:46 +0800
committeroliver <oliver@FreeBSD.org>2012-06-24 18:01:46 +0800
commita35a33755c11a304832f478c76d37b09a0e06a66 (patch)
treefe8a96f7cc0462ebd4bc9f056b1dfe614d3ce906 /multimedia
parentec222afbbd31646980c10366ca664b5e9e003de3 (diff)
downloadfreebsd-ports-gnome-a35a33755c11a304832f478c76d37b09a0e06a66.tar.gz
freebsd-ports-gnome-a35a33755c11a304832f478c76d37b09a0e06a66.tar.zst
freebsd-ports-gnome-a35a33755c11a304832f478c76d37b09a0e06a66.zip
add libguess support
PR: 166172 Submitted By: Stanislav Sedov <stas@deglitch.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index d033abdd862c..95a075a62574 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -32,15 +32,13 @@ MAN1= audacious.1 audtool.1
PORTDOCS= README AUTHORS
-# no ports for:
-# CHARSET "Build with automatic charset detection" off \
-
OPTIONS= DBUS "Build with dbus support" on \
GNOME "Build with gconf support" off \
- ICONV "Build with iconv support" on \
+ ICONV "Build with iconv support" on \
NLS "Native Language Support" on \
EXECINFO "Build with libexecinfo support" on \
- SSE2 "Build with SSE2 instruction set" on
+ SSE2 "Build with SSE2 instruction set" on \
+ CHARSET "Build with automatic charset detection" on
.include <bsd.port.pre.mk>
@@ -79,6 +77,13 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=--disable-sse2
.endif
+.if defined(WITH_CHARSET)
+LIB_DEPENDS+= guess.1:${PORTSDIR}/textproc/libguess
+CONFIGURE_ARGS+=--enable-chardet
+.else
+CONFIGURE_ARGS+=--disable-chardet
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile