aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-09-23 21:28:58 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-09-23 21:28:58 +0800
commitb1c76ef0aeed4442f3105b2e329f69b4ee467108 (patch)
tree1732fc5929aa7a338e82ea835b1683232ac4f2a9 /multimedia
parent3b019795f1173f10b3f2631690594f8a5d2446bb (diff)
downloadfreebsd-ports-gnome-b1c76ef0aeed4442f3105b2e329f69b4ee467108.tar.gz
freebsd-ports-gnome-b1c76ef0aeed4442f3105b2e329f69b4ee467108.tar.zst
freebsd-ports-gnome-b1c76ef0aeed4442f3105b2e329f69b4ee467108.zip
multimedia/kodi: Set USES= compiler:c++11-lib
- USES= compiler:c++11-lib was left out of the original patch due to an oversight. Add it and remove FreeBSD 9 specific USE_GCC= yes. - No PORTREVISION bump as the compiler choice remained the same. PR: 202812 Submitted by: mickael.maillot@gmail.com MFH: 2015Q3 X-MFH-With: r397342, r397605
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kodi/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index df3ae8981395..5bf6fa25ecc7 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -60,8 +60,8 @@ GH_PROJECT= ffmpeg
GH_TAGNAME= 2.6.4-Isengard
KODI_COMMIT= f4dda26
-USES= autoreconf:build gettext gmake iconv jpeg libtool \
- pkgconfig python:2
+USES= autoreconf:build compiler:c++11-lib gettext gmake iconv jpeg \
+ libtool pkgconfig python:2
GNU_CONFIGURE= yes
USE_XORG= xmu xrandr xt xtst
USE_GL= glu glew
@@ -144,11 +144,6 @@ SFTP_CONFIGURE_ENABLE= ssh
CONFIGURE_ARGS+= --disable-debug --disable-alsa --disable-pulse
-.include <bsd.port.pre.mk>
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000000
-USE_GCC= yes
-.endif
-
post-extract:
${MKDIR} ${WRKSRC}/tools/depends/target/ffmpeg/${GH_PROJECT}-${GH_TAGNAME}
${TAR} --strip-components=1 -xf ${DISTDIR}/${GH_PROJECT}-${GH_TAGNAME}.tar.gz \
@@ -172,4 +167,4 @@ post-install:
| ${XARGS} ${STRIP_CMD}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/kodi/kodi-xrandr
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>