aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /multimedia
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audiopreview/Makefile6
-rw-r--r--multimedia/bombono/Makefile2
-rw-r--r--multimedia/handbrake/Makefile6
-rw-r--r--multimedia/kmplayer-kde4/Makefile2
-rw-r--r--multimedia/pitivi/Makefile6
-rw-r--r--multimedia/xbmc/Makefile2
6 files changed, 13 insertions, 11 deletions
diff --git a/multimedia/audiopreview/Makefile b/multimedia/audiopreview/Makefile
index 8034bf64cb96..5d93e1085850 100644
--- a/multimedia/audiopreview/Makefile
+++ b/multimedia/audiopreview/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= http://audiopreview.codealpha.net/files/
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Command-line tool to play previews of audio and video files
-USES= gmake pkgconfig
+USES= gettext gmake pkgconfig
USE_GSTREAMER= core
USE_GNOME= intltool
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/audiopreview man/man1/audiopreview.1.gz
diff --git a/multimedia/bombono/Makefile b/multimedia/bombono/Makefile
index 813101521f80..a9a7887ad448 100644
--- a/multimedia/bombono/Makefile
+++ b/multimedia/bombono/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= gm:${PORTSDIR}/graphics/GraphicsMagick \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
toolame:${PORTSDIR}/audio/toolame
-USES= pkgconfig scons tar:bzip2
+USES= gettext pkgconfig scons tar:bzip2
USE_GCC= any
INSTALLS_ICONS= yes
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 15a97f501891..bcbccbdef182 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -46,8 +46,7 @@ LIB_DEPENDS+= libdvdcss.so.2:${PORTSDIR}/multimedia/libdvdcss
.endif
GNU_CONFIGURE= yes
-USES= gmake iconv libtool:build pkgconfig python:build
-USE_AUTOTOOLS= autoconf:env automake:env
+USES= autoreconf:build gmake iconv libtool:build pkgconfig python:build
WRKSRC= ${WRKDIR}/HandBrake-${PORTVERSION}
PLIST_FILES= bin/HandBrakeCLI
@@ -79,8 +78,11 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.if ${PORT_OPTIONS:MX11}
CONFIGURE_ARGS+= --disable-gtk-update-checks --disable-gst
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libnotify.so:${PORTSDIR}/devel/libnotify
+USES+= gettext
USE_GNOME+= gtk20
PLIST_FILES+= bin/HandBrake
.else
diff --git a/multimedia/kmplayer-kde4/Makefile b/multimedia/kmplayer-kde4/Makefile
index 5996771ee270..f56c06ab53e5 100644
--- a/multimedia/kmplayer-kde4/Makefile
+++ b/multimedia/kmplayer-kde4/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libcairo.so:${PORTSDIR}/graphics/cairo
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-USES= cmake pkgconfig tar:bzip2
+USES= cmake gettext pkgconfig tar:bzip2
USE_GNOME= gtk20
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
USE_KDE4= automoc4 kdelibs kdeprefix
diff --git a/multimedia/pitivi/Makefile b/multimedia/pitivi/Makefile
index b9346b5ebb54..98528787477b 100644
--- a/multimedia/pitivi/Makefile
+++ b/multimedia/pitivi/Makefile
@@ -14,13 +14,13 @@ COMMENT= Gstreamer based non-linear audio/video editor
RUN_DEPENDS= py*-zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_SITELIBDIR}/goocanvasmodule.so:${PORTSDIR}/graphics/py-goocanvas
-USES= gmake pkgconfig python tar:bzip2
+USES= gettext gmake pkgconfig python tar:bzip2
USE_GNOME= pygtk2
USE_GSTREAMER= gnonlin python good
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBAES}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=/var
USE_LDCONFIG= yes
diff --git a/multimedia/xbmc/Makefile b/multimedia/xbmc/Makefile
index 4a60d56e3f01..3818c939c572 100644
--- a/multimedia/xbmc/Makefile
+++ b/multimedia/xbmc/Makefile
@@ -52,7 +52,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
xdpyinfo:${PORTSDIR}/x11/xdpyinfo
-USES= gmake iconv:wchar_t libtool:build pkgconfig python:2
+USES= gettext gmake iconv:wchar_t libtool:build pkgconfig python:2
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
USE_XORG= xt xmu xtst