aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-16 17:42:53 +0800
committermiwi <miwi@FreeBSD.org>2009-01-16 17:42:53 +0800
commitdcfb9fdd66f1ecc0b7be5a49bc24fe4abd8a04fe (patch)
tree36e2b6ae6ca3544ca4cc97912c236000c69b265f /multimedia
parent4a83611c85c5af0b867cd1eaa639a4e8060e233c (diff)
downloadfreebsd-ports-gnome-dcfb9fdd66f1ecc0b7be5a49bc24fe4abd8a04fe.tar.gz
freebsd-ports-gnome-dcfb9fdd66f1ecc0b7be5a49bc24fe4abd8a04fe.tar.zst
freebsd-ports-gnome-dcfb9fdd66f1ecc0b7be5a49bc24fe4abd8a04fe.zip
MPEG TS/PS/ES Transport, Program and Elementary Stream tools
This is a set of cross-platform command line tools for working with MPEG data. The emphasis is on relatively simple tools which concentrate on MPEG (H.264 and H.262) data packaged according to H.222 (i.e., TS or PS), with a particular interest in checking for conformance. Transport Stream (TS) is typically used for distribution of cable and satellite data. Program Stream (PS) is typically used to store data on DVDs. The tools are focussed on: * Quick reporting of useful data (tsinfo, stream_type) * Giving a quick overview of the entities in the stream (esdots, psdots) * Reporting on TS packets (tsreport) or ES units/frames/ fields (esreport) * Simple manipulation of stream data (es2ts, esfilter, esreverse, esmerge, ts2es) * Streaming of data, possibly with introduced errors (tsplay) WWW: http://tstools.berlios.de/ PR: ports/130517 Submitted by: J.R. Oldroyd <fbsd at opal.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/tstools/Makefile34
-rw-r--r--multimedia/tstools/distinfo3
-rw-r--r--multimedia/tstools/pkg-descr23
-rw-r--r--multimedia/tstools/pkg-plist31
5 files changed, 92 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 6837b361770d..8c69b51dd0c2 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -251,6 +251,7 @@
SUBDIR += toxine
SUBDIR += transcode
SUBDIR += transkode
+ SUBDIR += tstools
SUBDIR += tunapie
SUBDIR += tv_grab_au
SUBDIR += umr
diff --git a/multimedia/tstools/Makefile b/multimedia/tstools/Makefile
new file mode 100644
index 000000000000..6976a5fd33c5
--- /dev/null
+++ b/multimedia/tstools/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: tstools
+# Date created: 2009 January 12
+# Whom: J.R. Oldroyd <fbsd@opal.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tstools
+DISTVERSION= 1_11
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= tstools
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fbsd@opal.com
+COMMENT= MPEG Transport, Program and Elementary Stream tools
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ ${CP} ${WRKSRC}/bin/* ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib
+ ${CP} ${WRKSRC}/lib/* ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/docs/${PORTNAME}
+ ${CP} ${WRKSRC}/docs/* ${PREFIX}/share/docs/${PORTNAME}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/tstools/distinfo b/multimedia/tstools/distinfo
new file mode 100644
index 000000000000..30714b795aaa
--- /dev/null
+++ b/multimedia/tstools/distinfo
@@ -0,0 +1,3 @@
+MD5 (tstools-1_11.tgz) = 2650a09f828b19bb22829a7828f13cde
+SHA256 (tstools-1_11.tgz) = 4e207ad7298ec421c6710e3024147b486320d792cec2dbd34efb7e6d9e96230a
+SIZE (tstools-1_11.tgz) = 392616
diff --git a/multimedia/tstools/pkg-descr b/multimedia/tstools/pkg-descr
new file mode 100644
index 000000000000..cdf4d519a4cf
--- /dev/null
+++ b/multimedia/tstools/pkg-descr
@@ -0,0 +1,23 @@
+MPEG TS/PS/ES Transport, Program and Elementary Stream tools
+
+This is a set of cross-platform command line tools for working with
+MPEG data. The emphasis is on relatively simple tools which
+concentrate on MPEG (H.264 and H.262) data packaged according to
+H.222 (i.e., TS or PS), with a particular interest in checking for
+conformance. Transport Stream (TS) is typically used for distribution
+of cable and satellite data. Program Stream (PS) is typically used
+to store data on DVDs.
+
+The tools are focussed on:
+
+ * Quick reporting of useful data (tsinfo, stream_type)
+ * Giving a quick overview of the entities in the stream
+ (esdots, psdots)
+ * Reporting on TS packets (tsreport) or ES units/frames/
+ fields (esreport)
+ * Simple manipulation of stream data (es2ts, esfilter,
+ esreverse, esmerge, ts2es)
+ * Streaming of data, possibly with introduced errors
+ (tsplay)
+
+WWW: http://tstools.berlios.de/
diff --git a/multimedia/tstools/pkg-plist b/multimedia/tstools/pkg-plist
new file mode 100644
index 000000000000..70d19edb6892
--- /dev/null
+++ b/multimedia/tstools/pkg-plist
@@ -0,0 +1,31 @@
+bin/es2ts
+bin/esdots
+bin/esfilter
+bin/esmerge
+bin/esreport
+bin/esreverse
+bin/m2ts2ts
+bin/pcapreport
+bin/ps2ts
+bin/psdots
+bin/psreport
+bin/stream_type
+bin/ts2es
+bin/ts_packet_insert
+bin/tsinfo
+bin/tsplay
+bin/tsreport
+bin/tsserve
+lib/libtstools.a
+%%PORTDOCS%%share/docs/tstools/ac3.txt
+%%PORTDOCS%%share/docs/tstools/adts.txt
+%%PORTDOCS%%share/docs/tstools/build_html.py
+%%PORTDOCS%%share/docs/tstools/default.css
+%%PORTDOCS%%share/docs/tstools/get_next_access_unit.py
+%%PORTDOCS%%share/docs/tstools/get_next_access_unit.py.html
+%%PORTDOCS%%share/docs/tstools/index.txt
+%%PORTDOCS%%share/docs/tstools/library.txt
+%%PORTDOCS%%share/docs/tstools/todo.txt
+%%PORTDOCS%%share/docs/tstools/tools.txt
+%%PORTDOCS%%@dirrm share/docs/tstools
+%%PORTDOCS%%@dirrm share/docs