aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-11-10 00:25:26 +0800
committeradamw <adamw@FreeBSD.org>2014-11-10 00:25:26 +0800
commitdf9675101c2570b9bf7fd08408caf2727c199bb5 (patch)
tree3c59c96a466f51131837721027b879a002590dca /multimedia
parent4e81ec68e1f18bcdf9d5627fadca24c4417a1a9b (diff)
downloadfreebsd-ports-gnome-df9675101c2570b9bf7fd08408caf2727c199bb5.tar.gz
freebsd-ports-gnome-df9675101c2570b9bf7fd08408caf2727c199bb5.tar.zst
freebsd-ports-gnome-df9675101c2570b9bf7fd08408caf2727c199bb5.zip
Update MediaBrowser port to latest upstream 3.0.5424.1 stable.
Also tidy up a few items in the port recommended by josh4trunks. This includes improving rc script to minimise customisation (maximise use of rc.subr), moving the storage of the MediaBrowser database files to /var/db/mediabrowser and adding some more comments for users. Add an entry to UPDATING explaining the database directory move from /usr/local/mediabrowser to /var/db/mediabrowser. The default MediaBrowser database/configuration/logs/media metadata storage directory has moved from /usr/local/mediabrowser to /var/db/mediabrowser. Users are advised either to move the contents of the old directory to the new location, or to add a mediabrowser_data_dir entry to /etc/rc.conf. PR: 194904 Submitted by: Ben Woods
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mediabrowser/Makefile13
-rw-r--r--multimedia/mediabrowser/distinfo4
-rw-r--r--multimedia/mediabrowser/files/mediabrowser.in78
-rw-r--r--multimedia/mediabrowser/pkg-message10
-rw-r--r--multimedia/mediabrowser/pkg-plist220
5 files changed, 242 insertions, 83 deletions
diff --git a/multimedia/mediabrowser/Makefile b/multimedia/mediabrowser/Makefile
index 25b7593b07ae..b0ca59afeb80 100644
--- a/multimedia/mediabrowser/Makefile
+++ b/multimedia/mediabrowser/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mediabrowser
-PORTVERSION= 3.0.5416.0
+PORTVERSION= 3.0.5424.1
CATEGORIES= multimedia
MAINTAINER= woodsb02@gmail.com
@@ -18,16 +18,15 @@ LIB_DEPENDS= libavformat.so:${PORTSDIR}/multimedia/ffmpeg \
USE_GITHUB= yes
GH_ACCOUNT= MediaBrowser
GH_PROJECT= MediaBrowser
-GH_COMMIT= 14a81fb
+GH_COMMIT= 628919d
GH_TAGNAME= ${PORTVERSION}
USES= mono pkgconfig
USE_RC_SUBR= mediabrowser
-SUB_LIST= SUPPORT_PATH=${SUPPORT_PATH} USERS=${USERS} GROUPS=${GROUPS}
+SUB_LIST= PORTNAME=${PORTNAME} USER=${USERS} GROUP=${GROUPS}
USERS= mediabrowser
GROUPS= mediabrowser
-SUPPORT_PATH?= ${PREFIX}/mediabrowserdata
do-build:
(cd ${WRKSRC} && \
@@ -37,9 +36,9 @@ do-build:
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/mediabrowser
(cd ${WRKSRC}/MediaBrowser.Server.Mono/bin/Release\ Mono && \
- ${RM} -rv ./MediaInfo && \
- ${RM} -rv ./libwebp && \
- ${RM} -rv ./sqlite3 && \
+ ${ECHO_MSG} "Deleting the following non-FreeBSD library files:" && \
+ ${FIND} -E . -iregex '(.*\.dylib|.*libwebp.*|.*sqlite3.*|.*.dylib.*|MediaInfo\.dll)' -print -delete && \
+ ${FIND} . -type d -empty -print -delete && \
${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/mediabrowser)
.include <bsd.port.mk>
diff --git a/multimedia/mediabrowser/distinfo b/multimedia/mediabrowser/distinfo
index d3719f0c0717..792f86b76873 100644
--- a/multimedia/mediabrowser/distinfo
+++ b/multimedia/mediabrowser/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mediabrowser-3.0.5416.0.tar.gz) = e88e701d41b9f614082f6bf567df7f17a05dd78997511e8eafcb06cf4bb261c1
-SIZE (mediabrowser-3.0.5416.0.tar.gz) = 49250655
+SHA256 (mediabrowser-3.0.5424.1.tar.gz) = 791c856ca36279ee04f384a6aca36ec5b5f873cef85e9326eed5f254d7cc8acb
+SIZE (mediabrowser-3.0.5424.1.tar.gz) = 44009795
diff --git a/multimedia/mediabrowser/files/mediabrowser.in b/multimedia/mediabrowser/files/mediabrowser.in
index d2e37ece052b..5a1277598d1a 100644
--- a/multimedia/mediabrowser/files/mediabrowser.in
+++ b/multimedia/mediabrowser/files/mediabrowser.in
@@ -2,80 +2,40 @@
# $FreeBSD$
#
-# PROVIDE: mediabrowser
+# PROVIDE: %%PORTNAME%%
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
-# Add the following lines to /etc/rc.conf to enable the MediaBrowser Server:
-#
-# mediabrowser_enable="YES"
-#
-# mediabrowser_support_path="%%SUPPORT_PATH%%" # MediaBrowser data: logs, media metadata, settings, etc
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
#
+# %%PORTNAME%%_enable: Set to YES to enable %%PORTNAME%%
+# Default: NO
+# %%PORTNAME%%_data_dir: Directory where %%PORTNAME%% configuration
+# data is stored.
+# Default: /var/db/%%PORTNAME%%
. /etc/rc.subr
-
-name=mediabrowser
-rcvar=mediabrowser_enable
+name=%%PORTNAME%%
+rcvar=${name}_enable
load_rc_config $name
-: ${mediabrowser_enable:=NO}
-: ${mediabrowser_support_path="%%SUPPORT_PATH%%"}
-: ${mediabrowser_user="%%USERS%%"}
-: ${mediabrowser_group="%%GROUPS%%"}
+: ${%%PORTNAME%%_enable:="NO"}
+: ${%%PORTNAME%%_data_dir:="/var/db/%%PORTNAME%%"}
-extra_commands=status
-start_precmd=mediabrowser_precmd
-start_cmd=mediabrowser_startcmd
-status_cmd=mediabrowser_statuscmd
-stop_cmd=mediabrowser_stopcmd
-pidfile=/var/run/${name}.pid
+pidfile="/var/run/%%PORTNAME%%.pid"
+command="/usr/sbin/daemon"
+procname="%%LOCALBASE%%/bin/mono"
+command_args="-f -u %%USER%% -p ${pidfile} ${procname} %%PREFIX%%/lib/mediabrowser/MediaBrowser.Server.Mono.exe -ffmpeg %%LOCALBASE%%/bin/ffmpeg -ffprobe %%LOCALBASE%%/bin/ffprobe -programdata ${%%PORTNAME%%_data_dir}"
+start_precmd=mediabrowser_precmd
mediabrowser_precmd()
{
export LC_ALL="C"
export LANG="C"
- ulimit -s 3000
-
- if [ ! -d "${mediabrowser_support_path}" ]; then
- install -d -g ${mediabrowser_group} -o ${mediabrowser_user} "${mediabrowser_support_path}";
- fi
-}
-mediabrowser_startcmd()
-{
- if [ -f "${pidfile}" ] && (pgrep -F ${pidfile} -f MediaBrowser >/dev/null); then
- echo "${name} is already running with pid: $(cat ${pidfile})";
- else
- echo "Starting ${name}."
- /usr/sbin/daemon -u ${mediabrowser_user} -p ${pidfile} -f \
- %%PREFIX%%/bin/mono %%PREFIX%%/lib/mediabrowser/MediaBrowser.Server.Mono.exe \
- -ffmpeg %%PREFIX%%/bin/ffmpeg -ffprobe %%PREFIX%%/bin/ffprobe \
- -programdata ${mediabrowser_support_path}
- fi
-}
-
-mediabrowser_statuscmd()
-{
- if [ -f "${pidfile}" ] && (pgrep -F ${pidfile} -f MediaBrowser >/dev/null); then
- echo "${name} is running with pid: $(cat ${pidfile})";
- else
- echo "${name} is not running.";
- exit 1;
- fi
-}
-
-mediabrowser_stopcmd()
-{
- if [ -f "${pidfile}" ] && (pgrep -F ${pidfile} -f MediaBrowser >/dev/null); then
- main_pid=$(cat ${pidfile});
- child_pids=$(pgrep -P ${main_pid});
- all_pids="${main_pid} ${child_pids}"
- kill ${sig_stop} ${all_pids};
- wait_for_pids ${all_pids};
- else
- echo "${name} is not running.";
- exit 1;
+ if [ ! -d "${%%PORTNAME%%_data_dir}" ]; then
+ install -d -g %%GROUP%% -o %%GROUP%% "${%%PORTNAME%%_data_dir}";
fi
}
diff --git a/multimedia/mediabrowser/pkg-message b/multimedia/mediabrowser/pkg-message
index 6e8dfb38d3af..e4a56cd1d99f 100644
--- a/multimedia/mediabrowser/pkg-message
+++ b/multimedia/mediabrowser/pkg-message
@@ -1,5 +1,13 @@
-
MediaBrowser uses ffmpeg for transcoding, which by default has
lame support disabled due to licensing issues. To enable mp3
audio when transcoding, you must reinstall multimedia/ffmpeg
from ports with the lame support option enabled.
+
+To automatically start MediaBrowser at boot time:
+# echo 'mediabrowser_enable="YES"' >> /etc/rc.conf
+
+To then manually start MediaBrowser without rebooting:
+# service mediabrowser start
+
+Once started, visit the following webpage to configure:
+http://localhost:8096/mediabrowser
diff --git a/multimedia/mediabrowser/pkg-plist b/multimedia/mediabrowser/pkg-plist
index 553530bc6d1d..6f67ca47e64e 100644
--- a/multimedia/mediabrowser/pkg-plist
+++ b/multimedia/mediabrowser/pkg-plist
@@ -3,34 +3,23 @@ lib/mediabrowser/DvdLib.dll
lib/mediabrowser/Imazen.WebP.dll
lib/mediabrowser/Imazen.WebP.dll.config
lib/mediabrowser/MediaBrowser.Api.dll
-lib/mediabrowser/MediaBrowser.Api.dll.mdb
lib/mediabrowser/MediaBrowser.Common.Implementations.dll
-lib/mediabrowser/MediaBrowser.Common.Implementations.dll.mdb
lib/mediabrowser/MediaBrowser.Common.dll
-lib/mediabrowser/MediaBrowser.Common.dll.mdb
lib/mediabrowser/MediaBrowser.Controller.dll
-lib/mediabrowser/MediaBrowser.Controller.dll.mdb
lib/mediabrowser/MediaBrowser.Dlna.dll
lib/mediabrowser/MediaBrowser.IsoMounting.Linux.dll
lib/mediabrowser/MediaBrowser.LocalMetadata.dll
-lib/mediabrowser/MediaBrowser.LocalMetadata.dll.mdb
lib/mediabrowser/MediaBrowser.MediaEncoding.dll
lib/mediabrowser/MediaBrowser.MediaInfo.dll
lib/mediabrowser/MediaBrowser.MediaInfo.dll.config
-lib/mediabrowser/MediaBrowser.MediaInfo.dll.mdb
lib/mediabrowser/MediaBrowser.Model.dll
lib/mediabrowser/MediaBrowser.Model.dll.mdb
lib/mediabrowser/MediaBrowser.Providers.dll
-lib/mediabrowser/MediaBrowser.Providers.dll.mdb
lib/mediabrowser/MediaBrowser.Server.Implementations.dll
-lib/mediabrowser/MediaBrowser.Server.Implementations.dll.mdb
lib/mediabrowser/MediaBrowser.Server.Mono.exe
lib/mediabrowser/MediaBrowser.Server.Mono.exe.config
lib/mediabrowser/MediaBrowser.WebDashboard.dll
-lib/mediabrowser/MediaBrowser.WebDashboard.dll.mdb
lib/mediabrowser/MediaBrowser.XbmcMetadata.dll
-lib/mediabrowser/MediaBrowser.XbmcMetadata.dll.mdb
-lib/mediabrowser/MediaInfo.dll
lib/mediabrowser/Mono.Nat.dll
lib/mediabrowser/Mono.Posix.dll
lib/mediabrowser/MoreLinq.dll
@@ -44,7 +33,6 @@ lib/mediabrowser/ServiceStack.Text.dll
lib/mediabrowser/ServiceStack.dll
lib/mediabrowser/SharpCompress.dll
lib/mediabrowser/SimpleInjector.dll
-lib/mediabrowser/System.Data.SQLite.Linq.dll
lib/mediabrowser/System.Data.SQLite.dll
lib/mediabrowser/System.Data.SQLite.dll.config
lib/mediabrowser/WebMarkupMin.Core.dll
@@ -179,6 +167,7 @@ lib/mediabrowser/dashboard-ui/css/images/notifications/error.png
lib/mediabrowser/dashboard-ui/css/images/notifications/info.png
lib/mediabrowser/dashboard-ui/css/images/rightarrow.png
lib/mediabrowser/dashboard-ui/css/images/rotten.png
+lib/mediabrowser/dashboard-ui/css/images/server.png
lib/mediabrowser/dashboard-ui/css/images/stars.png
lib/mediabrowser/dashboard-ui/css/images/supporter/donatepaypal.png
lib/mediabrowser/dashboard-ui/css/images/supporter/nonsupporterbadge.png
@@ -469,6 +458,7 @@ lib/mediabrowser/dashboard-ui/support.html
lib/mediabrowser/dashboard-ui/supporter.html
lib/mediabrowser/dashboard-ui/supporterkey.html
lib/mediabrowser/dashboard-ui/thirdparty/apiclient/connectionmanager.js
+lib/mediabrowser/dashboard-ui/thirdparty/apiclient/connectservice.js
lib/mediabrowser/dashboard-ui/thirdparty/apiclient/credentials.js
lib/mediabrowser/dashboard-ui/thirdparty/apiclient/device.js
lib/mediabrowser/dashboard-ui/thirdparty/apiclient/md5.js
@@ -687,6 +677,210 @@ lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.4/jquery.mobile-1.4.3.
lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.4/jquery.mobile-1.4.4.min.css
lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.4/jquery.mobile-1.4.4.min.js
lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.4/jquery.mobile-1.4.4.min.map
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/ajax-loader.gif
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/action-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/action-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/alert-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/alert-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-l-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-l-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-r-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-r-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-d-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-l-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-l-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-r-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-r-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-l-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-l-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-r-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-r-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/arrow-u-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/audio-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/audio-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/back-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/back-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/bars-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/bars-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/bullets-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/bullets-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/calendar-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/calendar-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/camera-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/camera-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-d-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-d-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-l-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-l-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-r-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-r-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-u-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/carat-u-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/check-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/check-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/clock-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/clock-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/cloud-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/cloud-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/comment-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/comment-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/delete-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/delete-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/edit-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/edit-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/eye-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/eye-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/forbidden-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/forbidden-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/forward-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/forward-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/gear-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/gear-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/grid-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/grid-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/heart-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/heart-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/home-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/home-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/info-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/info-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/location-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/location-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/lock-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/lock-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/mail-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/mail-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/minus-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/minus-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/navigation-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/navigation-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/phone-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/phone-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/plus-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/plus-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/power-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/power-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/recycle-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/recycle-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/refresh-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/refresh-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/search-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/search-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/shop-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/shop-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/star-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/star-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/tag-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/tag-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/user-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/user-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/video-black.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-png/video-white.png
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/action-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/action-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/alert-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/alert-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-l-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-l-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-r-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-r-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-d-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-l-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-l-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-r-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-r-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-l-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-l-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-r-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-r-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/arrow-u-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/audio-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/audio-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/back-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/back-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/bars-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/bars-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/bullets-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/bullets-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/calendar-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/calendar-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/camera-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/camera-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-d-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-d-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-l-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-l-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-r-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-r-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-u-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/carat-u-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/check-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/check-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/clock-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/clock-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/cloud-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/cloud-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/comment-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/comment-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/delete-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/delete-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/edit-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/edit-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/eye-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/eye-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/forbidden-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/forbidden-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/forward-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/forward-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/gear-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/gear-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/grid-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/grid-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/heart-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/heart-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/home-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/home-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/info-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/info-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/location-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/location-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/lock-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/lock-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/mail-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/mail-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/minus-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/minus-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/navigation-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/navigation-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/phone-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/phone-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/plus-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/plus-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/power-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/power-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/recycle-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/recycle-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/refresh-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/refresh-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/search-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/search-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/shop-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/shop-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/star-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/star-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/tag-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/tag-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/user-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/user-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/video-black.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/images/icons-svg/video-white.svg
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/jquery.mobile-1.4.5.min.css
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/jquery.mobile-1.4.5.min.js
+lib/mediabrowser/dashboard-ui/thirdparty/jquerymobile-1.4.5/jquery.mobile-1.4.5.min.map
lib/mediabrowser/dashboard-ui/thirdparty/jstree1.0/jquery.jstree.js
lib/mediabrowser/dashboard-ui/thirdparty/jstree1.0/jquery.jstree.min.js
lib/mediabrowser/dashboard-ui/thirdparty/jstree1.0/themes/apple/bg.jpg
@@ -738,8 +932,6 @@ lib/mediabrowser/dashboard-ui/wizardservice.html
lib/mediabrowser/dashboard-ui/wizardsettings.html
lib/mediabrowser/dashboard-ui/wizardstart.html
lib/mediabrowser/dashboard-ui/wizarduser.html
-lib/mediabrowser/libwebp.dll
-lib/mediabrowser/sqlite3.dll
lib/mediabrowser/swagger-ui/css/highlight.default.css
lib/mediabrowser/swagger-ui/css/screen.css
lib/mediabrowser/swagger-ui/images/logo_small.png