aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2009-04-26 19:42:25 +0800
committeroliver <oliver@FreeBSD.org>2009-04-26 19:42:25 +0800
commite04b3a79de4989fd0a303fc581c395f136599886 (patch)
tree19f1ebe311b489688e74ccc147f6f5d0cd844837 /multimedia
parenta421acd8b19c249224659c40c643c59a626d0657 (diff)
downloadfreebsd-ports-gnome-e04b3a79de4989fd0a303fc581c395f136599886.tar.gz
freebsd-ports-gnome-e04b3a79de4989fd0a303fc581c395f136599886.tar.zst
freebsd-ports-gnome-e04b3a79de4989fd0a303fc581c395f136599886.zip
add a CURL option for the lastfm/scrobbler plugin
clarify the neon option [1] PR: ports/133442 [1] Submitted by: baileygeoff@telus.net [1]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious-plugins/Makefile12
-rw-r--r--multimedia/audacious-plugins/pkg-plist2
2 files changed, 12 insertions, 2 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 9f16adbfeddf..c18dd098f6e9 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -61,14 +61,15 @@ OPTIONS= DBUS "Enable dbus support" on \
OSS4 "Enable OSS4 output plugin" off \
TIMIDITY "Enable timidity plugin" off \
CDAUDIO "Enable cdaudio-ng input plugin" on \
- NEON "Enable neon support (experimental)" on \
+ NEON "Enable neon (HTTP) support" on \
MMS "Enable mms support" off \
MTP "Enable MTP upload support" off \
PARANORMAL "Enable paranormal vis plugin" on \
XSPF "Enable XSPF support" on \
TTA "Enable TrueAudio plugin" on \
GNOME "Build with gnomevfs/gconf support" off \
- NLS "Native Language Support" on
+ NLS "Native Language Support" on \
+ CURL "curl for lastfm/scrobbler support" off
.include <bsd.port.pre.mk>
@@ -362,6 +363,13 @@ USE_GNOME+= gnomevfs2 gconf2
CONFIGURE_ARGS+=--enable-gnome-vfs --enable-gconf
.endif
+.if !defined(WITHOUT_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+PLIST_SUB+= CURLPLUGIN=""
+.else
+PLIST_SUB+= CURLPLUGIN="@comment "
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index eb685dd7d338..32b5955448bc 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -14,6 +14,7 @@ lib/audacious/General/alarm.so
%%DBUS%%lib/audacious/General/gnomeshortcuts.so
lib/audacious/General/hotkey.so
%%LIRCPLUGIN%%lib/audacious/General/lirc.so
+%%CURLPLUGIN%%lib/audacious/General/scrobbler.so
lib/audacious/General/song_change.so
lib/audacious/General/statusicon.so
%%AACPLUGIN%%lib/audacious/Input/aac.so
@@ -45,6 +46,7 @@ lib/audacious/Input/vtx.so
lib/audacious/Output/filewriter.so
%%JACKPLUGIN%%lib/audacious/Output/jackout.so
lib/audacious/Output/null.so
+%%CURLPLUGIN%%lib/audacious/Transport/lastfm.so
%%NEONPLUGIN%%lib/audacious/Transport/neon.so
lib/audacious/Transport/stdio.so
lib/audacious/Visualization/blur_scope.so