aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-29 06:42:30 +0800
committerpav <pav@FreeBSD.org>2006-08-29 06:42:30 +0800
commit04be59c6f546b73d7f78bdd0a86b693f7345602d (patch)
tree790dff7cd1c81e34db17ec6b8bbb970f564985d3 /multimedia
parent6b68485906ecfee91a9fc6f8ec126f1b3cd385e8 (diff)
downloadfreebsd-ports-gnome-04be59c6f546b73d7f78bdd0a86b693f7345602d.tar.gz
freebsd-ports-gnome-04be59c6f546b73d7f78bdd0a86b693f7345602d.tar.zst
freebsd-ports-gnome-04be59c6f546b73d7f78bdd0a86b693f7345602d.zip
- Tell consumers to link -fPIC enabled library on amd64
Fixes libxine build
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdca/Makefile10
-rw-r--r--multimedia/libdts/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/multimedia/libdca/Makefile b/multimedia/libdca/Makefile
index 1e171157b788..4df7e8c6b801 100644
--- a/multimedia/libdca/Makefile
+++ b/multimedia/libdca/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdts
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://debian.unnet.nl/pub/videolan/libdts/${PORTVERSION}/ \
http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
@@ -19,4 +20,11 @@ USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldts|ldts_pic|' ${WRKSRC}/libdts/libdts.pc.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/libdts/Makefile b/multimedia/libdts/Makefile
index 1e171157b788..4df7e8c6b801 100644
--- a/multimedia/libdts/Makefile
+++ b/multimedia/libdts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdts
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://debian.unnet.nl/pub/videolan/libdts/${PORTVERSION}/ \
http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
@@ -19,4 +20,11 @@ USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldts|ldts_pic|' ${WRKSRC}/libdts/libdts.pc.in
+.endif
+
+.include <bsd.port.post.mk>