aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-15 20:56:54 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-15 20:56:54 +0800
commit4177237f3eb75ce29e3fc2cecfc47de2ec66dc0e (patch)
tree923b618bebdbc4238c062b98c5a404d170c486ef /multimedia
parent272ed8c5d7c251c5c99981872a8cbda39fb06b71 (diff)
downloadfreebsd-ports-gnome-4177237f3eb75ce29e3fc2cecfc47de2ec66dc0e.tar.gz
freebsd-ports-gnome-4177237f3eb75ce29e3fc2cecfc47de2ec66dc0e.tar.zst
freebsd-ports-gnome-4177237f3eb75ce29e3fc2cecfc47de2ec66dc0e.zip
multimedia/openh264: make sure as(1) is available
aarch64 lacks binutils in base unlike armv6 while the buildbot only copies ld(1) from ports under /usr/bin. Note, Clang 3.9 still doesn't support the assembly used here.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/openh264/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/multimedia/openh264/Makefile b/multimedia/openh264/Makefile
index 01e50733a3c2..b6c731b10149 100644
--- a/multimedia/openh264/Makefile
+++ b/multimedia/openh264/Makefile
@@ -27,13 +27,12 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
CFLAGS_OPT="" CFLAGS_DEBUG=""
ALL_TARGET= all
-BROKEN_aarch64= Fails to compile: cc: error: unable to execute command: Executable as does not exist
-
OPTIONS_DEFINE= DEBUG PLUGINS TEST
OPTIONS_DEFAULT=PLUGINS
OPTIONS_SUB= yes
DEBUG_BUILD_DEPENDS_OFF= ${DEBUG_BUILD_DEPENDS_OFF_${ARCH}}
+DEBUG_BUILD_DEPENDS_OFF_aarch64=as:devel/binutils
DEBUG_BUILD_DEPENDS_OFF_amd64= nasm:devel/nasm
DEBUG_BUILD_DEPENDS_OFF_i386= nasm:devel/nasm
DEBUG_MAKE_ARGS=BUILDTYPE=Debug