aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2008-10-20 23:46:04 +0800
committerflz <flz@FreeBSD.org>2008-10-20 23:46:04 +0800
commit5b2ecb3aa3d7f0a3112b064668505a2652708dfb (patch)
treef91a5deb477932f72684e0af0fb44168c6e0866c /multimedia
parent14b958ba17f57356efac03f34384b0052da8a2b0 (diff)
downloadfreebsd-ports-gnome-5b2ecb3aa3d7f0a3112b064668505a2652708dfb.tar.gz
freebsd-ports-gnome-5b2ecb3aa3d7f0a3112b064668505a2652708dfb.tar.zst
freebsd-ports-gnome-5b2ecb3aa3d7f0a3112b064668505a2652708dfb.zip
Fix crash when listening to radio and pidgin-musictracker
is active. PR: ports/127285 Submitted by: "Eric L. Chen" <d9364104@mail.nchu.edu.tw>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/banshee/Makefile2
-rw-r--r--multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs29
2 files changed, 30 insertions, 1 deletions
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 733c47d8ed37..2c22753bfc3f 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -7,7 +7,7 @@
PORTNAME= banshee
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://download.banshee-project.org/banshee/
DISTNAME= ${PORTNAME}-1-${PORTVERSION}
diff --git a/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs b/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs
new file mode 100644
index 000000000000..ce82cc721c61
--- /dev/null
+++ b/multimedia/banshee/files/patch-src_Core_Banshee.Core_Banshee.Collection_TrackInfo.cs
@@ -0,0 +1,29 @@
+--- src/Core/Banshee.Core/Banshee.Collection/TrackInfo.cs.orig 2008-09-11 09:01:14.000000000 +0800
++++ src/Core/Banshee.Core/Banshee.Collection/TrackInfo.cs 2008-09-11 09:14:56.000000000 +0800
+@@ -356,17 +356,17 @@
+
+ // Properties specified by the XMMS2 player spec
+ dict.Add ("URI", Uri == null ? String.Empty : Uri.AbsoluteUri);
+- dict.Add ("length", Duration.TotalSeconds);
+- dict.Add ("name", TrackTitle);
+- dict.Add ("artist", ArtistName);
+- dict.Add ("album", AlbumTitle);
++ dict.Add ("length", Duration == null ? 0 : Duration.TotalSeconds);
++ dict.Add ("name", TrackTitle == null ? String.Empty : TrackTitle);
++ dict.Add ("artist", ArtistName == null ? String.Empty : ArtistName);
++ dict.Add ("album", AlbumTitle == null ? String.Empty : AlbumTitle);
+
+ // Our own
+- dict.Add ("track-number", TrackNumber);
+- dict.Add ("track-count", TrackCount);
+- dict.Add ("disc", Disc);
+- dict.Add ("year", year);
+- dict.Add ("rating", rating);
++ dict.Add ("track-number", TrackNumber == null ? 0 : TrackNumber);
++ dict.Add ("track-count", TrackCount == null ? 0 : TrackCount);
++ dict.Add ("disc", Disc == null ? 0 : Disc);
++ dict.Add ("year", year == null ? 0 : year);
++ dict.Add ("rating", rating == null ? 0 : rating);
+
+ return dict;
+ }