aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2015-07-17 15:26:23 +0800
committermakc <makc@FreeBSD.org>2015-07-17 15:26:23 +0800
commit80ca06cdecdaf62ca7839aa50ef0bea7845373b1 (patch)
tree9fcfd47417fe1c7a5301e2d9673b8a1f0272432b /multimedia
parent2b214cf52f48df056bf6dd07743d8ba771ddedf9 (diff)
downloadfreebsd-ports-gnome-80ca06cdecdaf62ca7839aa50ef0bea7845373b1.tar.gz
freebsd-ports-gnome-80ca06cdecdaf62ca7839aa50ef0bea7845373b1.tar.zst
freebsd-ports-gnome-80ca06cdecdaf62ca7839aa50ef0bea7845373b1.zip
multimedia/minitube:
- Update to 2.4 with support for the latest YouTube API - Remove INSTALLS_ICONS needless for Qt/KDE ports
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/minitube/Makefile13
-rw-r--r--multimedia/minitube/distinfo4
-rw-r--r--multimedia/minitube/pkg-message16
3 files changed, 26 insertions, 7 deletions
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index 8accdc883d35..aad932cea497 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= minitube
-PORTVERSION= 2.3
+PORTVERSION= 2.4
CATEGORIES= multimedia www
-MASTER_SITES= http://flavio.tordini.org/files/minitube/
MAINTAINER= makc@FreeBSD.org
COMMENT= TV-like client for YouTube
@@ -11,10 +10,11 @@ COMMENT= TV-like client for YouTube
USE_QT4= dbus gui network phonon script sql xml \
moc_build rcc_build imageformats_run
USES= qmake
-INSTALLS_ICONS= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= flaviotordini
-QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE}
+QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE} \
+ DEFINES+=APP_GOOGLE_API_KEY="${MINITUBE_GOOGLE_API_KEY}"
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -22,6 +22,9 @@ NLS_USE= QT4=linguisttools_build
.include <bsd.port.options.mk>
+pre-everything::
+ @${CAT} ${PKGMESSAGE}
+
pre-configure:
.if !${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/include(locale\/locale.pri)/d' ${WRKSRC}/minitube.pro
diff --git a/multimedia/minitube/distinfo b/multimedia/minitube/distinfo
index b817d0c06267..010d116a2521 100644
--- a/multimedia/minitube/distinfo
+++ b/multimedia/minitube/distinfo
@@ -1,2 +1,2 @@
-SHA256 (minitube-2.3.tar.gz) = 7fb24e295dc3e2f4ce41add1ef71c7b1fef57383578f46af8e271710c86c2247
-SIZE (minitube-2.3.tar.gz) = 955192
+SHA256 (flaviotordini-minitube-2.4_GH0.tar.gz) = 1d8a427a4120d623c689969d92904bf66bf7d3edafcb0f6f9eb7f24d6db39c7b
+SIZE (flaviotordini-minitube-2.4_GH0.tar.gz) = 984265
diff --git a/multimedia/minitube/pkg-message b/multimedia/minitube/pkg-message
new file mode 100644
index 000000000000..49fd0262b7ae
--- /dev/null
+++ b/multimedia/minitube/pkg-message
@@ -0,0 +1,16 @@
+Google is now requiring an API key in order to access YouTube Data
+web services.
+
+To obtain a key:
+
+1. Create a new project at https://console.developers.google.com/
+
+2. Select newly created project, go to APIs & auth / APIs, select
+ the Youtube Data API and enable api.
+
+3. Go to APIs & auth / Credentials and create a new Public API
+ access key ("Browser key").
+
+4. If you are going to build minitube from ports, set
+ MINITUBE_GOOGLE_API_KEY=your_key in make.conf. If you use package
+ set GOOGLE_API_KEY environment variable to your key.