aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-02-28 12:55:24 +0800
committerlioux <lioux@FreeBSD.org>2003-02-28 12:55:24 +0800
commit8735b9daad8dc37f084a8b30d2274a88482c2e3b (patch)
treebe4a41ca0f3f8e84f78a208fff7339b1f52d11ad /multimedia
parent7dd53d6f4855952b01c01ea822f36f2f58bf52bf (diff)
downloadfreebsd-ports-gnome-8735b9daad8dc37f084a8b30d2274a88482c2e3b.tar.gz
freebsd-ports-gnome-8735b9daad8dc37f084a8b30d2274a88482c2e3b.tar.zst
freebsd-ports-gnome-8735b9daad8dc37f084a8b30d2274a88482c2e3b.zip
o Unmark IGNORE
o Update to 0.5.0
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-player/Makefile43
-rw-r--r--multimedia/gstreamer-player/distinfo2
-rw-r--r--multimedia/gstreamer-player/files/patch-configure10
-rw-r--r--multimedia/gstreamer-player/pkg-plist64
4 files changed, 80 insertions, 39 deletions
diff --git a/multimedia/gstreamer-player/Makefile b/multimedia/gstreamer-player/Makefile
index 85631646d7a0..47de323d844a 100644
--- a/multimedia/gstreamer-player/Makefile
+++ b/multimedia/gstreamer-player/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTVERSION= 0.5.0
CATEGORIES= multimedia audio gnome
-MASTER_SITES= http://gstreamer.net/releases/0.4.0/src/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -player
DISTNAME= gst-player-${PORTVERSION}
@@ -17,32 +17,41 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= Simple yet functional mediaplayer written with GStreamer
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20 \
+LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20 \
+ gconf-2.5:${PORTSDIR}/devel/gconf2 \
+ glade-2.0.0:${PORTSDIR}/devel/libglade2 \
gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
- gstreamer.0:${PORTSDIR}/multimedia/gstreamer \
+ gstreamer-0.6.0:${PORTSDIR}/multimedia/gstreamer \
+ gstplay-0.6.0:${PORTSDIR}/multimedia/gstreamer-plugins \
gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20 \
+ pango-1.0.200:${PORTSDIR}/x11-toolkits/pango \
popt.0:${PORTSDIR}/devel/popt \
xml2.5:${PORTSDIR}/textproc/libxml2
-RUN_DEPENDS= gst-visualise:${PORTSDIR}/multimedia/gstreamer-plugins
-
-IGNORE= Incompatible with latest gstreamer libraries
USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack \
+ gnomehier \
+ gnomeprefix
USE_LIBTOOL= yes
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME} \
- --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG}
+PLIST_SUB= \
+ VERSION="${PORTVERSION}" \
+ SHLIB_VERSION="${SHLIB_VERSION}"
INSTALLS_SHLIB= yes
+MAN1= gst-player.1
+
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
-post-patch:
-# remove version number from include dir name
- @${FIND} ${WRKSRC} -type f -name Makefile.in | \
- ${XARGS} -n 10 ${REINPLACE_CMD} -E \
- 's|^(lib[[:alpha:]]+includedir.+)-@VERSION@|\1|'
+# library minor number
+SHLIB_VERSION= 0
+
+pre-install:
+# required for PREFIX safeness, the dir might not exist under PREFIX
+ @${MKDIR} ${PREFIX}/etc/gconf/
.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-player/distinfo b/multimedia/gstreamer-player/distinfo
index 3d6a5e373638..ae15079a6ab3 100644
--- a/multimedia/gstreamer-player/distinfo
+++ b/multimedia/gstreamer-player/distinfo
@@ -1 +1 @@
-MD5 (gst-player-0.4.0.tar.gz) = b991024aaa225a2daa214637ee1ab1e6
+MD5 (gst-player-0.5.0.tar.bz2) = 96db3a9cb7ebe73e16f1d1ea3b2a38c6
diff --git a/multimedia/gstreamer-player/files/patch-configure b/multimedia/gstreamer-player/files/patch-configure
new file mode 100644
index 000000000000..f65461d9916c
--- /dev/null
+++ b/multimedia/gstreamer-player/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Feb 28 00:06:22 2003
++++ configure Fri Feb 28 00:06:17 2003
+@@ -7814,6 +7814,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/multimedia/gstreamer-player/pkg-plist b/multimedia/gstreamer-player/pkg-plist
index 297bd7db4795..7debec535a6b 100644
--- a/multimedia/gstreamer-player/pkg-plist
+++ b/multimedia/gstreamer-player/pkg-plist
@@ -1,25 +1,47 @@
bin/gst-player
-include/gstreamer/gst-player/gst/gstvideowidget.h
-include/gstreamer/gst/gst-player/play/play.h
-lib/gst/libgstplay.la
-lib/gst/libgstplay.so
-lib/gst/libgstplay.so.0
-lib/libgstplayer.la
+bin/gst-player-gtk
+etc/gconf/gconf.xml.defaults/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/gst-player/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/gst-player/%gconf.xml
+etc/gconf/schemas/gst-player.schemas
+include/gst-player-%%VERSION%%/gst/gstvideowidget.h
+include/gst-player-%%VERSION%%/gst/gtk-playlist.h
+lib/libgstplayer.a
lib/libgstplayer.so
-lib/libgstplayer.so.0
+lib/libgstplayer.so.%%SHLIB_VERSION%%
+libdata/bonobo/servers/Gst-Player-Control.server
+libexec/gst-player-control
+share/gnome/application-registry/gst-player.applications
share/gnome/applications/gst-player.desktop
-share/gnome/pixmaps/gst-player/mini-down.png
-share/gnome/pixmaps/gst-player/mini-up.png
-share/gnome/pixmaps/gst-player/seek-small.png
-share/gnome/pixmaps/gst-player/seek.png
-@dirrm share/gnome/pixmaps/gst-player
-@unexec rmdir %D/share/gnome/pixmaps 2>/dev/null || true
+share/gnome/gst-player/ui/demaximize.png
+share/gnome/gst-player/ui/forward.png
+share/gnome/gst-player/ui/gst-player-logo.png
+share/gnome/gst-player/ui/gst-player-playing.png
+share/gnome/gst-player/ui/maximize.png
+share/gnome/gst-player/ui/mediacontrol.glade
+share/gnome/gst-player/ui/next.png
+share/gnome/gst-player/ui/pause.png
+share/gnome/gst-player/ui/play.png
+share/gnome/gst-player/ui/playlist.glade
+share/gnome/gst-player/ui/playlist.png
+share/gnome/gst-player/ui/previous.png
+share/gnome/gst-player/ui/stop.png
+share/gnome/gst-player/ui/volume-max.png
+share/gnome/gst-player/ui/volume-medium.png
+share/gnome/gst-player/ui/volume-min.png
+share/gnome/gst-player/ui/volume-zero.png
+share/gnome/gst-player/ui/volume.png
+share/gnome/gst-player/ui/volume_mute.png
+share/gnome/mime-info/gst-player.keys
+share/gnome/pixmaps/gst-player-48.png
+@dirrm share/gnome/gst-player/ui
+@dirrm share/gnome/gst-player
@unexec rmdir %D/share/gnome/applications 2>/dev/null || true
-@unexec rmdir %D/share/gnome 2>/dev/null 2>/dev/null || true
-@dirrm lib/gst
-@dirrm include/gstreamer/gst/gst-player/play
-@dirrm include/gstreamer/gst/gst-player
-@dirrm include/gstreamer/gst-player/gst
-@dirrm include/gstreamer/gst-player
-@dirrm include/gstreamer/gst
-@dirrm include/gstreamer
+@unexec rmdir %D/share/gnome/application-registry 2>/dev/null || true
+@dirrm include/gst-player-%%VERSION%%/gst
+@dirrm include/gst-player-%%VERSION%%
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/gst-player
+@dirrm etc/gconf/gconf.xml.defaults/apps/gst-player