aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2009-03-31 00:50:55 +0800
committernovel <novel@FreeBSD.org>2009-03-31 00:50:55 +0800
commit9c58b2a29b0d468cbc0b590f780f1856243bb111 (patch)
tree6d08ee8feecf8aec4d0e53218b885bfc795fa18a /multimedia
parent0c998f085d0673d003eff56d1996393bee83b3b5 (diff)
downloadfreebsd-ports-gnome-9c58b2a29b0d468cbc0b590f780f1856243bb111.tar.gz
freebsd-ports-gnome-9c58b2a29b0d468cbc0b590f780f1856243bb111.tar.zst
freebsd-ports-gnome-9c58b2a29b0d468cbc0b590f780f1856243bb111.zip
Add a patch created by Thomas Klausner <wiz@NetBSD.org> for NetBSD pkgsrc to
fix BMPX with recent cairomm and kindly provided by him to me and un-BREAK the port.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/bmpx/Makefile2
-rw-r--r--multimedia/bmpx/files/patch-widgets-popup.cc13
2 files changed, 13 insertions, 2 deletions
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index fedb787fb451..49173bba0655 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -29,8 +29,6 @@ LIB_DEPENDS= tag.6:${PORTSDIR}/audio/taglib \
CONFLICTS= bmpx-devel-[0-9]*
-BROKEN= does not compile
-
USE_BISON= build
USE_XORG= ice sm
USE_BZIP2= yes
diff --git a/multimedia/bmpx/files/patch-widgets-popup.cc b/multimedia/bmpx/files/patch-widgets-popup.cc
new file mode 100644
index 000000000000..1f2e1b1dc8b9
--- /dev/null
+++ b/multimedia/bmpx/files/patch-widgets-popup.cc
@@ -0,0 +1,13 @@
+$NetBSD: patch-aj,v 1.1 2009/03/26 23:12:22 wiz Exp $
+
+--- widgets/popup.cc.orig 2008-03-05 21:31:12.000000000 +0000
++++ widgets/popup.cc
+@@ -308,7 +308,7 @@ namespace Bmp
+
+ if (m_location == ARROW_TOP)
+ {
+- Cairo::Matrix matrix = { 1, 0, 0, -1, 0, h };
++ Cairo::Matrix matrix ( 1, 0, 0, -1, 0, h );
+ cr->set_matrix (matrix);
+ }
+