aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-05 15:29:05 +0800
committeraz <az@FreeBSD.org>2013-09-05 15:29:05 +0800
commita09da98df1b3a5bed3c993e9e75014c03e1790e0 (patch)
tree0265fe44e2e8b525ce586385590e09f52eff9e23 /multimedia
parent6741a733d57a46465e151cd9258765bb5885a9a3 (diff)
downloadfreebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.tar.gz
freebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.tar.zst
freebsd-ports-gnome-a09da98df1b3a5bed3c993e9e75014c03e1790e0.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/clive/Makefile3
-rw-r--r--multimedia/gcap/Makefile3
-rw-r--r--multimedia/grake/Makefile3
-rw-r--r--multimedia/p5-FFmpeg-Command/Makefile3
-rw-r--r--multimedia/subtitleoffsetmodifier/Makefile3
-rw-r--r--multimedia/youtube-viewer/Makefile3
6 files changed, 12 insertions, 6 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index cbf8ed4116be..5b88401c9be9 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
# deskutils/ljclive, multimedia/clive1 (same executable/manpage/distfile name)
CONFLICTS= py*-clive-[0-1]* ljclive-[0-9]*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= clive.1
PLIST_FILES= bin/clive \
diff --git a/multimedia/gcap/Makefile b/multimedia/gcap/Makefile
index 3267d66b8ddb..7d9ab988cb77 100644
--- a/multimedia/gcap/Makefile
+++ b/multimedia/gcap/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS= p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= gcap.1
PLIST_DIRS= ${SITE_PERL_REL}/${PERL_ARCH}/auto/gcap
diff --git a/multimedia/grake/Makefile b/multimedia/grake/Makefile
index d182009079eb..21de0fe5f4e0 100644
--- a/multimedia/grake/Makefile
+++ b/multimedia/grake/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= grake.1
PLIST_DIRS= ${SITE_PERL_REL}/${PERL_ARCH}/auto/grake
diff --git a/multimedia/p5-FFmpeg-Command/Makefile b/multimedia/p5-FFmpeg-Command/Makefile
index 78e0c13e3348..35497234f820 100644
--- a/multimedia/p5-FFmpeg-Command/Makefile
+++ b/multimedia/p5-FFmpeg-Command/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
RUN_DEPENDS:= ${BUILD_DEPENDS}
RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= FFmpeg::Command.3
diff --git a/multimedia/subtitleoffsetmodifier/Makefile b/multimedia/subtitleoffsetmodifier/Makefile
index 1b4b0e645285..587e788c383d 100644
--- a/multimedia/subtitleoffsetmodifier/Makefile
+++ b/multimedia/subtitleoffsetmodifier/Makefile
@@ -15,7 +15,8 @@ DISTFILES= subtitle-offset-modificator.pl
MAINTAINER= edwin@mavetju.org
COMMENT= Subtitle offset modificator
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
PLIST_FILES= bin/subtitle-offset-modificator
diff --git a/multimedia/youtube-viewer/Makefile b/multimedia/youtube-viewer/Makefile
index 386eed0f22ae..f47de0f68100 100644
--- a/multimedia/youtube-viewer/Makefile
+++ b/multimedia/youtube-viewer/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-XML-Fast>=0:${PORTSDIR}/net/p5-XML-Fast \
mplayer:${PORTSDIR}/multimedia/mplayer
PROJECTHOST= trizen
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
PLIST_FILES= bin/youtube-viewer