aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-20 09:11:55 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-20 09:11:55 +0800
commita291fef7114f486a68fced3666d7ee0ee902d797 (patch)
tree967e28d16c8f23f82292caa69d6f54cabf795291 /multimedia
parent5706888fc0fd0be273e807b06ee5bedba794be46 (diff)
downloadfreebsd-ports-gnome-a291fef7114f486a68fced3666d7ee0ee902d797.tar.gz
freebsd-ports-gnome-a291fef7114f486a68fced3666d7ee0ee902d797.tar.zst
freebsd-ports-gnome-a291fef7114f486a68fced3666d7ee0ee902d797.zip
multimedia/plexhometheater: minor cleanup
- Convert to USE_GL - Adjust PLIST_SUB outside of conditional - Drop 8.x support - OPSYS/OSVERSION also defined in .options.mk Approved by: portmgr blanket
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexhometheater/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 3973827c8904..14e3732fd7e2 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -34,7 +34,6 @@ LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfribidi.so:${PORTSDIR}/converters/fribidi \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libhal.so:${PORTSDIR}/sysutils/hal \
libjasper.so:${PORTSDIR}/graphics/jasper \
liblzo2.so:${PORTSDIR}/archivers/lzo2 \
@@ -78,14 +77,18 @@ CMAKE_ARGS+= -DCMAKE_PREFIX_PATH=${LOCALBASE}
CFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_XORG= xt xmu xtst xrandr
-USE_GL= glu
+USE_GL= glu glew
USE_SDL= image sdl mixer
INSTALLS_ICONS= yes
+
ONLY_FOR_ARCHS= i386 amd64
+PLEX_ARCH_i386= x86
+PLEX_ARCH_amd64=x86_64
WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}
SUB_FILES= ${PORTNAME}.sh pkg-message
+PLIST_SUB= ARCH=${PLEX_ARCH_${ARCH}}
DESKTOP_ENTRIES="Plex Home Theater" \
"${COMMENT}" \
@@ -109,18 +112,7 @@ LIRC_RUN_DEPENDS= lircd:${PORTSDIR}/comms/lirc
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_PulseAudio:BOOL=true
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == i386
-PLIST_SUB+= ARCH="x86"
-.else
-PLIST_SUB+= ARCH="x86_64"
-.endif
-
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 900033
-USE_BINUTILS= yes
-MAKE_ENV= COMPILER_PATH=${LOCALBASE}/bin
-.endif
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} 's/[[:<:]]ARCH[[:>:]]/FFMPEG_ARCH/' \
@@ -146,4 +138,4 @@ post-install:
${RM} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/*.so
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>