aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-03-13 01:18:44 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-03-13 01:18:44 +0800
commita2e13f0f30235a7b8fdbaa95e627fc4d5d1a2be0 (patch)
tree07101b69677c52869448135ad2dab50e249a83d5 /multimedia
parentbc10b56fdfa824232f0ba46886ec8341c66128d0 (diff)
downloadfreebsd-ports-gnome-a2e13f0f30235a7b8fdbaa95e627fc4d5d1a2be0.tar.gz
freebsd-ports-gnome-a2e13f0f30235a7b8fdbaa95e627fc4d5d1a2be0.tar.zst
freebsd-ports-gnome-a2e13f0f30235a7b8fdbaa95e627fc4d5d1a2be0.zip
- Pet portlint: remove ABI version number from LIB_DEPENDS
- Convert to new options framework - Use USES macro - Bump PORTREVISION for dependency change - Cleanup Makefile header
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libquvi/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/multimedia/libquvi/Makefile b/multimedia/libquvi/Makefile
index 23fd3893ed70..1c043fa3cfcc 100644
--- a/multimedia/libquvi/Makefile
+++ b/multimedia/libquvi/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: libquvi
-# Date created: 2011-10-06
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libquvi
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= multimedia devel
MASTER_SITES= SF/quvi/${PORTVERSION:R}/${PORTNAME}/ \
GOOGLE_CODE
@@ -15,23 +12,27 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Cross-platform library for parsing flash media stream URLs
BUILD_DEPENDS= libquvi-scripts>=0.4.0:${PORTSDIR}/multimedia/libquvi-scripts
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= libquvi-scripts>=0.4.0:${PORTSDIR}/multimedia/libquvi-scripts
+OPTIONS_DEFINE= DOCS
+
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
USE_ICONV= yes
USE_LDCONFIG= yes
USE_LUA= yes
USE_XZ= yes
+USES= pathfix
MAN3= libquvi.3
PROJECTHOST= quvi
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/doc/nd/ && ${COPYTREE_SHARE} . ${DOCSDIR}/
.endif