aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-05-17 04:49:18 +0800
committerpawel <pawel@FreeBSD.org>2016-05-17 04:49:18 +0800
commitab075dce60525fffda141b8a5293376ff279b711 (patch)
tree598caeda489bc5eda1c920656e25d78253297c86 /multimedia
parente0a885adbaf1ef4cf55c93b45c249c3c1ce5c220 (diff)
downloadfreebsd-ports-gnome-ab075dce60525fffda141b8a5293376ff279b711.tar.gz
freebsd-ports-gnome-ab075dce60525fffda141b8a5293376ff279b711.tar.zst
freebsd-ports-gnome-ab075dce60525fffda141b8a5293376ff279b711.zip
Update to version 2.6.3
Changelog: Fix bug which caused error moving sets with no layouts (regression). Optimise recording of generated frames. Fixes for recording audio from external pulse audio. Fix incorrect recognition of single jpeg/png as video (regression). Fix "Open Location" (regression). Use png rather than jpeg internally whenever possible. Improved support for mpv instead of mplayer. Add a few new effects ported from Toonz.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile10
-rw-r--r--multimedia/lives/distinfo5
-rw-r--r--multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp12
-rw-r--r--multimedia/lives/pkg-plist2
4 files changed, 20 insertions, 9 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 6c37588b837e..4500ab1c7144 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.6.2
+PORTVERSION= 2.6.3
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -39,13 +39,12 @@ RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:audio/ladspa \
x264:multimedia/x264 \
cdrecord:sysutils/cdrtools
-USES= ghostscript:run libtool localbase pathfix perl5 pkgconfig \
- python shebangfix tar:bzip2
+USES= compiler:c++11-lib ghostscript:run libtool localbase pathfix perl5 \
+ pkgconfig python shebangfix tar:bzip2
SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
smogrify tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
lives-plugins/plugins/playback/audiostream/audiostreamer.pl
GNU_CONFIGURE= yes
-USE_CSTD= gnu89
USE_GNOME= gtk30 intltool
USE_LDCONFIG= yes
@@ -88,9 +87,6 @@ post-patch:
@${REINPLACE_CMD} '/selectRandom/d' \
${WRKSRC}/lives-plugins/weed-plugins/projectM.cpp
-pre-build-NLS-on:
- @(cd ${WRKSRC}/po && ${DO_MAKE_BUILD} update-po)
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index a228c629bf5f..b95e32a67cdf 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,2 +1,3 @@
-SHA256 (lives-2.6.2.tar.bz2) = a90ac6a65d879bc3931a112baf9943d1cb9d3a8538bcd2134090510d8df830cc
-SIZE (lives-2.6.2.tar.bz2) = 3800397
+TIMESTAMP = 1463232875
+SHA256 (lives-2.6.3.tar.bz2) = 495248a51f00925576631821266e1f8acf3eca3b5eb1eaaf350201bfc000b1dc
+SIZE (lives-2.6.3.tar.bz2) = 3888592
diff --git a/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp b/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp
new file mode 100644
index 000000000000..b101543e5702
--- /dev/null
+++ b/multimedia/lives/files/patch-lives-plugins_weed-plugins_toonz.cpp
@@ -0,0 +1,12 @@
+--- lives-plugins/weed-plugins/toonz.cpp.orig 2016-05-16 16:01:17 UTC
++++ lives-plugins/weed-plugins/toonz.cpp
+@@ -38,7 +38,8 @@ Redistribution and use in source and bin
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-
++#include <array>
++#include <random>
+
+ #ifdef HAVE_SYSTEM_WEED
+ #include <weed/weed.h>
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index d7edf18d69fc..258eaa09b35a 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -64,6 +64,7 @@ lib/lives/plugins/decoders/zzavformat_decoder.so
lib/lives/plugins/effects/realtime/weed/RGBdelay.so
lib/lives/plugins/effects/realtime/weed/alien_overlay.so
lib/lives/plugins/effects/realtime/weed/alpha_means.so
+lib/lives/plugins/effects/realtime/weed/alpha_visualizer.so
lib/lives/plugins/effects/realtime/weed/audio_fft.so
lib/lives/plugins/effects/realtime/weed/audio_transition.so
lib/lives/plugins/effects/realtime/weed/audio_volume.so
@@ -124,6 +125,7 @@ lib/lives/plugins/effects/realtime/weed/softlight.so
lib/lives/plugins/effects/realtime/weed/targeted_zoom.so
lib/lives/plugins/effects/realtime/weed/textfun.so
lib/lives/plugins/effects/realtime/weed/tone_gen.so
+lib/lives/plugins/effects/realtime/weed/toonz.so
lib/lives/plugins/effects/realtime/weed/tvpic.so
lib/lives/plugins/effects/realtime/weed/vector_visualiser.so
lib/lives/plugins/effects/realtime/weed/vertigo.so