aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-09-26 02:44:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-09-26 02:44:57 +0800
commitb7e9dd82868f21f7cbdcf8a8640f3d3f7c95ca42 (patch)
treea479c2ee82fff7d73936ee2dfc5466ae4392d0eb /multimedia
parenta61fcf265a34c7902a4b92b736d05a8b32abdcfe (diff)
downloadfreebsd-ports-gnome-b7e9dd82868f21f7cbdcf8a8640f3d3f7c95ca42.tar.gz
freebsd-ports-gnome-b7e9dd82868f21f7cbdcf8a8640f3d3f7c95ca42.tar.zst
freebsd-ports-gnome-b7e9dd82868f21f7cbdcf8a8640f3d3f7c95ca42.zip
- Add gstreamer support & fix build when gstreamer is present
PR: 127624 Submitted by: "Eric L. Chen" <d9364104 at mail dot nchu dot edu dot tw> Improved by: me
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/schroedinger/Makefile16
-rw-r--r--multimedia/schroedinger/pkg-plist6
2 files changed, 20 insertions, 2 deletions
diff --git a/multimedia/schroedinger/Makefile b/multimedia/schroedinger/Makefile
index 76844f2ea4a1..283c88af5c38 100644
--- a/multimedia/schroedinger/Makefile
+++ b/multimedia/schroedinger/Makefile
@@ -7,6 +7,7 @@
PORTNAME= schroedinger
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.diracvideo.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +19,21 @@ LIB_DEPENDS= oil:${PORTSDIR}/devel/liboil
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+WANT_GSTREAMER= yes
+
+OPTIONS= GSTREAMER "Enable gstreamer plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GSTREAMER)
+CONFIGURE_ARGS+= --disable-gstreamer
+PLIST_SUB+= GSTREAMER="@comment "
+.else
+USE_GSTREAMER= yes
+PLIST_SUB+= GSTREAMER=""
+.endif
post-patch:
${REINPLACE_CMD} -e 's|^pkgconfigdir=.*|pkgconfigdir="\\$$(prefix)/libdata/pkgconfig"|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/schroedinger/pkg-plist b/multimedia/schroedinger/pkg-plist
index a1b4905bd635..67dcc42e7849 100644
--- a/multimedia/schroedinger/pkg-plist
+++ b/multimedia/schroedinger/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
include/schroedinger-1.0/schroedinger/schro-stdint.h
include/schroedinger-1.0/schroedinger/schro.h
include/schroedinger-1.0/schroedinger/schroanalysis.h
@@ -37,6 +36,9 @@ lib/libschroedinger-1.0.a
lib/libschroedinger-1.0.la
lib/libschroedinger-1.0.so
lib/libschroedinger-1.0.so.1
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.a
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.la
+%%GSTREAMER%%lib/gstreamer-0.10/libgstschro.so
libdata/pkgconfig/schroedinger-1.0.pc
share/gtk-doc/html/schroedinger/home.png
share/gtk-doc/html/schroedinger/index.html
@@ -78,5 +80,7 @@ share/gtk-doc/html/schroedinger/schropublic.html
share/gtk-doc/html/schroedinger/style.css
share/gtk-doc/html/schroedinger/up.png
@dirrm share/gtk-doc/html/schroedinger
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
@dirrm include/schroedinger-1.0/schroedinger
@dirrm include/schroedinger-1.0
reebsd-ports-gnome/commit/mail/enigmail?h=gstreamer0.10-removal&id=ebb23eab20b9c4ac3a90d126c97d84bd52cfa8ff'>Update to 0.83.4 release.ale2004-02-252-6/+4 * Try to fix bento error (the correct way to locate the wrkdir ofale2004-02-233-7/+7 * Respect WRKDIRPREFIX.ale2004-02-161-2/+2 * Update to 0.83.3 release.ale2004-02-152-5/+7 * Update to 0.83.2 release.ale2004-02-092-5/+5 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * - Fix build, restoring my original intention of copying the mozilla WRKSRCale2004-01-302-3/+6