aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-04-26 18:44:28 +0800
committerak <ak@FreeBSD.org>2013-04-26 18:44:28 +0800
commitbe0532aa1927751208f2697351ec6365d64f46e3 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /multimedia
parent1b4e8ae3fa9398a48e6c4797e41a32870c88ed6c (diff)
downloadfreebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.tar.gz
freebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.tar.zst
freebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.zip
- Convert USE_GETTEXT to USES (part 4)
Approved by: portmgr (bapt)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/aegisub/Makefile3
-rw-r--r--multimedia/beep-media-player/Makefile2
-rw-r--r--multimedia/bino/Makefile2
-rw-r--r--multimedia/freetuxtv/Makefile2
-rw-r--r--multimedia/gmerlin-avdecoder/Makefile3
-rw-r--r--multimedia/gmerlin/Makefile3
-rw-r--r--multimedia/gmtk/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile3
-rw-r--r--multimedia/gstreamer/Makefile3
-rw-r--r--multimedia/kdenlive/Makefile2
-rw-r--r--multimedia/kino/Makefile3
-rw-r--r--multimedia/libxine/Makefile2
-rw-r--r--multimedia/lives/Makefile2
-rw-r--r--multimedia/mkvtoolnix/Makefile3
-rw-r--r--multimedia/ogmrip/Makefile3
-rw-r--r--multimedia/quark/Makefile3
-rw-r--r--multimedia/sabbu/Makefile2
-rw-r--r--multimedia/totem-pl-parser/Makefile3
-rw-r--r--multimedia/totem/Makefile3
-rw-r--r--multimedia/vdr/Makefile3
-rw-r--r--multimedia/xfce4-media/Makefile3
-rw-r--r--multimedia/xfce4-parole/Makefile2
22 files changed, 22 insertions, 35 deletions
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index ac7cf0383196..b26dccb0c46d 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -28,7 +28,7 @@ EFENCE_DESC= Electric Fence (require profiling)
ASS_DESC= libASS subtitle provider
HUNSPELL_DESC= Spell checking via Hunspell
-USES= pkgconfig
+USES= pkgconfig gettext
USE_GNOME= intltool
USE_WX= 2.8
WX_COMPS= wx contrib
@@ -36,7 +36,6 @@ WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_GL= glu
USE_ICONV= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gcc-prec --without-lua50
diff --git a/multimedia/beep-media-player/Makefile b/multimedia/beep-media-player/Makefile
index 683a0993ce3d..675d2d19cf1b 100644
--- a/multimedia/beep-media-player/Makefile
+++ b/multimedia/beep-media-player/Makefile
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT= OSS VORBIS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
index 45a22c3a932c..6a0c2057d564 100644
--- a/multimedia/bino/Makefile
+++ b/multimedia/bino/Makefile
@@ -32,7 +32,7 @@ MAN1= bino.1
INFO= bino
.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/multimedia/freetuxtv/Makefile b/multimedia/freetuxtv/Makefile
index 6d306ce6f5b0..e54364a879fd 100644
--- a/multimedia/freetuxtv/Makefile
+++ b/multimedia/freetuxtv/Makefile
@@ -39,7 +39,7 @@ CONFIGURE_ARGS+=--with-gtk=2.0
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/multimedia/gmerlin-avdecoder/Makefile b/multimedia/gmerlin-avdecoder/Makefile
index c838555b6fd2..321589fe30ff 100644
--- a/multimedia/gmerlin-avdecoder/Makefile
+++ b/multimedia/gmerlin-avdecoder/Makefile
@@ -25,8 +25,7 @@ DVDREAD_DESC= libdvdread support
GMERLIN_DESC= gmerlin support
SAMBA_DESC= Samba support using libsmbclient
-USES= pathfix pkgconfig
-USE_GETTEXT= yes
+USES= pathfix pkgconfig gettext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cpuflags=none --without-doxygen
USE_LDCONFIG= yes
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index 8b84ea51c524..945d6aff373f 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -22,11 +22,10 @@ OPTIONS_DEFAULT= CDDB CDIO JACK JPEG LIBVISUAL \
OPTIMIZED_CFLAGS PNG PULSEAUDIO QUICKTIME \
TIFF
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-v4l --disable-v4l2 --disable-v4lconvert \
--without-doxygen --with-cpuflags=none --disable-musicbrainz
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gtk20 libxml2
USE_XORG= x11 xext xfixes xinerama xv
USE_GL= gl
diff --git a/multimedia/gmtk/Makefile b/multimedia/gmtk/Makefile
index 432a0a492caa..6eb33aa0d0ec 100644
--- a/multimedia/gmtk/Makefile
+++ b/multimedia/gmtk/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+= --disable-gtk3
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index e1a41e6f0e21..671c660fdcbd 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -41,13 +41,12 @@ UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= good
SHLIB_VERSION= 1
-USE_GETTEXT= yes
VERSION= ${GST_VERSION}
WANT_GSTREAMER= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME+= gnomehack ltverhack ltasneededhack
-USES= pkgconfig
+USES= pkgconfig gettext
USE_AUTOTOOLS= libtool
GST_PLUGIN?= base
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index 383aa4991c64..1ac3cc094b47 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -17,11 +17,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-i
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-USES= bison pathfix pkgconfig
+USES= bison pathfix pkgconfig gettext
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20 libxml2 ltverhack ltasneededhack
-USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-tests \
--disable-examples \
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index 88e62299ef1f..9de097d665ca 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -54,7 +54,7 @@ RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CMAKE_ARGS+= -DBUILD_po:BOOL=FALSE
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
index 976618444c3b..774386024875 100644
--- a/multimedia/kino/Makefile
+++ b/multimedia/kino/Makefile
@@ -22,9 +22,8 @@ FFMPEG_KINO_DESC= With ffmpeg-kino
USE_XORG= x11 xv ice
USE_AUTOTOOLS= autoconf
-USE_GETTEXT= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix libglade2 libxml2
USE_ICONV= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 730e0cfa6c9b..b227474f54b6 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -97,7 +97,7 @@ IGNORE= only builds with -O1 or higher, check CFLAGS
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 4d2f2e87a9ad..c0cdc5cb8a66 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -89,7 +89,7 @@ PLIST_SUB+= FREI0R="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index ea0432a33f46..5a6de9aae401 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -24,10 +24,9 @@ LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
ebml:${PORTSDIR}/textproc/libebml \
matroska:${PORTSDIR}/multimedia/libmatroska
-USES= pkgconfig
+USES= pkgconfig gettext
USE_BZIP2= yes
USE_GCC= 4.6+
-USE_GETTEXT= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_RAKE= yes
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 3bcbb627c3d8..a257c85448a1 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -33,9 +33,8 @@ MP4BOX_DESC= Enable Mpeg-4 container support
THEORA_DESC= Enable Ogg Theora video codec support
SRT_DESC= Enable SRT text subtitles support
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= glib20 intlhack libxml2
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/multimedia/quark/Makefile b/multimedia/quark/Makefile
index cd28091aa37e..4d7adfde622f 100644
--- a/multimedia/quark/Makefile
+++ b/multimedia/quark/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gnomevfs2
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 65a7ac3364e0..65f3dd17a457 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -26,7 +26,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= WITH_NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= WITH_NLS=""
.endif
diff --git a/multimedia/totem-pl-parser/Makefile b/multimedia/totem-pl-parser/Makefile
index 18dc1e58cd81..1dd2137fa2d9 100644
--- a/multimedia/totem-pl-parser/Makefile
+++ b/multimedia/totem-pl-parser/Makefile
@@ -19,9 +19,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-i
USE_BZIP2= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix glib20 libxml2 intlhack ltverhack
-USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index c30fed86752a..16b91e045ef6 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -26,8 +26,7 @@ CONFLICTS= totem-3.[0-9]*
USE_PYTHON= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack desktopfileutils \
nautilus2 ltverhack pygtk2 gnomehier
USE_GSTREAMER= core gconf hal good mpeg2dec soup ugly python gio
diff --git a/multimedia/vdr/Makefile b/multimedia/vdr/Makefile
index 3ba84d7fc332..07221cf7e4e6 100644
--- a/multimedia/vdr/Makefile
+++ b/multimedia/vdr/Makefile
@@ -22,11 +22,10 @@ DVBPATCH_DESC= DVB audio patch for some countries
STB0899_SIGNAL_DESC= STB0899 signal strength patch
OPTIONS_DEFAULT= IPTVPATCH TTXPATCH
-USES= pkgconfig
+USES= pkgconfig gettext
DIST_SUBDIR= vdr
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_ICONV= yes
PORTDOCS= COPYING INSTALL MANUAL README HISTORY
MAKE_JOBS_SAFE= yes
diff --git a/multimedia/xfce4-media/Makefile b/multimedia/xfce4-media/Makefile
index 4905303aeaf5..3f40131227ad 100644
--- a/multimedia/xfce4-media/Makefile
+++ b/multimedia/xfce4-media/Makefile
@@ -17,9 +17,8 @@ LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gettext
USE_GNOME= glib20 gtk20 intltool intlhack
USE_XFCE= configenv libexo libgui libutil panel
USE_XORG= x11 sm
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
index 9da1dae47ab0..c7085ca1caee 100644
--- a/multimedia/xfce4-parole/Makefile
+++ b/multimedia/xfce4-parole/Makefile
@@ -50,7 +50,7 @@ USE_GSTREAMER+= soup
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else