aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-27 04:46:25 +0800
committermiwi <miwi@FreeBSD.org>2009-07-27 04:46:25 +0800
commitc4d1d1c3df7d23fca07abb66f373c028d825b88e (patch)
treed92bbcebd300ab9423ef36db3b39a6bbe365e079 /multimedia
parent10e9351816ce147f73467721d0dd616b22b7a73a (diff)
downloadfreebsd-ports-gnome-c4d1d1c3df7d23fca07abb66f373c028d825b88e.tar.gz
freebsd-ports-gnome-c4d1d1c3df7d23fca07abb66f373c028d825b88e.tar.zst
freebsd-ports-gnome-c4d1d1c3df7d23fca07abb66f373c028d825b88e.zip
- Update to 1.0.0
PR: 137011 Submitted by: Ports Fury
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile26
-rw-r--r--multimedia/lives/distinfo6
-rw-r--r--multimedia/lives/pkg-plist21
3 files changed, 32 insertions, 21 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index f7a528336823..7a3710c9ed12 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -6,16 +6,14 @@
#
PORTNAME= lives
-PORTVERSION= 1.0.0.p1
-PORTREVISION= 1
+PORTVERSION= 1.0.0
CATEGORIES= multimedia
MASTER_SITES= http://www.xs4all.nl/~salsaman/lives/current/
-DISTNAME= LiVES-${PORTVERSION:S/.p/-pre/}
+DISTNAME= LiVES-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Video editing system
-BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
oil-0.3.0:${PORTSDIR}/devel/liboil \
visual-0.4.0:${PORTSDIR}/graphics/libvisual04 \
@@ -26,7 +24,6 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
sox:${PORTSDIR}/audio/sox \
ogg123:${PORTSDIR}/audio/vorbis-tools \
convert:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r \
sswf:${PORTSDIR}/graphics/sswf \
ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
mencoder:${PORTSDIR}/multimedia/mencoder \
@@ -37,6 +34,8 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
x264:${PORTSDIR}/multimedia/x264 \
xmms:${PORTSDIR}/multimedia/xmms
+OPTIONS= FREI0R "Enable frei0r support" off
+
WRKSRC= ${WRKDIR}/${DISTNAME:L}
USE_BZIP2= yes
@@ -63,6 +62,17 @@ DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FREI0R)
+BUILD_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+RUN_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+PLIST_SUB+= FREI0R=""
+.else
+CONFIGURE_ENV+= ac_cv_header_frei0r_h=no
+PLIST_SUB+= FREI0R="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/LIBS/s|-ldl ||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|: install-docDATA|:|g ; \
@@ -72,12 +82,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|off64_t|off_t|g ; \
s|lseek64|lseek|g' ${WRKSRC}/${file}
.endfor
+ @${REINPLACE_CMD} -e 's|/usr/lib/|${LOCALBASE}/lib/|g' \
+ ${WRKSRC}/lives-plugins/weed-plugins/frei0r.c
@${FIND} ${WRKSRC} -name "Makefile.in" -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e \
'/FLAGS/s|-O3||g ; \
/FLAGS/s|-ldl||g ; \
/flags/s|-L/usr/lib64||g ; \
- /flags/s|-W,-Bsymbolic||g ; \
+ /flags/s|-Wl,-Bsymbolic||g ; \
/flags/s|--tag=disable-static||g'
post-install:
@@ -88,4 +100,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index cbde226c4b8c..9599c28386f2 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,3 +1,3 @@
-MD5 (LiVES-1.0.0-pre1.tar.bz2) = b36ac5dfe0ad34a9bb8b9f1a393395b7
-SHA256 (LiVES-1.0.0-pre1.tar.bz2) = 2b53a09d40a8ac4f4420d3c38d359b75584afb1de5a91fe8d986977d198ca9ee
-SIZE (LiVES-1.0.0-pre1.tar.bz2) = 2448449
+MD5 (LiVES-1.0.0.tar.bz2) = 8ea46b36ac641852b115e08c7edd52f8
+SHA256 (LiVES-1.0.0.tar.bz2) = 17b18391ef4873da2a07ddd1e7288a497052a70e326f17d6c6295ed765c601c4
+SIZE (LiVES-1.0.0.tar.bz2) = 2781862
diff --git a/multimedia/lives/pkg-plist b/multimedia/lives/pkg-plist
index 98018bfc8065..7455652a0a44 100644
--- a/multimedia/lives/pkg-plist
+++ b/multimedia/lives/pkg-plist
@@ -62,8 +62,8 @@ lib/lives/plugins/effects/realtime/weed/fg_bg_removal.la
lib/lives/plugins/effects/realtime/weed/fg_bg_removal.so
lib/lives/plugins/effects/realtime/weed/fireTV.la
lib/lives/plugins/effects/realtime/weed/fireTV.so
-lib/lives/plugins/effects/realtime/weed/frei0r.la
-lib/lives/plugins/effects/realtime/weed/frei0r.so
+%%FREI0R%%lib/lives/plugins/effects/realtime/weed/frei0r.la
+%%FREI0R%%lib/lives/plugins/effects/realtime/weed/frei0r.so
lib/lives/plugins/effects/realtime/weed/gdk_fast_resize.la
lib/lives/plugins/effects/realtime/weed/gdk_fast_resize.so
lib/lives/plugins/effects/realtime/weed/haip.la
@@ -263,23 +263,22 @@ share/applications/LiVES.desktop
%%DATADIR%%/plugins/effects/RFXscripts/wave.script
%%DATADIR%%/themes/camera/frame.jpg
%%DATADIR%%/themes/camera/main.jpg
+%%DATADIR%%/themes/crayons/frame.jpg
+%%DATADIR%%/themes/crayons/main.jpg
+%%DATADIR%%/themes/crayons-bright/frame.jpg
+%%DATADIR%%/themes/crayons-bright/main.jpg
%%DATADIR%%/themes/cutting_room/frame.jpg
%%DATADIR%%/themes/cutting_room/main.jpg
-%%DATADIR%%/themes/default/frame.jpg
-%%DATADIR%%/themes/default/main.jpg
%%DATADIR%%/themes/editor/frame.jpg
%%DATADIR%%/themes/editor/main.jpg
-%%DATADIR%%/themes/greenish/frame.jpg
-%%DATADIR%%/themes/greenish/main.jpg
%%DATADIR%%/themes/lives-splash.png
%%DATADIR%%/themes/pinks/frame.jpg
%%DATADIR%%/themes/pinks/main.jpg
-%%DATADIR%%/themes/sunburst/frame.jpg
-%%DATADIR%%/themes/sunburst/main.jpg
share/locale/cs/LC_MESSAGES/lives.mo
share/locale/de_DE/LC_MESSAGES/lives.mo
share/locale/es/LC_MESSAGES/lives.mo
share/locale/fr/LC_MESSAGES/lives.mo
+share/locale/he/LC_MESSAGES/lives.mo
share/locale/hu/LC_MESSAGES/lives.mo
share/locale/it/LC_MESSAGES/lives.mo
share/locale/ja/LC_MESSAGES/lives.mo
@@ -288,15 +287,15 @@ share/locale/pl/LC_MESSAGES/lives.mo
share/locale/pt/LC_MESSAGES/lives.mo
share/locale/pt_BR/LC_MESSAGES/lives.mo
share/locale/ru/LC_MESSAGES/lives.mo
+share/locale/sk/LC_MESSAGES/lives.mo
share/locale/tr/LC_MESSAGES/lives.mo
share/locale/zh_CN/LC_MESSAGES/lives.mo
share/pixmaps/lives.xpm
-@dirrm %%DATADIR%%/themes/sunburst
@dirrm %%DATADIR%%/themes/pinks
-@dirrm %%DATADIR%%/themes/greenish
@dirrm %%DATADIR%%/themes/editor
-@dirrm %%DATADIR%%/themes/default
@dirrm %%DATADIR%%/themes/cutting_room
+@dirrm %%DATADIR%%/themes/crayons-bright
+@dirrm %%DATADIR%%/themes/crayons
@dirrm %%DATADIR%%/themes/camera
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/plugins/effects/RFXscripts