aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /multimedia
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avifile/Makefile1
-rw-r--r--multimedia/camserv/Makefile1
-rw-r--r--multimedia/emovix/Makefile1
-rw-r--r--multimedia/kaffeine/Makefile1
-rw-r--r--multimedia/libdvbpsi/Makefile1
-rw-r--r--multimedia/libdvdread/Makefile2
-rw-r--r--multimedia/libfame/Makefile2
-rw-r--r--multimedia/motion/Makefile2
-rw-r--r--multimedia/nmm/Makefile1
-rw-r--r--multimedia/sublib/Makefile1
-rw-r--r--multimedia/toxine/Makefile1
11 files changed, 0 insertions, 14 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 752dc0f6fa21..7a4a418fc318 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -33,7 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gnu-ld --enable-iconv \
--disable-v4l \
--disable-divx4
-CONFIGURE_TARGET=
PLIST_SUB= LIB_VERSION="${LIB_VERSION}" VERSION="${VERSION}"
diff --git a/multimedia/camserv/Makefile b/multimedia/camserv/Makefile
index 12f7c872d341..774591f0b8dd 100644
--- a/multimedia/camserv/Makefile
+++ b/multimedia/camserv/Makefile
@@ -25,7 +25,6 @@ ONLY_FOR_ARCHS= i386 alpha
USE_AUTOTOOLS= autoconf:262 libtool:15 libltdl:15
USE_EFL= imlib2
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/gtk12 \
-I${LOCALBASE}/include/gdk-pixbuf-1.0 \
diff --git a/multimedia/emovix/Makefile b/multimedia/emovix/Makefile
index e0e9948dc3cb..2be265249fed 100644
--- a/multimedia/emovix/Makefile
+++ b/multimedia/emovix/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= h.eichmann@gmx.de
COMMENT= A mini linux distro to create bootable video CDs
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_PERL5= yes
USE_PERL5_BUILD=yes
diff --git a/multimedia/kaffeine/Makefile b/multimedia/kaffeine/Makefile
index 89137b32e822..75a891b00b22 100644
--- a/multimedia/kaffeine/Makefile
+++ b/multimedia/kaffeine/Makefile
@@ -24,7 +24,6 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CXXFLAGS="${CFLAGS} -I${WRKSRC}" CFLAGS="${CFLAGS} -I${WRKSRC}"
-CONFIGURE_TARGET=
DVB_HEADERS= ca.h dmx.h frontend.h net.h audio.h video.h
.ifdef (WITH_GSTREAMER)
diff --git a/multimedia/libdvbpsi/Makefile b/multimedia/libdvbpsi/Makefile
index 06dfe9e59cdc..0fc50cb7630e 100644
--- a/multimedia/libdvbpsi/Makefile
+++ b/multimedia/libdvbpsi/Makefile
@@ -20,7 +20,6 @@ USE_DOS2UNIX= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if defined(WITH_DEBUG)
CONFIGURE_ARGS= --enable-debug
.else
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index a80216372b37..09b3c7d3eae6 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -22,8 +22,6 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-
DOC_FILES= AUTHORS COPYING NEWS README TODO
# allow build with more warnings enabled
diff --git a/multimedia/libfame/Makefile b/multimedia/libfame/Makefile
index 3507d4396006..eed530d3d778 100644
--- a/multimedia/libfame/Makefile
+++ b/multimedia/libfame/Makefile
@@ -20,8 +20,6 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
MAN3= fame_close.3 fame_encode_frame.3 fame_get_object.3 fame_init.3 \
fame_open.3 fame_register.3 fame_unregister.3 fame_encode_slice.3 \
fame_start_frame.3 fame_end_frame.3
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 5da612f07c0d..484950e7763e 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -22,8 +22,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
ONLY_FOR_ARCHS= i386 amd64
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
MAN1= motion.1
USE_AUTOTOOLS= autoconf:262
diff --git a/multimedia/nmm/Makefile b/multimedia/nmm/Makefile
index a8a244629b87..60055a2227ff 100644
--- a/multimedia/nmm/Makefile
+++ b/multimedia/nmm/Makefile
@@ -47,7 +47,6 @@ USE_AUTOTOOLS= libltdl libtool:15 \
autoconf:262:env autoheader:262:env \
automake:19:env aclocal:19:env
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --program-prefix=nmm- \
--enable-final \
--disable-examples-helloworld --disable-examples-avmux \
diff --git a/multimedia/sublib/Makefile b/multimedia/sublib/Makefile
index 5219b8df777e..806b964338fc 100644
--- a/multimedia/sublib/Makefile
+++ b/multimedia/sublib/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
USE_ZIP= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GNOME= gnomehack
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
diff --git a/multimedia/toxine/Makefile b/multimedia/toxine/Makefile
index f89f84671050..d7ab0a8c8ae3 100644
--- a/multimedia/toxine/Makefile
+++ b/multimedia/toxine/Makefile
@@ -18,7 +18,6 @@ COMMENT= Text user interface using the xine library
LIB_DEPENDS= xine.1:${PORTSDIR}/multimedia/libxine
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= AALIB "Enable aalib support" on \