aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2009-05-10 13:51:11 +0800
committernobutaka <nobutaka@FreeBSD.org>2009-05-10 13:51:11 +0800
commitdbd50ba2cc8106012dfea3065761a8c31b56e341 (patch)
treecf5282d511e023113801a1fe0d9f72b9e43a439a /multimedia
parent85a6345279d573a6ff0def8d567ef1387be8368c (diff)
downloadfreebsd-ports-gnome-dbd50ba2cc8106012dfea3065761a8c31b56e341.tar.gz
freebsd-ports-gnome-dbd50ba2cc8106012dfea3065761a8c31b56e341.tar.zst
freebsd-ports-gnome-dbd50ba2cc8106012dfea3065761a8c31b56e341.zip
- Update to 1.1.16.3.
- Fix hardcoded libdvdcss shared library version. [*] PR: ports/134153 [*] Submitted by: Joseph S. Atkinson <jsa@wickedmachine.net> [*], jpaetzel [*]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile19
-rw-r--r--multimedia/libxine/distinfo6
-rw-r--r--multimedia/libxine/files/patch-configure30
3 files changed, 34 insertions, 21 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index a6da4e6b1eb6..96789927402f 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 1.1.16.2
-PORTREVISION= 1
+PORTVERSION= 1.1.16.3
CATEGORIES= multimedia ipv6
MASTER_SITES= SF
PKGNAMEPREFIX= lib
@@ -31,6 +30,10 @@ LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
mad.2:${PORTSDIR}/audio/libmad \
dca.0:${PORTSDIR}/multimedia/libdca
+.if !defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
+.endif
+
USE_BZIP2= yes
USE_GETTEXT= yes
USE_ICONV= yes
@@ -72,7 +75,11 @@ MAN1= xine-config.1 xine-list-1.1.1
MAN5= xine.5
DOCSDIR= ${PREFIX}/share/doc/xine-lib
-PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.25"
+PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.26"
+
+# DVDCSS version hardcoded in src/input/input_dvd.c misc/cdda_server.c
+# and src/input/libdvdnav/dvd_input.c (dlopen'ed)
+DVDCSS_LIBVERSION= 3
.include <bsd.port.pre.mk>
@@ -207,6 +214,12 @@ post-patch:
/freebsd-elf)/,/;;/ s|versuffix="\.$$current"|versuffix="$$major"|' \
${WRKSRC}/${f}
.endfor
+ @${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/src/input/input_dvd.c
+ @${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/misc/cdda_server.c
+ @${REINPLACE_CMD} -E -e 's|(libdvdcss.so)\.2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/src/input/libdvdnav/dvd_input.c
pre-configure:
@${REINPLACE_CMD} -e \
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index 72e556bf2cd8..383fb5de6c65 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1,3 +1,3 @@
-MD5 (xine-lib-1.1.16.2.tar.bz2) = 336dd1f6266e9f943430ca6009b7aa7e
-SHA256 (xine-lib-1.1.16.2.tar.bz2) = 67f2469faee964b75f43459547b5e2f9a407b8dc30cbeffa989cce312e16b2c1
-SIZE (xine-lib-1.1.16.2.tar.bz2) = 7407399
+MD5 (xine-lib-1.1.16.3.tar.bz2) = 4f508abf088cf427a731f85634c8260d
+SHA256 (xine-lib-1.1.16.3.tar.bz2) = d25a241efa55dc7d8f482336efa8bb7b9bb9d69b6df8a8a37f2660948fd67b52
+SIZE (xine-lib-1.1.16.3.tar.bz2) = 7468182
diff --git a/multimedia/libxine/files/patch-configure b/multimedia/libxine/files/patch-configure
index de875dfd1d26..2a8ce001c8e8 100644
--- a/multimedia/libxine/files/patch-configure
+++ b/multimedia/libxine/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2009-02-11 03:35:05.000000000 +0900
-+++ configure 2009-02-22 18:37:34.000000000 +0900
-@@ -10363,6 +10363,12 @@
+--- configure.orig 2009-05-06 22:57:51.000000000 +0900
++++ configure 2009-05-06 23:03:23.000000000 +0900
+@@ -10918,6 +10918,12 @@
fi
;;
@@ -13,7 +13,7 @@
netbsd* | netbsdelf*-gnu)
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
-@@ -13853,7 +13859,7 @@
+@@ -14450,7 +14456,7 @@
if test -z "$haveit"; then
LIBICONV="${LIBICONV}${LIBICONV:+ }-L$found_dir"
fi
@@ -22,39 +22,39 @@
LIBICONV="${LIBICONV}${LIBICONV:+ }$found_so"
else
LIBICONV="${LIBICONV}${LIBICONV:+ }-l$name"
-@@ -26519,12 +26525,12 @@
+@@ -27953,12 +27959,12 @@
pkg_cv_CACA_CFLAGS="$CACA_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
-+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
+ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
+ pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
else
pkg_failed=yes
fi
-@@ -26537,12 +26543,12 @@
+@@ -27971,12 +27977,12 @@
pkg_cv_CACA_LIBS="$CACA_LIBS"
else
if test -n "$PKG_CONFIG" && \
-- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
+- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
-+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
++ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
+ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
+ pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
else
pkg_failed=yes
fi
-@@ -26561,9 +26567,9 @@
+@@ -27995,9 +28001,9 @@
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
@@ -66,7 +66,7 @@
fi
# Put the nasty error message in config.log where it belongs
echo "$CACA_PKG_ERRORS" >&5
-@@ -29191,6 +29197,8 @@
+@@ -30662,6 +30668,8 @@
fi
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
@@ -75,7 +75,7 @@
fi
if test "x$no_libFLAC" = "x" ; then
-@@ -42228,7 +42236,7 @@
+@@ -43882,7 +43890,7 @@
xinelibdir='${libdir}/xine'
xinedatadir='${datadir}/xine'