aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-06 09:13:37 +0800
committeredwin <edwin@FreeBSD.org>2007-09-06 09:13:37 +0800
commite5cc186f87d8844abbdce10771c577fe96574160 (patch)
treeb3b4279d5e1343437faad86f747d9c75c67a84b1 /multimedia
parent06cc52b1a84f54bfd6d4081ea863794e1ee4f566 (diff)
downloadfreebsd-ports-gnome-e5cc186f87d8844abbdce10771c577fe96574160.tar.gz
freebsd-ports-gnome-e5cc186f87d8844abbdce10771c577fe96574160.tar.zst
freebsd-ports-gnome-e5cc186f87d8844abbdce10771c577fe96574160.zip
[patch] multimedia/pvr250: unbreak on -CURRENT
newbus API has changed. patch accordingly. PR: ports/116128 Submitted by: Simun Mikecin <numisemis@yahoo.com> Approved by: edwin@
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/pvr250/Makefile5
-rw-r--r--multimedia/pvr250/files/extra-patch-dev::cxm::cxm.c11
-rw-r--r--multimedia/pvr250/files/extra-patch-dev::cxm::cxm.h20
3 files changed, 36 insertions, 0 deletions
diff --git a/multimedia/pvr250/Makefile b/multimedia/pvr250/Makefile
index a84e0362ea4b..cbb069f0d9bb 100644
--- a/multimedia/pvr250/Makefile
+++ b/multimedia/pvr250/Makefile
@@ -39,6 +39,11 @@ MODULESDIR= /boot/kernel
.endif
PLIST_SUB= MODULESDIR=${MODULESDIR}
+.if ${OSVERSION} >= 700031
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-dev::cxm::cxm.h \
+ ${PATCHDIR}/extra-patch-dev::cxm::cxm.c
+.endif
+
.if !exists(${DISTDIR}/hcwPVRP2.sys)
IGNORE= You need the file hcwPVRP2.sys from the CD coming with the PVR-250/350 card. Please place this file in ${DISTDIR} and run make again.
.endif
diff --git a/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.c b/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.c
new file mode 100644
index 000000000000..8d1b865b3de0
--- /dev/null
+++ b/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.c
@@ -0,0 +1,11 @@
+--- dev/cxm/cxm.c.orig 2007-09-05 19:08:24.707875447 +0200
++++ dev/cxm/cxm.c 2007-09-05 19:08:17.000000000 +0200
+@@ -1799,7 +1799,7 @@
+ }
+
+ error = bus_setup_intr(dev, sc->irq_res, INTR_TYPE_TTY,
+- cxm_intr, sc, &sc->ih_cookie);
++ NULL, cxm_intr, sc, &sc->ih_cookie);
+ if (error) {
+ device_printf(dev, "could not setup irq\n");
+ goto fail;
diff --git a/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.h b/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.h
new file mode 100644
index 000000000000..5f525b5625c6
--- /dev/null
+++ b/multimedia/pvr250/files/extra-patch-dev::cxm::cxm.h
@@ -0,0 +1,20 @@
+--- dev/cxm/cxm.h.orig 2007-09-05 19:10:08.361061000 +0200
++++ dev/cxm/cxm.h 2007-09-05 19:14:25.486827125 +0200
+@@ -211,8 +211,6 @@
+ cxm_pal_60hz_source_format,
+ cxm_secam_50hz_source_format };
+
+-extern const struct cxm_tuner cxm_tuners[];
+-
+ enum cxm_type { cxm_unknown_type, cxm_iTVC15_type, cxm_iTVC16_type };
+
+ /*
+@@ -635,6 +633,8 @@
+ const struct cxm_saa7115_command *scaling;
+ };
+
++extern const struct cxm_tuner cxm_tuners[];
++
+ int cxm_saa7115_init( struct cxm_softc *sc );
+ int cxm_saa7115_mute( struct cxm_softc *sc );
+ int cxm_saa7115_unmute( struct cxm_softc *sc );