aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-11 20:58:40 +0800
committerbapt <bapt@FreeBSD.org>2013-05-11 20:58:40 +0800
commitf486fae1e58629d92b1f794b4f60cc9fc1283478 (patch)
tree2ec79ba0438e788ff8ca417ef033f5706959398e /multimedia
parentf69f231146e5bf6f00ac4e8196a730688545c46a (diff)
downloadfreebsd-ports-gnome-f486fae1e58629d92b1f794b4f60cc9fc1283478.tar.gz
freebsd-ports-gnome-f486fae1e58629d92b1f794b4f60cc9fc1283478.tar.zst
freebsd-ports-gnome-f486fae1e58629d92b1f794b4f60cc9fc1283478.zip
Convert to new options framework
While here remove test for unsupported versions
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/cuse4bsd-kmod/Makefile12
-rw-r--r--multimedia/fxtv/Makefile15
-rw-r--r--multimedia/libbluray/Makefile11
-rw-r--r--multimedia/libvpx/Makefile35
-rw-r--r--multimedia/pwcbsd/Makefile30
5 files changed, 37 insertions, 66 deletions
diff --git a/multimedia/cuse4bsd-kmod/Makefile b/multimedia/cuse4bsd-kmod/Makefile
index 698595747307..96790e15cca8 100644
--- a/multimedia/cuse4bsd-kmod/Makefile
+++ b/multimedia/cuse4bsd-kmod/Makefile
@@ -26,17 +26,13 @@ PLIST_SUB= KMODNAME="${KMODNAME}" \
INCLUDEDIR="${INCLUDEDIR}" \
MANDIR="${MANDIR}"
-OPTIONS= DEBUG "Build with debugging support" Off
+OPTIONS_DEFINE= DEBUG
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-IGNORE= requires FreeBSD 8.0-RELEASE or later
-.endif
+.include <bsd.port.options.mk>
MAKE_ARGS+=" PTHREAD_LIBS=${PTHREAD_LIBS}"
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
MAKE_ARGS+=" HAVE_DEBUG=YES"
.endif
@@ -45,4 +41,4 @@ do-install:
${INSTALL_KLD} ${WRKSRC}/${KMODNAME}.ko ${KMODDIR}
kldxref ${KMODDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index 3b20c489f923..639b83131237 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fxtv
-# Date created: Thu Nov 4 19:54:04 EST 1999
-# Whom: Randall Hopper <aa8vb@nc.rr.com>
-#
+# Created by: Randall Hopper <aa8vb@nc.rr.com>
# $FreeBSD$
-#
PORTNAME= fxtv
PORTVERSION= 1.03
@@ -27,13 +23,14 @@ MAN1= fxtv.1
ONLY_FOR_ARCHS= alpha i386 ia64 amd64
-OPTIONS= EXTRA "Extra programs required to record/playback/save" off
+OPTIONS_DEFINE= EXTRA
+EXTRA_DESC= Extra programs required to record/playback/save
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# This program does not actually require the programs below unless you
# use audio/video recording and/or playback and save to a non-raw format.
-.if defined(WITH_EXTRA)
+.if ${PORT_OPTIONS:MEXTRA}
RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox \
mpg123:${PORTSDIR}/audio/mpg123 \
mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
@@ -43,4 +40,4 @@ RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox \
pre-install:
${CP} ${WRKSRC}/fxtv.1 ${WRKSRC}/fxtv.man
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/libbluray/Makefile b/multimedia/libbluray/Makefile
index 26abf0a49082..3b930b6f05c5 100644
--- a/multimedia/libbluray/Makefile
+++ b/multimedia/libbluray/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libbluray
-# Date created: 19 February 2011
-# Whom: kamikaze@bsdforen.de
-#
+# Created by: kamikaze@bsdforen.de
# $FreeBSD$
-#
PORTNAME= libbluray
PORTVERSION= 0.2.2
@@ -32,11 +28,12 @@ MAKE_JOBS_SAFE= yes
MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
CFLAGS=${CFLAGS:Q}
-OPTIONS= JAVA "Enable Blu-Ray Java support" off
+OPTIONS_DEFINE= JAVA
+JAVA_DESC+ Enable Blu-Ray Java support
.include <bsd.port.options.mk>
-.if defined(WITH_JAVA)
+.if ${PORT_OPTIONS:MJAVA}
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
CATEGORIES+= java
USE_JAVA= 1.6+
diff --git a/multimedia/libvpx/Makefile b/multimedia/libvpx/Makefile
index 66461adc9485..1eaaa65b0ca0 100644
--- a/multimedia/libvpx/Makefile
+++ b/multimedia/libvpx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libvpx
-# Date created: 2010-05-21
-# Whom: Ashish SHUKLA <ashish@FreeBSD.org>
-#
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libvpx
PORTVERSION= 1.1.0
@@ -28,11 +24,11 @@ MAKE_JOBS_SAFE=yes
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= DEBUG "Enable debugging" OFF \
- POSTPROC "Enable postprocessing" ON \
- RUNTIME "Enable runtime CPU detection" ON \
- THREADS "Enable multithread" ON \
- SHARED "Enable shared-library support" ON
+OPTIONS_DEFINE= DEBUG POSTPROC RUNTIME THREADS SHARED
+OPTIONS_DEFAULT= POSTPROC RUNTIME THREADS SHARED
+POSTPROC_DESC= Enable postprocessing
+RUNTIME_DESC= Enable runtime CPU detection
+SHARED_DESC= Enable shared-library support
ALL_TARGET=
CONFIGURE_ARGS+= --enable-pic --disable-install-srcs --enable-vp8 --disable-install-docs
@@ -40,31 +36,29 @@ MAKE_ARGS+= DIST_DIR=${PREFIX} verbose=yes
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITH_POSTPROC)
+.if ${PORT_OPTIONS:MPOSTPROC}
CONFIGURE_ARGS+= --enable-postproc
.endif
-.if defined(WITH_RUNTIME)
+.if ${PORT_OPTIONS:MRUNTIME}
CONFIGURE_ARGS+= --enable-runtime-cpu-detect
.endif
-.if defined(WITHOUT_THREADS)
+.if ! ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --disable-multithread
.endif
-.if defined(WITH_SHARED)
+.if ${PORT_OPTIONS:MSHARED}
CONFIGURE_ARGS+= --enable-shared
PLIST_SUB+= SHARED=""
.else
PLIST_SUB+= SHARED="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "amd64"
CONFIGURE_ARGS+= --target=x86_64-linux-gcc
.elif ${ARCH} == "i386"
@@ -84,12 +78,7 @@ post-patch:
${WRKSRC}/build/make/configure.sh
@${GREP} -Rl '^#!/bin/bash' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e 's,#!/bin/bash,#!/usr/bin/env bash,g'
-.if ${OSVERSION} < 700000
- @${GREP} -Rl 'LIBVPX_SO.*extralibs' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
- -e 's/\(LIBVPX_SO.*extralibs[[:space:]]*+=[[:space:]]*\)/\1-lc /g'
-.else
@${GREP} -Rl -- '-l\?pthread' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} -E \
-e 's/-l?pthread/${PTHREAD_LIBS}/g'
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
index f2387e3373e6..1a4f9b6abc07 100644
--- a/multimedia/pwcbsd/Makefile
+++ b/multimedia/pwcbsd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pwcbsd
-# Date created: 17 Feb 2006
-# Whom: Raaf <freebsd@luna.afraid.org>
-#
+# Created by: Raaf <freebsd@luna.afraid.org>
# $FreeBSD$
-#
PORTNAME= pwcbsd
PORTVERSION= 1.4.1
@@ -24,33 +20,29 @@ MAN4= pwc.4
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
-OPTIONS= PROGRAMS "Build the programs" on \
- MMAP "Enable mmap support (MAY CRASH YOUR SYSTEM)" off
+OPTIONS_DEFINE= PROGRAMS MMAP
+OPTIONS_DEFAULT= PROGRAMS
+PROGRAMS_DESC= Build the programs
+MMAP_DESC= Enable mmap support (MAY CRASH YOUR SYSTEM)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if (${OSVERSION} > 800063) && (${OSVERSION} < 800094)
-BROKEN= Please update to a newer version of FreeBSD 8
-.endif
-
-.if ${OSVERSION} >= 800094
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.kld \
${FILESDIR}/extra-patch-pwc-ctrl.c \
${FILESDIR}/extra-patch-pwc-v4l.c \
${FILESDIR}/extra-patch-pwc.c \
${FILESDIR}/extra-patch-pwc.h
-.endif
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source files
.endif
-.if defined(WITH_MMAP)
+.if ${PORT_OPTIONS:MMMAP}
ALL_TARGET= mmap
.else
ALL_TARGET= all
.endif
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
ALL_TARGET+= pwcview
PROGRAMS= pwcview
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -62,16 +54,16 @@ PLIST_SUB+= PROGRAMS="@comment "
.endif
post-patch:
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
.endif
post-install:
${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
-.if !defined(WITHOUT_PROGRAMS)
+.if ${PORT_OPTIONS:MPROGRAMS}
${INSTALL_PROGRAM} ${PROGRAMS:S|^|${WRKSRC}/|} ${PREFIX}/bin
${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/|} ${PREFIX}/man/man1
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>