aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
committernetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
commit41aa99b87f1fc1de75ee54ee38b4782ee393704b (patch)
tree377e4c9c9dd556f0b4785f3df7b930015778713f /multimedia
parent0a7250c8120524f20b14e530af6f7eddf2e77d1e (diff)
downloadfreebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.gz
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.zst
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/linux-divx4linux/Makefile2
-rw-r--r--multimedia/linux-divx4linux4/Makefile2
-rw-r--r--multimedia/linux-divxplayer/Makefile3
-rw-r--r--multimedia/linux-realplayer/Makefile3
-rw-r--r--multimedia/linux-xmovie/Makefile3
-rw-r--r--multimedia/mtv/Makefile4
-rw-r--r--multimedia/netshow/Makefile3
7 files changed, 17 insertions, 3 deletions
diff --git a/multimedia/linux-divx4linux/Makefile b/multimedia/linux-divx4linux/Makefile
index d3d15a0f593e..e4ad9dae3f41 100644
--- a/multimedia/linux-divx4linux/Makefile
+++ b/multimedia/linux-divx4linux/Makefile
@@ -7,6 +7,7 @@
PORTNAME= divx4linux
PORTVERSION= 5.0.${RELEASE_DATE}
+PORTREVISION= 1
CATEGORIES= multimedia linux
MASTER_SITES= http://download.divx.com/divx/
PKGNAMEPREFIX= linux-
@@ -20,6 +21,7 @@ RESTRICTED= unsure of licensing issues
ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${RELEASE_DATE}
NO_BUILD= yes
PLIST_SUB= PKGNAME="${PKGNAME}"
diff --git a/multimedia/linux-divx4linux4/Makefile b/multimedia/linux-divx4linux4/Makefile
index b7cf07455fa7..0fc175a878a2 100644
--- a/multimedia/linux-divx4linux4/Makefile
+++ b/multimedia/linux-divx4linux4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= divx4linux
PORTVERSION= 0.${RELEASE_DATE:S/_/./}
+PORTREVISION= 1
CATEGORIES= multimedia linux
MASTER_SITES= http://download.divx.com/videocodecs/linux/
PKGNAMEPREFIX= linux-
@@ -20,6 +21,7 @@ RESTRICTED= unsure of licensing issues
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME:C/_.+$//}
NO_BUILD= yes
diff --git a/multimedia/linux-divxplayer/Makefile b/multimedia/linux-divxplayer/Makefile
index 92f620c39b57..a8df55abace5 100644
--- a/multimedia/linux-divxplayer/Makefile
+++ b/multimedia/linux-divxplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= divxplayer
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= multimedia linux
MASTER_SITES= http://download.divx.com/player/
PKGNAMEPREFIX= linux-
@@ -15,6 +16,8 @@ DISTNAME= divx-player-installer
MAINTAINER= lioux@FreeBSD.org
COMMENT= DivX(TM) Video Player for Linux from DivX.com
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index 84c570a41ffb..3b8a9963e9a4 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linux-realplayer
PORTVERSION= 10.0.2
+PORTREVISION= 1
CATEGORIES= multimedia audio linux
MASTER_SITES= https://helixcommunity.org/download.php/801/
DISTNAME= RealPlayer-${PORTVERSION}.608-20041214.i586
@@ -17,13 +18,13 @@ COMMENT= Linux RealPlayer 10 from RealNetworks
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
RUN_DEPENDS= \
- ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8 \
${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2
WRKSRC= ${WRKDIR}/usr/local/RealPlayer
ONLY_FOR_ARCHS= i386
RESTRICTED= "Redistribution not allowed"
NO_BUILD= yes
+USE_LINUX= yes
# Linux binary should not be stripped by INSTALL_PROGRAM
# because as a side effect it brands the binary as FreeBSD.
diff --git a/multimedia/linux-xmovie/Makefile b/multimedia/linux-xmovie/Makefile
index 9b1d2310a1fd..fdc061ecdf0f 100644
--- a/multimedia/linux-xmovie/Makefile
+++ b/multimedia/linux-xmovie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmovie
PORTVERSION= 1.9.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= heroines
@@ -19,6 +19,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= A movie player for AVI, MPEG-2/4 and MOV movies
EXTRACT_DEPENDS=rpm2cpio:${PORTSDIR}/archivers/rpm
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
diff --git a/multimedia/mtv/Makefile b/multimedia/mtv/Makefile
index 0bc6cd08ce09..d74996b437b6 100644
--- a/multimedia/mtv/Makefile
+++ b/multimedia/mtv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mtv
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= multimedia linux
MASTER_SITES= ftp://ftp.mpegtv.com/pub/mpeg/mpegtv/player/x86-unknown-linux-glibc/packages/TGZ/
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz libSDLx11.so.tar.gz
@@ -14,7 +15,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz libSDLx11.so.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= High-performance MPEG video player (shareware)
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
NO_PACKAGE= "No redistribution"
@@ -22,6 +23,7 @@ NO_CDROM= "No redistribution"
NO_BUILD= yes
NO_FILTER_SHLIBS=yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/mtv
MAN1= mtv.1
diff --git a/multimedia/netshow/Makefile b/multimedia/netshow/Makefile
index 7d1ade4f4158..b25855082bf8 100644
--- a/multimedia/netshow/Makefile
+++ b/multimedia/netshow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netshow
PORTVERSION= 2.00.251
+PORTREVISION= 1
CATEGORIES= multimedia linux net
MASTER_SITES= http://www.microsoft.com/netshow/download/en/beta/
DISTNAME= netshow_linux
@@ -15,6 +16,8 @@ EXTRACT_SUFX= .gz
MAINTAINER= dburr@FreeBSD.org
COMMENT= Microsoft NetShow video stream player
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
RESTRICTED= "Commercial software"
BROKEN= Unfetchable