aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-26 22:31:02 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-26 22:31:02 +0800
commit49409061681515ab339d9c49a607a8708bc722b5 (patch)
tree14179114208904408d24f202fc2455a6a911a95d /multimedia
parent36125d5079305ecb40f63c581fdb690eb7bd6ed1 (diff)
downloadfreebsd-ports-gnome-49409061681515ab339d9c49a607a8708bc722b5.tar.gz
freebsd-ports-gnome-49409061681515ab339d9c49a607a8708bc722b5.tar.zst
freebsd-ports-gnome-49409061681515ab339d9c49a607a8708bc722b5.zip
multimedia/x265: unbreak on aarch64[1] and mips
/usr/bin/ld: common/CMakeFiles/common.dir/common.cpp.o: relocation R_AARCH64_ADR_PREL_PG_HI21 against external symbol `__stderrp@@FBSD_1.0' can not be used when making a shared object; recompile with -fPIC /usr/bin/ld: common/CMakeFiles/common.dir/common.cpp.o(.text+0x1e0): unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `__stderrp@@FBSD_1.0' /usr/bin/ld: final link failed: Bad value /usr/bin/ld: x265: hidden symbol `__sync_fetch_and_add_4' in /usr/lib/libgcc.a(stdatomic.o) is referenced by DSO /usr/bin/ld: final link failed: Nonrepresentable section on output PR: 216473 [1] Reported by: pkg-fallout Submitted by: mikael.urankar@gmail.com [1] Approved by: portmgr blanket
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/x265/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 50699d76201a..9a931108931e 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -19,12 +19,13 @@ BUILD_DEPENDS= yasm:devel/yasm
USES= cmake pathfix tar:bz2
USE_LDCONFIG= yes
CMAKE_ARGS= -DENABLE_TESTS=on -DPLATFORM_LIBS=md
+CFLAGS_aarch64= -fPIC
+CFLAGS_mips= -DNO_ATOMICS # cannot use lang/gcc
+CFLAGS_mips64= -DNO_ATOMICS # cannot use lang/gcc
EXTRACT_AFTER_ARGS+= --exclude "md5*"
WRKSRC= ${WRKDIR}/multicoreware-${PORTNAME}-be14a7e9755e/source
-BROKEN_mips64= Fails to link: Nonrepresentable section on output
-
do-test:
${WRKSRC}/test/TestBench