aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-04-03 19:34:53 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-04-03 19:34:53 +0800
commit7c94e523a1d086ef8f3c33797da3a1e151e29bc0 (patch)
treea9e70f5d41c54099a6fe9a8391a40c0c6cbfec38 /multimedia
parentc5e7053724f8f8333b51080d480418fd9c300c9c (diff)
downloadfreebsd-ports-gnome-7c94e523a1d086ef8f3c33797da3a1e151e29bc0.tar.gz
freebsd-ports-gnome-7c94e523a1d086ef8f3c33797da3a1e151e29bc0.tar.zst
freebsd-ports-gnome-7c94e523a1d086ef8f3c33797da3a1e151e29bc0.zip
- Fix package list
- Remove code for EOL FreeBSD versions - Drop ABI version in LIB_DEPENDS (where not needed) - Provide NLS option Approved by: portmgr (bdrewery)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/subtitleeditor/Makefile21
-rw-r--r--multimedia/subtitleeditor/pkg-plist60
2 files changed, 49 insertions, 32 deletions
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index d29627eb55b7..93e178e4ca9b 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= subtitleeditor
PORTVERSION= 0.40.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:C/\.[0-9]*$//}/ \
CRITICAL
@@ -16,13 +16,12 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
gstreamermm-0.10.2:${PORTSDIR}/multimedia/gstreamermm \
- enchant.1:${PORTSDIR}/textproc/enchant \
- pcre.3:${PORTSDIR}/devel/pcre
+ enchant:${PORTSDIR}/textproc/enchant \
+ pcre:${PORTSDIR}/devel/pcre
USE_GMAKE= yes
USE_GNOME= gtk20
USE_GSTREAMER= good
-USE_GETTEXT= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -30,10 +29,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
MAN1= subtitleeditor.1
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 700043
-BROKEN= does not compile
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -41,4 +46,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|strtoll|strtoq|g' ${WRKSRC}/plugins/subtitleformats/advancedsubstationalpha/advancedsubstationalpha.cc
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' ${WRKSRC}/plugins/actions/findandreplace/findandreplace.cc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/subtitleeditor/pkg-plist b/multimedia/subtitleeditor/pkg-plist
index cadd83f88108..45c80805300d 100644
--- a/multimedia/subtitleeditor/pkg-plist
+++ b/multimedia/subtitleeditor/pkg-plist
@@ -122,30 +122,30 @@ share/icons/hicolor/22x22/apps/subtitleeditor.png
share/icons/hicolor/24x24/apps/subtitleeditor.png
share/icons/hicolor/32x32/apps/subtitleeditor.png
share/icons/hicolor/scalable/apps/subtitleeditor.svg
-share/locale/bg/LC_MESSAGES/subtitleeditor.mo
-share/locale/el/LC_MESSAGES/subtitleeditor.mo
-share/locale/ca/LC_MESSAGES/subtitleeditor.mo
-share/locale/cs/LC_MESSAGES/subtitleeditor.mo
-share/locale/da/LC_MESSAGES/subtitleeditor.mo
-share/locale/de/LC_MESSAGES/subtitleeditor.mo
-share/locale/en_GB/LC_MESSAGES/subtitleeditor.mo
-share/locale/eo/LC_MESSAGES/subtitleeditor.mo
-share/locale/es/LC_MESSAGES/subtitleeditor.mo
-share/locale/fr/LC_MESSAGES/subtitleeditor.mo
-share/locale/gl/LC_MESSAGES/subtitleeditor.mo
-share/locale/hu/LC_MESSAGES/subtitleeditor.mo
-share/locale/it/LC_MESSAGES/subtitleeditor.mo
-share/locale/nl/LC_MESSAGES/subtitleeditor.mo
-share/locale/pl/LC_MESSAGES/subtitleeditor.mo
-share/locale/pt/LC_MESSAGES/subtitleeditor.mo
-share/locale/lt/LC_MESSAGES/subtitleeditor.mo
-share/locale/zh_TW/LC_MESSAGES/subtitleeditor.mo
-share/locale/pt_BR/LC_MESSAGES/subtitleeditor.mo
-share/locale/pt_PT/LC_MESSAGES/subtitleeditor.mo
-share/locale/ru/LC_MESSAGES/subtitleeditor.mo
-share/locale/sr/LC_MESSAGES/subtitleeditor.mo
-share/locale/tr/LC_MESSAGES/subtitleeditor.mo
-share/locale/zh_CN/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/el/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/da/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/de/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/es/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/it/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/subtitleeditor.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/subtitleeditor.mo
share/pixmaps/subtitleeditor.svg
share/subtitleeditor/menubar.xml
share/subtitleeditor/plugins-description/actions/about.se-plugin
@@ -261,6 +261,18 @@ share/subtitleeditor/plugins-share/substationalpha/dialog-substationalpha-prefer
@dirrm share/subtitleeditor/plugins-description/subtitleformats
@dirrm share/subtitleeditor/plugins-description/actions
@dirrm share/subtitleeditor/plugins-description
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrm share/subtitleeditor
@dirrm lib/subtitleeditor/plugins/subtitleformats
@dirrm lib/subtitleeditor/plugins/actions