aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-11-16 23:19:50 +0800
committertobik <tobik@FreeBSD.org>2019-11-16 23:19:50 +0800
commitd01035b6896cceec402b8674e1e1028fc72801ae (patch)
tree37051797b9aa2daaf7dcceca0e2b2f2c2952a196 /multimedia
parentcc3f417c9002042dde1c9c488aba413f41235aff (diff)
downloadfreebsd-ports-gnome-d01035b6896cceec402b8674e1e1028fc72801ae.tar.gz
freebsd-ports-gnome-d01035b6896cceec402b8674e1e1028fc72801ae.tar.zst
freebsd-ports-gnome-d01035b6896cceec402b8674e1e1028fc72801ae.zip
*/gstreamer*: Prevent false QA warnings about missing USES
gstreamer1?-plugins/Makefile.common can under some circumstances create empty USE_XORG, USE_GNOME, etc. which trigger the warnings. gstreamer-plugins-good triggers the USE_XORG warning because USES is overwritten again after including the master Makefile. gstreamer-plugin-sdl was missing USES=sdl Approved by: multimedia (kwm) Differential Revision: https://reviews.freebsd.org/D22406
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-plugins-good/Makefile3
-rw-r--r--multimedia/gstreamer-plugins/Makefile3
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common3
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common8
4 files changed, 15 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins-good/Makefile b/multimedia/gstreamer-plugins-good/Makefile
index f0133bfe856d..c1dc4843e27c 100644
--- a/multimedia/gstreamer-plugins-good/Makefile
+++ b/multimedia/gstreamer-plugins-good/Makefile
@@ -15,8 +15,7 @@ MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:multimedia/gstreamer-plugins
RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:multimedia/gstreamer-plugins
-USES+= xorg
-USE_XORG+= xdamage
+USE_XORG= xdamage
gst_good_DIST= good
GOOD_GST_DIRS= gst sys po
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 5f0ac196fa3f..5a535fc3e7ea 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -46,6 +46,9 @@ SHLIB_VERSION= 1
VERSION= ${GST_VERSION}
WANT_GSTREAMER= yes
USES= gettext gmake gnome libtool:keepla pathfix pkgconfig shebangfix tar:bzip2
+.if defined(USE_XORG)
+USES+= xorg
+.endif
USE_GNOME+= introspection:build
GNU_CONFIGURE= yes
GST_PLUGIN?= base
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 278c698b6381..2352182d4149 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -449,6 +449,7 @@ gst_resindvd_PLIST_FILES= ${GST_LIB_DIR}/libresindvd.la \
gst_resindvd_DIST= bad
# sdl
+gst_sdl_USES= sdl
gst_sdl_USE_SDL+= sdl
gst_sdl_PLIST_FILES= ${GST_LIB_DIR}/libgstsdl.la \
${GST_LIB_DIR}/libgstsdl.so
@@ -622,7 +623,9 @@ USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
PLIST_DIRS= ${gst_${GST_PLUGIN}_PLIST_DIRS}
EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
+.if ${gst_${GST_PLUGIN}_USE_GNOME}!=""
USE_GNOME+= ${gst_${GST_PLUGIN}_USE_GNOME}
+.endif
CONFIGURE_ENV+= ${gst_${GST_PLUGIN}_CONFIGURE_ENV}
.if ${gst_${GST_PLUGIN}_GCONF_SCHEMAS}!=""
GCONF_SCHEMAS= ${gst_${GST_PLUGIN}_GCONF_SCHEMAS}
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index ecc27d8761f0..527333e04db7 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -539,8 +539,10 @@ gst_${GST_PLUGIN}_EXTRA_LIBS?=
gst_${GST_PLUGIN}_PREBUILD_DIR?=
gst_${GST_PLUGIN}_GST_PLUGIN_DIR?= ext/${GST_PLUGIN}
gst_${GST_PLUGIN}_POSTBUILD_DIR?=
+gst_${GST_PLUGIN}_USE_XORG?=
gst_${GST_PLUGIN}_USE_GNOME?=
gst_${GST_PLUGIN}_CONFIGURE_ENV?=
+gst_${GST_PLUGIN}_USE_GL?=
gst_${GST_PLUGIN}_GLIB_SCHEMAS?=
gst_${GST_PLUGIN}_CONFIGURE_ARGS?=
gst_${GST_PLUGIN}_USE_SDL?=
@@ -552,10 +554,16 @@ RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
+.if ${gst_${GST_PLUGIN}_USE_XORG}!=""
USE_XORG+= ${gst_${GST_PLUGIN}_USE_XORG}
+.endif
+.if ${gst_${GST_PLUGIN}_USE_GNOME}!=""
USE_GNOME+= ${gst_${GST_PLUGIN}_USE_GNOME}
+.endif
CONFIGURE_ENV+= ${gst_${GST_PLUGIN}_CONFIGURE_ENV}
+.if ${gst_${GST_PLUGIN}_USE_GL}!=""
USE_GL+= ${gst_${GST_PLUGIN}_USE_GL}
+.endif
.if ${gst_${GST_PLUGIN}_GLIB_SCHEMAS}!=""
GLIB_SCHEMAS= ${gst_${GST_PLUGIN}_GLIB_SCHEMAS}