aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2002-06-30 21:22:56 +0800
committernobutaka <nobutaka@FreeBSD.org>2002-06-30 21:22:56 +0800
commitde48f3e60518a64f2063fb04b334de932c21145b (patch)
tree9a10edd6e0e85fa88bb07116384efba42ec2e4af /multimedia
parent9dabcc6d51649ea5be4d341f5e18da98dddfa44f (diff)
downloadfreebsd-ports-gnome-de48f3e60518a64f2063fb04b334de932c21145b.tar.gz
freebsd-ports-gnome-de48f3e60518a64f2063fb04b334de932c21145b.tar.zst
freebsd-ports-gnome-de48f3e60518a64f2063fb04b334de932c21145b.zip
Backout previous fix for link warnings and remove -lc from link command line instead.
Submitted by: Bjoern Fischer <bfischer@Techfak.Uni-Bielefeld.DE>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdvdnav/Makefile3
-rw-r--r--multimedia/libdvdnav/files/patch-ltmain.sh19
2 files changed, 14 insertions, 8 deletions
diff --git a/multimedia/libdvdnav/Makefile b/multimedia/libdvdnav/Makefile
index 4a02e93ea7b2..18a61b501e9f 100644
--- a/multimedia/libdvdnav/Makefile
+++ b/multimedia/libdvdnav/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= dvdread.2:${PORTSDIR}/graphics/libdvdread
GNU_CONFIGURE= yes
CONFIGURE_ENV= THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- THREAD_LIBS="${PTHREAD_LIBS}" \
- LIBS="-lcrypt"
+ THREAD_LIBS="${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
post-patch:
diff --git a/multimedia/libdvdnav/files/patch-ltmain.sh b/multimedia/libdvdnav/files/patch-ltmain.sh
index 0591f6be269a..062d77ae1c56 100644
--- a/multimedia/libdvdnav/files/patch-ltmain.sh
+++ b/multimedia/libdvdnav/files/patch-ltmain.sh
@@ -1,6 +1,6 @@
---- ltmain.sh.orig Mon Apr 29 18:30:38 2002
-+++ ltmain.sh Tue May 21 01:46:02 2002
-@@ -958,6 +958,7 @@
+--- ltmain.sh.orig Sat Jun 1 21:12:45 2002
++++ ltmain.sh Tue Jun 11 22:25:52 2002
+@@ -967,6 +967,7 @@
;;
-avoid-version)
@@ -8,7 +8,7 @@
avoid_version=yes
continue
;;
-@@ -1045,14 +1046,14 @@
+@@ -1054,14 +1055,14 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
@@ -25,7 +25,7 @@
# Do not include libc_r directly, use -pthread flag.
continue
;;
-@@ -2459,7 +2460,7 @@
+@@ -2468,13 +2469,13 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
@@ -34,7 +34,14 @@
# Do not include libc due to us having libc/libc_r.
;;
*)
-@@ -4247,10 +4248,12 @@
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+- deplibs="$deplibs -lc"
++ deplibs="$deplibs"
+ fi
+ ;;
+ esac
+@@ -4273,10 +4274,12 @@
fi
# Install the pseudo-library for information purposes.