aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-31 03:20:22 +0800
committerkrion <krion@FreeBSD.org>2004-03-31 03:20:22 +0800
commitec7e839df6339ee2ce45b2a86705d36babd6ddb2 (patch)
tree89a2307095c132bb20ec384fd75a853ff48669ed /multimedia
parent919d5d370736760e6caa8a55aa6ec939d3387eec (diff)
downloadfreebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.tar.gz
freebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.tar.zst
freebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.zip
- Use USE_ICONV knob
Approved by: portmgr
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile2
-rw-r--r--multimedia/mplayer/Makefile4
-rw-r--r--multimedia/mplayerxp/Makefile4
-rw-r--r--multimedia/vlc-devel/Makefile2
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--multimedia/xmms/Makefile3
6 files changed, 8 insertions, 9 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 23f8f694eb9b..798a15f846f1 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -23,12 +23,12 @@ LIB_DEPENDS= FLAC.5:${PORTSDIR}/audio/flac \
vorbis.3:${PORTSDIR}/audio/libvorbis \
mad.2:${PORTSDIR}/audio/libmad \
speex.2:${PORTSDIR}/audio/speex \
- iconv.3:${PORTSDIR}/converters/libiconv \
aa.1:${PORTSDIR}/graphics/aalib \
mng.1:${PORTSDIR}/graphics/libmng \
dvdread.3:${PORTSDIR}/multimedia/libdvdread
USE_GETTEXT= yes
+USE_ICONV= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 40c2af33b741..36539dc1b753 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -197,11 +197,11 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= riggs@rrr.de
COMMENT= High performance media player/encoder supporting many formats
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
+USE_ICONV= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 82ecb31f51b4..d0650a70cb7d 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -15,8 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Multi-threaded branch of the well known mplayer media player
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
mp3lame.0:${PORTSDIR}/audio/lame \
png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/multimedia/mplayer-fonts
@@ -24,6 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/mplayer/fonts:${PORTSDIR}/multimedia/mplayer-fon
ONLY_FOR_ARCHS= i386
USE_BZIP2= yes
USE_GNOME= gtk12
+USE_ICONV= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_REINPLACE= yes
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index 5d72fe22c6dd..71d204c7a1dc 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -37,7 +37,6 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
mad.2:${PORTSDIR}/audio/libmad \
avcodec.0:${PORTSDIR}/${FFMPEG_PORT} \
a52.0:${PORTSDIR}/audio/liba52 \
- iconv.3:${PORTSDIR}/converters/libiconv \
vorbis.3:${PORTSDIR}/audio/libvorbis \
FLAC.5:${PORTSDIR}/audio/flac \
faad.0:${PORTSDIR}/audio/faad \
@@ -48,6 +47,7 @@ USE_GETOPT_LONG=yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12
+USE_ICONV= yes
USE_REINPLACE= yes
USE_SDL= sdl
USE_XLIB= yes
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 5d72fe22c6dd..71d204c7a1dc 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -37,7 +37,6 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
mad.2:${PORTSDIR}/audio/libmad \
avcodec.0:${PORTSDIR}/${FFMPEG_PORT} \
a52.0:${PORTSDIR}/audio/liba52 \
- iconv.3:${PORTSDIR}/converters/libiconv \
vorbis.3:${PORTSDIR}/audio/libvorbis \
FLAC.5:${PORTSDIR}/audio/flac \
faad.0:${PORTSDIR}/audio/faad \
@@ -48,6 +47,7 @@ USE_GETOPT_LONG=yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12
+USE_ICONV= yes
USE_REINPLACE= yes
USE_SDL= sdl
USE_XLIB= yes
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index 6ee2042c6a7e..d9f8c1acd862 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -15,14 +15,13 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= esk@ira.uka.de
COMMENT?= X Multimedia System --- An audio player with a Winamp GUI
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12 gnomehack libxml
USE_REINPLACE= yes
WANT_GNOME= yes
USE_GMAKE= yes
+USE_ICONV= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \