aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-04-06 12:59:00 +0800
committerlioux <lioux@FreeBSD.org>2003-04-06 12:59:00 +0800
commit60a38eb1b845b48dbe5fed21a4c3b77fe802c6ae (patch)
tree217c3e60e8c9c28737268f73ee8c4dab7264c115 /multimedia
parent58a0def5b02e7c41fc0a6d254ac4e24c46a84bf6 (diff)
downloadfreebsd-ports-gnome-60a38eb1b845b48dbe5fed21a4c3b77fe802c6ae.tar.gz
freebsd-ports-gnome-60a38eb1b845b48dbe5fed21a4c3b77fe802c6ae.tar.zst
freebsd-ports-gnome-60a38eb1b845b48dbe5fed21a4c3b77fe802c6ae.zip
o Chase lib version bump in ogle port version 0.9.1
o Add a patch fix to correctly detect device files (e.g., /dev/acd0a) [1] Submitted by: Frerich Raabe <frerich.raabe@gmx.de> [1]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/okle/Makefile2
-rw-r--r--multimedia/okle/files/patch-src::okle_win.cpp40
2 files changed, 41 insertions, 1 deletions
diff --git a/multimedia/okle/Makefile b/multimedia/okle/Makefile
index 156077a9466e..071b870ef0d1 100644
--- a/multimedia/okle/Makefile
+++ b/multimedia/okle/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://okle.sourceforge.net/
MAINTAINER= lioux@FreeBSD.org
COMMENT= A KDE frontend to the Ogle DVD player
-BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.9:${PORTSDIR}/multimedia/ogle
+BUILD_DEPENDS= ${LOCALBASE}/lib/ogle/libdvdcontrol.so.10:${PORTSDIR}/multimedia/ogle
RUN_DEPENDS= ogle:${PORTSDIR}/multimedia/ogle
USE_AUTOCONF_VER= 253
diff --git a/multimedia/okle/files/patch-src::okle_win.cpp b/multimedia/okle/files/patch-src::okle_win.cpp
new file mode 100644
index 000000000000..f2b8321aca14
--- /dev/null
+++ b/multimedia/okle/files/patch-src::okle_win.cpp
@@ -0,0 +1,40 @@
+--- src/okle_win.cpp.orig Tue Feb 25 11:19:50 2003
++++ src/okle_win.cpp Sun Apr 6 01:50:55 2003
+@@ -34,6 +34,7 @@
+ #include <kstandarddirs.h>
+ #include <qtooltip.h>
+ #include <dcopclient.h>
++#include <kfileitem.h>
+
+ extern "C" {
+ #include <X11/Xlib.h>
+@@ -519,16 +520,16 @@
+ void OkleWin::slotFileOpenDisc()
+ {
+ conf->setGroup("DVD");
+- QString dvdp = conf->readEntry("dvdpath","/dev/dvd");
++ QString dvdp = conf->readEntry("dvdpath","/dev/acd0c");
+
+- QFileInfo fi(dvdp);
+- if(!fi.exists())
++ KFileItem fi(KFileItem::Unknown, KFileItem::Unknown, dvdp);
++ if(!QFile::exists(dvdp))
+ {
+ KMessageBox::error(0,QString(i18n("%1 does not exist!")).arg(dvdp),i18n("Error"));
+ return;
+ }
+
+- if(!fi.isFile() && !fi.isSymLink())
++ if(!fi.isFile() && !fi.isLink())
+ {
+ KMessageBox::error(0,QString(i18n("%1 exists but is not a file or symlink!")).arg(dvdp),i18n("Error"));
+ return;
+@@ -714,7 +715,7 @@
+ {
+ PrefsWin* prefs = new PrefsWin(this);
+ conf->setGroup("DVD");
+- prefs->setDVDPath(conf->readEntry("dvdpath","/dev/dvd"));
++ prefs->setDVDPath(conf->readEntry("dvdpath","/dev/acd0c"));
+ prefs->setRegion(conf->readNumEntry("region",1));
+ if(prefs->exec())
+ {