aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2009-08-08 18:04:34 +0800
committerkwm <kwm@FreeBSD.org>2009-08-08 18:04:34 +0800
commiteff3b803df16699d62fb54d1b295d114a054ea6d (patch)
tree6fb4254f345147cf803c9ad9c42ac7c683d00a0a /multimedia
parent7f6c035f4c91763188f5541941da66fa0f81e923 (diff)
downloadfreebsd-ports-gnome-eff3b803df16699d62fb54d1b295d114a054ea6d.tar.gz
freebsd-ports-gnome-eff3b803df16699d62fb54d1b295d114a054ea6d.tar.zst
freebsd-ports-gnome-eff3b803df16699d62fb54d1b295d114a054ea6d.zip
Fix build after recent Gstreamer update.
Submitted by: pointhat (via pav)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/schroedinger/Makefile1
-rw-r--r--multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c19
-rw-r--r--multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h13
3 files changed, 33 insertions, 0 deletions
diff --git a/multimedia/schroedinger/Makefile b/multimedia/schroedinger/Makefile
index 678085e9ad7d..b2c7255b0dbd 100644
--- a/multimedia/schroedinger/Makefile
+++ b/multimedia/schroedinger/Makefile
@@ -7,6 +7,7 @@
PORTNAME= schroedinger
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.diracvideo.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c
new file mode 100644
index 000000000000..a0dd2a15164a
--- /dev/null
+++ b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.c
@@ -0,0 +1,19 @@
+--- gst-libs/gst/video/gstbasevideoutils.c.orig 2009-08-08 11:53:34.000000000 +0200
++++ gst-libs/gst/video/gstbasevideoutils.c 2009-08-08 11:53:58.000000000 +0200
+@@ -229,7 +229,7 @@ scan_slow (GstAdapter *adapter, GSList *
+ return ((GST_READ_UINT32_BE (tmp) & mask) == pattern);
+ }
+
+-
++/*
+ int
+ gst_adapter_masked_scan_uint32 (GstAdapter *adapter,
+ guint32 pattern, guint32 mask, int offset, int n)
+@@ -271,6 +271,7 @@ gst_adapter_masked_scan_uint32 (GstAdapt
+
+ return n;
+ }
++*/
+
+ GstBuffer *
+ gst_adapter_get_buffer (GstAdapter *adapter)
diff --git a/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h
new file mode 100644
index 000000000000..79828d557c56
--- /dev/null
+++ b/multimedia/schroedinger/files/patch-gst-libs_gst_video_gstbasevideoutils.h
@@ -0,0 +1,13 @@
+--- gst-libs/gst/video/gstbasevideoutils.h.orig 2009-08-08 11:53:39.000000000 +0200
++++ gst-libs/gst/video/gstbasevideoutils.h 2009-08-08 11:54:07.000000000 +0200
+@@ -84,8 +84,10 @@ gboolean gst_base_video_state_from_caps
+ GstClockTime gst_video_state_get_timestamp (const GstVideoState *state,
+ int frame_number);
+
++/*
+ int gst_adapter_masked_scan_uint32 (GstAdapter *adapter,
+ guint32 pattern, guint32 mask, int offset, int n);
++*/
+ GstBuffer *gst_adapter_get_buffer (GstAdapter *adapter);
+
+ G_END_DECLS