aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-11-28 04:25:07 +0800
committerlioux <lioux@FreeBSD.org>2005-11-28 04:25:07 +0800
commitf1e0695214896a10f8c04c7351b721d5ef89fdf9 (patch)
tree8285ed9e800c8abac879f096fd3d85c023fa78d9 /multimedia
parent2c4658e890aeecc5e662fcecbf66f6cfad8cd921 (diff)
downloadfreebsd-ports-gnome-f1e0695214896a10f8c04c7351b721d5ef89fdf9.tar.gz
freebsd-ports-gnome-f1e0695214896a10f8c04c7351b721d5ef89fdf9.tar.zst
freebsd-ports-gnome-f1e0695214896a10f8c04c7351b721d5ef89fdf9.zip
o Properly consider documentation building/installation process
- Do not try to build latex documentation (too many dependencies) when html gives exact the same information [1] - Actually install documentation unless NOPORTDOCS is defined [2] o Bump PORTREVISION due to (2) Submitted by: paul <paul@paulbeard.org> [1] (warn about lack of dvips)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libdvdcss/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/multimedia/libdvdcss/Makefile b/multimedia/libdvdcss/Makefile
index 942626e07f75..9b4d5616b2c0 100644
--- a/multimedia/libdvdcss/Makefile
+++ b/multimedia/libdvdcss/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libdvdcss
PORTVERSION= 1.2.9
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -23,7 +24,31 @@ USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+.ifndef(NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+
+PORTDOCS= *
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/ioctl.c
+# should we disable doc building?
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]*SUBDIRS[[:space:]]*=.*)doc|\1|' \
+ ${BUILD_WRKSRC}/Makefile.in
+.else
+# we do not want the latex documents... too many dependencies just
+# to get something in ps we already have get as html
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]*all:[[:space:]]*.*)stamp-latex|\1|' \
+ ${BUILD_WRKSRC}/doc/Makefile.in
+.endif
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
.include <bsd.port.mk>