aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-23 09:51:52 +0800
committermiwi <miwi@FreeBSD.org>2012-05-23 09:51:52 +0800
commit07134c32ecd3b7b26b2be0112ab631ebde95deca (patch)
tree389c2e1778181df5b274b5b50b598c74b58ac487 /multimedia
parente35ace6ab94e5597576f759dba02cff961288e37 (diff)
downloadfreebsd-ports-gnome-07134c32ecd3b7b26b2be0112ab631ebde95deca.tar.gz
freebsd-ports-gnome-07134c32ecd3b7b26b2be0112ab631ebde95deca.tar.zst
freebsd-ports-gnome-07134c32ecd3b7b26b2be0112ab631ebde95deca.zip
- Update to 0.5.907
PR: 168042 Submitted by: Ports Fury
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gxine/Makefile102
-rw-r--r--multimedia/gxine/distinfo4
-rw-r--r--multimedia/gxine/files/patch-src__Makefile.in18
-rw-r--r--multimedia/gxine/files/patch-src__console_outout.h11
-rw-r--r--multimedia/gxine/files/patch-src__engine.c11
-rw-r--r--multimedia/gxine/files/patch-src__lirc.c12
-rw-r--r--multimedia/gxine/files/patch-src__main.c10
-rw-r--r--multimedia/gxine/pkg-plist61
8 files changed, 140 insertions, 89 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 1f9f7417bdaa..baab2aaf21dd 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -6,89 +6,77 @@
#
PORTNAME= gxine
-PORTVERSION= 0.5.905
-PORTREVISION= 6
+PORTVERSION= 0.5.907
CATEGORIES= multimedia
MASTER_SITES= SF/xine/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An alternative GUI for the Xine media player
-LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
+LICENSE= GPLv2
-USE_BZIP2= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= gtk20 gnomehier
+LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr \
+ xine.2:${PORTSDIR}/multimedia/libxine
+
+OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" off \
+ GNOME "Enable Gnome integration" off \
+ LIRC "Enable lirc support" off
+
+USE_XZ= yes
+USE_GNOME= gnomehack gtk20
+USE_GECKO= libxul
USE_GMAKE= yes
-USE_GCC= 4.2+
-MAKE_ARGS+= LDFLAGS=-shared-libgcc
-CNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--without-hal --with-libintl-prefix=${LOCALBASE}
+USE_AUTOTOOLS= libtool
+CONFIGURE_ENV= MKDIR_P="${MKDIR}"
+CONFIGURE_ARGS= --enable-mozjs --disable-ffjs --disable-seajs \
+ --without-hal --with-libintl-prefix=${LOCALBASE}
INSTALLS_ICONS= yes
-
MAKE_JOBS_SAFE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
MANLANG= "" de es
MAN1= gxine.1 gxine_client.1
MANCOMPRESSED= no
-OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" off \
- GNOME "Enable Gnome integration" off \
- LIRC "Enable lirc support" off
-
.include <bsd.port.options.mk>
-.if defined(WITH_GNOME)
-USE_GNOME+= gnomevfs2 libgnomeui
-CONFIGURE_ARGS+=--with-dbus
+.if defined(WITH_MOZILLA_PLUGIN)
+USE_XORG+= xaw
+USE_WEBPLUGINS= native
+WEBPLUGINS_DIR= ${PREFIX}/lib/gxine
+WEBPLUGINS_FILES=gxineplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+PLIST_SUB+= MOZILLA_PLUGIN=""
.else
-CONFIGURE_ARGS+=--disable-integration-wizard --without-dbus
+CONFIGURE_ARGS+=--without-browser-plugin
+PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+.if defined(WITH_GNOME)
+BUILD_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
+CONFIGURE_ARGS+=--with-dbus
.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+=--disable-integration-wizard --without-dbus
.endif
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.2:${PORTSDIR}/comms/lirc
-CONFIGURE_ARGS+= --enable-lirc
-.else
-CONFIGURE_ARGS+= --disable-lirc
-.endif
-
-.if defined(WITHOUT_MOZILLA_PLUGIN)
-LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
-CONFIGURE_ARGS+=--without-browser-plugin --with-spidermonkey
-PLIST_SUB+= MOZILLA_PLUGIN="@comment "
+CONFIGURE_ARGS+=--enable-lirc
.else
-USE_XORG+= xaw
-USE_GECKO= libxul
-USE_WEBPLUGINS= native
-WEBPLUGINS_DIR= ${PREFIX}/lib/gxine
-WEBPLUGINS_FILES=gxineplugin.so
-.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
-LIB_DEPENDS+= nspr4.1:${PORTSDIR}/devel/nspr
-CONFIGURE_ENV+= NSPR_CFLAGS="-I${LOCALBASE}/include/nspr" \
- NSPR_LIBS="-L${LOCALBASE}/lib"
-PLIST_SUB+= MOZILLA_PLUGIN=""
+CONFIGURE_ARGS+=--disable-lirc
.endif
-pre-configure:
- @${REINPLACE_CMD} -e "/^mkdir_p/s:@mkdir_p@:${MKDIR}:" \
- ${WRKSRC}/po/Makefile.in.in
- @${REINPLACE_CMD} -e "/^mkdir_p/s:@mkdir_p@:${MKDIR}:" \
- ${WRKSRC}/misc/po/Makefile.in.in
- @${REINPLACE_CMD} -e "s:@MAKE_PNG_TRUE@:#:g" \
- ${WRKSRC}/pixmaps/Makefile.in
-
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION}<800000) && defined(WITH_MOZILLA_PLUGIN)
-BROKEN= does not compile with MOZILLA_PLUGIN
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/CFLAGS/s|-I/usr/local/include|| ; \
+ /CFLAGS/s|-L/usr/local/lib|| ; \
+ /CPPFLAGS/s|-I/usr/local/include|| ; \
+ s|XINE_LIST=.*|XINE_LIST=|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|@MAKE_PNG_TRUE@|#|' ${WRKSRC}/pixmaps/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gxine/distinfo b/multimedia/gxine/distinfo
index 5e376715269d..ccd162af9afa 100644
--- a/multimedia/gxine/distinfo
+++ b/multimedia/gxine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gxine-0.5.905.tar.bz2) = 9dcca3e581fddfc4cea8f9e45c99652f4dd336c1ca7726e910870b9c778b0cbf
-SIZE (gxine-0.5.905.tar.bz2) = 1203720
+SHA256 (gxine-0.5.907.tar.xz) = b5c925806a35cb23a24a80a39d494cefb529e22c957987741f269a994ab258d5
+SIZE (gxine-0.5.907.tar.xz) = 910528
diff --git a/multimedia/gxine/files/patch-src__Makefile.in b/multimedia/gxine/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..66fceef0ebd6
--- /dev/null
+++ b/multimedia/gxine/files/patch-src__Makefile.in
@@ -0,0 +1,18 @@
+--- src/Makefile.in.orig 2012-02-21 04:10:20.000000000 +0900
++++ src/Makefile.in 2012-05-15 17:11:18.000000000 +0900
+@@ -330,12 +330,12 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ GNU_VERBOSITY := $(if $(findstring GNU,$(shell $(MAKE) -v)),0,1)
+-INCLUDES = -I../include -I$(top_srcdir)/include -I$(includedir) \
+- -I$(top_builddir)/pixmaps $(LIRC_INCLUDE)
++INCLUDES = -I../include -I$(top_srcdir)/include \
++ -I$(top_builddir)/pixmaps $(JS_CFLAGS) $(LIRC_INCLUDE)
+
+ AM_CFLAGS = $(GNU99) $(XINE_CFLAGS) $(X_CFLAGS) \
+ $(GTK2_CFLAGS) $(GTHREAD2_CFLAGS) \
+- $(HAL_CFLAGS) $(UDEV_CFLAGS) $(DBUS_CFLAGS) $(JS_CFLAGS) \
++ $(HAL_CFLAGS) $(UDEV_CFLAGS) $(DBUS_CFLAGS) $(NSPR_CFLAGS) \
+ -DLOCALEDIR=\"$(localedir)\"
+
+ gxine_SOURCES = \
diff --git a/multimedia/gxine/files/patch-src__console_outout.h b/multimedia/gxine/files/patch-src__console_outout.h
new file mode 100644
index 000000000000..b9837e2e9543
--- /dev/null
+++ b/multimedia/gxine/files/patch-src__console_outout.h
@@ -0,0 +1,11 @@
+--- src/console_output.h.orig 2010-04-11 23:46:54.000000000 +0900
++++ src/console_output.h 2012-05-15 04:21:37.000000000 +0900
+@@ -21,7 +21,7 @@
+ #ifndef GXINE_CONSOLE_OUTPUT_H
+ #define GXINE_CONSOLE_OUTPUT_H
+
+-#include <glib/gmessages.h>
++#include <glib.h>
+
+ void console_output_init (void);
+
diff --git a/multimedia/gxine/files/patch-src__engine.c b/multimedia/gxine/files/patch-src__engine.c
new file mode 100644
index 000000000000..dbf1c4e80af3
--- /dev/null
+++ b/multimedia/gxine/files/patch-src__engine.c
@@ -0,0 +1,11 @@
+--- src/engine.c.orig 2011-10-12 07:47:52.000000000 +0900
++++ src/engine.c 2012-05-15 04:22:54.000000000 +0900
+@@ -30,7 +30,7 @@
+ #include <errno.h>
+ #include <unistd.h>
+
+-#include <glib/gthread.h>
++#include <glib.h>
+
+ #include "engine.h"
+ #include "ui.h"
diff --git a/multimedia/gxine/files/patch-src__lirc.c b/multimedia/gxine/files/patch-src__lirc.c
new file mode 100644
index 000000000000..33b93253db3c
--- /dev/null
+++ b/multimedia/gxine/files/patch-src__lirc.c
@@ -0,0 +1,12 @@
+--- src/lirc.c.orig 2011-08-07 20:20:33.000000000 +0900
++++ src/lirc.c 2012-05-15 03:54:41.000000000 +0900
+@@ -223,8 +223,8 @@
+ if (gxine_lirc_thread_created)
+ pthread_join (gxine_lirc_thread, NULL);
+ gxine_lirc_start ();
+-#endif
+ JS_SET_RVAL (cx, vp, gxine_lirc_thread ? JSVAL_TRUE : JSVAL_FALSE);
++#endif
+ return JS_TRUE;
+ }
+
diff --git a/multimedia/gxine/files/patch-src__main.c b/multimedia/gxine/files/patch-src__main.c
new file mode 100644
index 000000000000..165a29d9d630
--- /dev/null
+++ b/multimedia/gxine/files/patch-src__main.c
@@ -0,0 +1,10 @@
+--- src/main.c.orig 2010-12-05 20:38:44.000000000 +0900
++++ src/main.c 2012-05-15 04:23:45.000000000 +0900
+@@ -46,7 +46,6 @@
+ #include <gdk/gdk.h>
+ #include <gdk/gdkkeysyms.h>
+ #include <glib.h>
+-#include <glib/gmessages.h>
+
+ #include "desktop_integration.h"
+ #include "engine.h"
diff --git a/multimedia/gxine/pkg-plist b/multimedia/gxine/pkg-plist
index 30539abed527..d330bb8f6623 100644
--- a/multimedia/gxine/pkg-plist
+++ b/multimedia/gxine/pkg-plist
@@ -1,10 +1,10 @@
bin/gxine
bin/gxine_client
-etc/gxine/gtkrc
-etc/gxine/keypad.xml
-etc/gxine/startup
-etc/gxine/toolbar-fullscreen.xml
-etc/gxine/toolbar-window.xml
+%%ETCDIR%%/gtkrc
+%%ETCDIR%%/keypad.xml
+%%ETCDIR%%/startup
+%%ETCDIR%%/toolbar-fullscreen.xml
+%%ETCDIR%%/toolbar-window.xml
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.a
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.la
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.so
@@ -18,36 +18,37 @@ share/applications/gxine.desktop
%%DATADIR%%/pixmaps/set-contrast.svg
%%DATADIR%%/pixmaps/set-hue.svg
%%DATADIR%%/pixmaps/set-saturation.svg
+%%DATADIR%%/pixmaps/set-sharpness.svg
%%DATADIR%%/pixmaps/set-sync.svg
%%DATADIR%%/pixmaps/set-volume.svg
%%DATADIR%%/pixmaps/speaker.png
%%DATADIR%%/pixmaps/splash.png
%%DATADIR%%/pixmaps/subtitle.svg
share/icons/hicolor/64x64/apps/gxine.png
-%%NLS%%share/locale/cs/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/gxine.theme.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.theme.mo
+share/locale/cs/LC_MESSAGES/gxine.mo
+share/locale/cs/LC_MESSAGES/gxine.theme.mo
+share/locale/de/LC_MESSAGES/gxine.mo
+share/locale/de/LC_MESSAGES/gxine.theme.mo
+share/locale/es/LC_MESSAGES/gxine.mo
+share/locale/es/LC_MESSAGES/gxine.theme.mo
+share/locale/fi/LC_MESSAGES/gxine.mo
+share/locale/fi/LC_MESSAGES/gxine.theme.mo
+share/locale/fr/LC_MESSAGES/gxine.mo
+share/locale/fr/LC_MESSAGES/gxine.theme.mo
+share/locale/it/LC_MESSAGES/gxine.mo
+share/locale/it/LC_MESSAGES/gxine.theme.mo
+share/locale/ja/LC_MESSAGES/gxine.mo
+share/locale/ja/LC_MESSAGES/gxine.theme.mo
+share/locale/pl/LC_MESSAGES/gxine.mo
+share/locale/pl/LC_MESSAGES/gxine.theme.mo
+share/locale/ru/LC_MESSAGES/gxine.mo
+share/locale/ru/LC_MESSAGES/gxine.theme.mo
+share/locale/sv/LC_MESSAGES/gxine.mo
+share/locale/sv/LC_MESSAGES/gxine.theme.mo
+share/locale/uk/LC_MESSAGES/gxine.mo
+share/locale/uk/LC_MESSAGES/gxine.theme.mo
+share/locale/zh_CN/LC_MESSAGES/gxine.mo
+share/locale/zh_CN/LC_MESSAGES/gxine.theme.mo
share/pixmaps/gxine.png
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
@@ -58,4 +59,4 @@ share/pixmaps/gxine.png
@dirrmtry man/de
@dirrm lib/gxine
%%MOZILLA_PLUGIN%%@dirrmtry lib/browser_plugins
-@dirrm etc/gxine
+@dirrm %%ETCDIR%%