aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-03-22 10:07:32 +0800
committercpm <cpm@FreeBSD.org>2016-03-22 10:07:32 +0800
commit0dcc89a10fe74aa044b9d07091f83d4e84fda786 (patch)
tree1afd7bc0de5bd9f2d599079ce343df60ce3eb155 /multimedia
parent4135f48278f6239f7be99cf1941d52f5531a2f1f (diff)
downloadfreebsd-ports-gnome-0dcc89a10fe74aa044b9d07091f83d4e84fda786.tar.gz
freebsd-ports-gnome-0dcc89a10fe74aa044b9d07091f83d4e84fda786.tar.zst
freebsd-ports-gnome-0dcc89a10fe74aa044b9d07091f83d4e84fda786.zip
- Convert to USES=python:3,build
- Fix SIGSEGV with FFmpeg (reported by soralx@cydem.org) - Update MAINTAINER to my @FreeBSD.org address - Bump PORTREVISION PR: 208080 Approved by: junovitch (mentor)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer2/Makefile9
-rw-r--r--multimedia/mplayer2/files/patch-libmpdemux_demux__lavf.c18
2 files changed, 22 insertions, 5 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index 77b7b87af28b..b0ae0f940026 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -2,11 +2,11 @@
PORTNAME= mplayer2
PORTVERSION= ${MPLAYER2_PORT_VERSION}
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= multimedia audio
MASTER_SITES= LOCAL/gblach/
-MAINTAINER= cpm@fbsd.es
+MAINTAINER= cpm@FreeBSD.org
COMMENT= Advanced general-purpose video player
LICENSE= GPLv2
@@ -14,10 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-BUILD_DEPENDS= python3:${PORTSDIR}/lang/python3 \
- rst2man:${PORTSDIR}/textproc/py-docutils
+BUILD_DEPENDS= rst2man:${PORTSDIR}/textproc/py-docutils
-USES= cpe gmake iconv ncurses pkgconfig tar:xz
+USES= cpe gmake iconv ncurses pkgconfig python:3,build tar:xz
HAS_CONFIGURE= yes
CONFIGURE_ENV= TMPDIR="${WRKSRC}"
CONFIGURE_ARGS= --cc=${CC} \
diff --git a/multimedia/mplayer2/files/patch-libmpdemux_demux__lavf.c b/multimedia/mplayer2/files/patch-libmpdemux_demux__lavf.c
new file mode 100644
index 000000000000..ab16b8863f3d
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-libmpdemux_demux__lavf.c
@@ -0,0 +1,18 @@
+--- libmpdemux/demux_lavf.c.orig 2016-03-16 10:57:42 UTC
++++ libmpdemux/demux_lavf.c
+@@ -159,6 +159,7 @@ static int lavf_check_file(demuxer_t *de
+ int probe_data_size = 0;
+ int read_size = INITIAL_PROBE_SIZE;
+ int score;
++ char mime[] = "";
+
+ if (!demuxer->priv)
+ demuxer->priv = calloc(sizeof(lavf_priv_t), 1);
+@@ -203,6 +204,7 @@ static int lavf_check_file(demuxer_t *de
+ avpd.buf_size = probe_data_size;
+
+ score = 0;
++ avpd.mime_type = mime;
+ priv->avif = av_probe_input_format2(&avpd, probe_data_size > 0, &score);
+ read_size = FFMIN(2 * read_size, PROBE_BUF_SIZE - probe_data_size);
+ } while ((demuxer->desc->type != DEMUXER_TYPE_LAVF_PREFERRED ||