aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2009-03-25 00:58:56 +0800
committermm <mm@FreeBSD.org>2009-03-25 00:58:56 +0800
commit0ec1cc09cb2f9d2d74fe56c35cc9b32118d792d7 (patch)
tree0adecc85a6070827f0a7d9ee7526f62af9133547 /multimedia
parentee759ea69785cdd40583e0145bcfef66ac2c9357 (diff)
downloadfreebsd-ports-gnome-0ec1cc09cb2f9d2d74fe56c35cc9b32118d792d7.tar.gz
freebsd-ports-gnome-0ec1cc09cb2f9d2d74fe56c35cc9b32118d792d7.tar.zst
freebsd-ports-gnome-0ec1cc09cb2f9d2d74fe56c35cc9b32118d792d7.zip
- Add MAKE_JOBS_SAFE to support SMP compilation
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile1
-rw-r--r--multimedia/gpac-libgpac/Makefile1
-rw-r--r--multimedia/libtheora/Makefile1
-rw-r--r--multimedia/mp4v2/Makefile1
-rw-r--r--multimedia/mpeg4ip-libmp4v2/Makefile1
5 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 1bf86fd9d34e..312187fc5a42 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -19,6 +19,7 @@ HAS_CONFIGURE= yes
CONFIGURE_LOG= config.err
USE_BZIP2= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
WANT_SDL= yes
OPTIONS= AMR_NB "AMR narrowband encoder" off \
diff --git a/multimedia/gpac-libgpac/Makefile b/multimedia/gpac-libgpac/Makefile
index 990d28a2dcc3..362ce8f98792 100644
--- a/multimedia/gpac-libgpac/Makefile
+++ b/multimedia/gpac-libgpac/Makefile
@@ -20,6 +20,7 @@ COMMENT= Gpac MPEG-4 Systems library and headers
WRKSRC= ${WRKDIR}/gpac
ALL_TARGET= lib
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/multimedia/libtheora/Makefile b/multimedia/libtheora/Makefile
index e7d494c70d73..3312ab4b8ed7 100644
--- a/multimedia/libtheora/Makefile
+++ b/multimedia/libtheora/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= ltverhack
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
diff --git a/multimedia/mp4v2/Makefile b/multimedia/mp4v2/Makefile
index c4542795fbf0..b238507153f8 100644
--- a/multimedia/mp4v2/Makefile
+++ b/multimedia/mp4v2/Makefile
@@ -19,6 +19,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/multimedia/mpeg4ip-libmp4v2/Makefile b/multimedia/mpeg4ip-libmp4v2/Makefile
index c4542795fbf0..b238507153f8 100644
--- a/multimedia/mpeg4ip-libmp4v2/Makefile
+++ b/multimedia/mpeg4ip-libmp4v2/Makefile
@@ -19,6 +19,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \