aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-12-24 03:01:22 +0800
committerpawel <pawel@FreeBSD.org>2015-12-24 03:01:22 +0800
commit15317a7c99c231ea41c1881d532916ce7f57df12 (patch)
tree0b7a0c211f0a381e5223a5574c538a35d3fa0a6c /multimedia
parent7453e4177d1a1c51c78d1166201b30e2948ef3f6 (diff)
downloadfreebsd-ports-gnome-15317a7c99c231ea41c1881d532916ce7f57df12.tar.gz
freebsd-ports-gnome-15317a7c99c231ea41c1881d532916ce7f57df12.tar.zst
freebsd-ports-gnome-15317a7c99c231ea41c1881d532916ce7f57df12.zip
- Update to version 2.4.6
- Convert to USES=localbase - Remove -pthread from LDFLAGS, configure script detects it just fine - Patch configure to not detect it's own libweed installed on system allowing now correctly upgrading lives through ports Changelog: Fix crashes and compatibility issues with gtk+ >= 3.16 Fix a bug with missing clips when reloading layouts. Minor GUI improvements. Minor compilation fixes. Updates to French translation (thanks Jean-Marc).
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/lives/Makefile18
-rw-r--r--multimedia/lives/distinfo4
-rw-r--r--multimedia/lives/files/patch-configure42
3 files changed, 49 insertions, 15 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 03ba2c2b3f07..bbee0bf2c736 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.4.5
+PORTVERSION= 2.4.6
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -39,10 +39,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa \
x264:${PORTSDIR}/multimedia/x264 \
cdrecord:${PORTSDIR}/sysutils/cdrtools
-WRKSRC= ${WRKDIR}/${DISTNAME:tl}
-
-USES= ghostscript:run libtool pathfix perl5 pkgconfig python \
- shebangfix tar:bzip2
+USES= ghostscript:run libtool localbase pathfix perl5 pkgconfig \
+ python shebangfix tar:bzip2
SHEBANG_FILES= build-lives-rfx-plugin build-lives-rfx-plugin-multi \
smogrify tools/autolives.pl lives-plugins/plugins/encoders/*_encoder \
lives-plugins/plugins/playback/audiostream/audiostreamer.pl
@@ -54,8 +52,7 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-ldvgrab
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include -fPIC
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+CPPFLAGS+= -fPIC
DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
OMC/lives-OMC.txt RFX/LiVES-Perl.odt RFX/rfxbuilder.odt \
@@ -78,8 +75,6 @@ NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${perl_CMD}|' \
- ${WRKSRC}/build-lives-rfx-plugin
@${REINPLACE_CMD} -e 's| install-docDATA||g; s|-$$(VERSION)||g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|: install-data-local |: |g; s|-ldl||' \
@@ -93,10 +88,7 @@ post-patch:
@${REINPLACE_CMD} '/selectRandom/d' \
${WRKSRC}/lives-plugins/weed-plugins/projectM.cpp
-pre-build-NLS-on:
- @cd ${WRKSRC}/po && ${DO_MAKE_BUILD} update-po
-
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/multimedia/lives/distinfo b/multimedia/lives/distinfo
index 95a307880e74..15563d18250d 100644
--- a/multimedia/lives/distinfo
+++ b/multimedia/lives/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lives-2.4.5.tar.bz2) = d425fe8358915759cb40c9952b6214a23819c4f17df034c347b7ea92d8377ea6
-SIZE (lives-2.4.5.tar.bz2) = 3770985
+SHA256 (lives-2.4.6.tar.bz2) = 9af17c28142fe2d42ab73cfb8e7cd3ca5203a5b62af057b2ea50ecd11b4fa011
+SIZE (lives-2.4.6.tar.bz2) = 3808210
diff --git a/multimedia/lives/files/patch-configure b/multimedia/lives/files/patch-configure
new file mode 100644
index 000000000000..2f1a306d4549
--- /dev/null
+++ b/multimedia/lives/files/patch-configure
@@ -0,0 +1,42 @@
+--- configure.orig 2015-12-23 17:59:14 UTC
++++ configure
+@@ -28352,7 +28352,6 @@ if test -n "$WEED_CFLAGS"; then
+ test $ac_status = 0; }; then
+ pkg_cv_WEED_CFLAGS=`$PKG_CONFIG --cflags "libweed >= 0.8.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+-else
+ pkg_failed=yes
+ fi
+ else
+@@ -28441,7 +28440,6 @@ if test -n "$WEED_SLICE_CFLAGS"; then
+ test $ac_status = 0; }; then
+ pkg_cv_WEED_SLICE_CFLAGS=`$PKG_CONFIG --cflags "libweed_slice >= 0.8.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+-else
+ pkg_failed=yes
+ fi
+ else
+@@ -28531,7 +28529,6 @@ if test -n "$WEED_UTILS_CFLAGS"; then
+ test $ac_status = 0; }; then
+ pkg_cv_WEED_UTILS_CFLAGS=`$PKG_CONFIG --cflags "libweed-utils >= 0.8.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+-else
+ pkg_failed=yes
+ fi
+ else
+@@ -28620,7 +28617,6 @@ if test -n "$WEED_COMPAT_CFLAGS"; then
+ test $ac_status = 0; }; then
+ pkg_cv_WEED_COMPAT_CFLAGS=`$PKG_CONFIG --cflags "libweed-compat >= 0.9.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+-else
+ pkg_failed=yes
+ fi
+ else
+@@ -28709,7 +28705,6 @@ if test -n "$WEED_PLUGIN_CFLAGS"; then
+ test $ac_status = 0; }; then
+ pkg_cv_WEED_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "libweed-plugin >= 0.13.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+-else
+ pkg_failed=yes
+ fi
+ else